~ubuntu-branches/ubuntu/raring/konversation/raring

« back to all changes in this revision

Viewing changes to debian/patches/debian-changes-1.3.1-1ubuntu2

  • Committer: Bazaar Package Importer
  • Author(s): Jonathan Riddell
  • Date: 2010-08-12 10:48:48 UTC
  • Revision ID: james.westby@ubuntu.com-20100812104848-rddr7mdhfcs31p39
Tags: 1.3.1-1ubuntu3
Remove debian-changes-1.3.1-1ubuntu2 which reverted the other
patches

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Upstream changes introduced in version 1.3.1-1ubuntu2
2
 
 This patch has been created by dpkg-source during the package build.
3
 
 Here's the last changelog entry, hopefully it gives details on why
4
 
 those changes were made:
5
 
 .
6
 
 konversation (1.3.1-1ubuntu2) maverick; urgency=low
7
 
 .
8
 
   * Add back correct debian/patches/series file, adds back in
9
 
     kubuntu_01_default_channels.diff message-indicator/0001-Adds-
10
 
     support-for-Message-Indicator.diff LP: #616422
11
 
   * Remove obsolete debian/patches/kubuntu/ directory
12
 
 .
13
 
 The person named in the Author field signed this changelog entry.
14
 
Author: Jonathan Riddell <jriddell@ubuntu.com>
15
 
Bug-Ubuntu: https://bugs.launchpad.net/bugs/616422
16
 
 
17
 
---
18
 
The information above should follow the Patch Tagging Guidelines, please
19
 
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
20
 
are templates for supplementary fields that you might want to add:
21
 
 
22
 
Origin: <vendor|upstream|other>, <url of original patch>
23
 
Bug: <url in upstream bugtracker>
24
 
Bug-Debian: http://bugs.debian.org/<bugnumber>
25
 
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
26
 
Forwarded: <no|not-needed|url proving that it has been forwarded>
27
 
Reviewed-By: <name and email of someone who approved the patch>
28
 
Last-Update: <YYYY-MM-DD>
29
 
 
30
 
--- konversation-1.3.1.orig/config-konversation.h.cmake
31
 
+++ konversation-1.3.1/config-konversation.h.cmake
32
 
@@ -6,5 +6,4 @@
33
 
 #cmakedefine HAVE_STROPTS_H 1
34
 
 #cmakedefine HAVE_SYS_ENDIAN_H 1
35
 
 #cmakedefine HAVE_BYTESWAP_H 1
36
 
-#cmakedefine HAVE_KIDLETIME 1
37
 
-#cmakedefine HAVE_INDICATEQT 1
38
 
+#cmakedefine HAVE_KIDLETIME 1
39
 
\ No newline at end of file
40
 
--- konversation-1.3.1.orig/CMakeLists.txt
41
 
+++ konversation-1.3.1/CMakeLists.txt
42
 
@@ -7,7 +7,6 @@ set(KDE_MIN_VERSION "4.3.0")
43
 
 #atm this gets us FindQt4 and FindX11 (provided that the default cmake FindQt4 doesn't get used)
44
 
 find_package(KDE4 ${KDE_MIN_VERSION} REQUIRED)
45
 
 find_package(KdepimLibs REQUIRED)
46
 
-find_package(PkgConfig REQUIRED)
47
 
 include(KDE4Defaults)
48
 
 include(MacroLibrary)
49
 
 include(CheckIncludeFile)
50
 
@@ -54,10 +53,6 @@ macro_optional_find_package(QCA2)
51
 
 macro_bool_to_01(QCA2_FOUND HAVE_QCA2)
52
 
 macro_log_feature(QCA2_FOUND "QCA" "Qt Cryptographic Architecture" "http://delta.affinix.com/qca" FALSE "2.0.0" "Required for using encryption in IRC")
53
 
 
54
 
-pkg_check_modules(INDICATEQT indicate-qt>=0.2.2)
55
 
-macro_bool_to_01(INDICATEQT_FOUND HAVE_INDICATEQT)
56
 
-macro_log_feature(INDICATEQT_FOUND "libindicate-qt" "Qt binding for libindicate" "http://launchpad.net/libindicate-qt" FALSE "" "Support for message indicator")
57
 
-
58
 
 #define the value for HAVE_KSTATUSNOTIFIERITEM
59
 
 macro_bool_to_01(HAVEKDE4_4 HAVE_KSTATUSNOTIFIERITEM)
60
 
 
61
 
--- konversation-1.3.1.orig/src/notificationhandler.cpp
62
 
+++ konversation-1.3.1/src/notificationhandler.cpp
63
 
@@ -18,27 +18,11 @@
64
 
 #include "viewcontainer.h"
65
 
 #include "trayicon.h"
66
 
 #include "server.h"
67
 
-#include "config-konversation.h"
68
 
 
69
 
 #include <QTextDocument>
70
 
 
71
 
 #include <KNotification>
72
 
-#include <KWindowSystem>
73
 
 
74
 
-#ifdef HAVE_INDICATEQT
75
 
-#include <qindicateindicator.h>
76
 
-#include <qindicateserver.h>
77
 
-
78
 
-class Indicator : public QIndicate::Indicator
79
 
-{
80
 
-    public:
81
 
-        Indicator(QIndicate::Server* server)
82
 
-        : QIndicate::Indicator(server)
83
 
-        {}
84
 
-
85
 
-        QPointer<ChatWindow> m_chatWin;
86
 
-};
87
 
-#endif
88
 
 
89
 
 namespace Konversation
90
 
 {
91
 
@@ -47,23 +31,6 @@ namespace Konversation
92
 
         : QObject(parent)
93
 
     {
94
 
         m_mainWindow = parent->getMainWindow();
95
 
-        #ifdef HAVE_INDICATEQT
96
 
-        m_indicateServer = QIndicate::Server::defaultInstance();
97
 
-        m_indicateServer->setType("message.irc");
98
 
-        QString appName = KGlobal::mainComponent().componentName();
99
 
-        KService::Ptr service = KService::serviceByDesktopName(appName);
100
 
-        if (service) {
101
 
-            m_indicateServer->setDesktopFile(service->entryPath());
102
 
-        } else {
103
 
-            kWarning() << "Could not find desktop file for application";
104
 
-        }
105
 
-        connect(m_indicateServer, SIGNAL(serverDisplay()),
106
 
-            SLOT(slotIndicateServerDisplay()));
107
 
-        updateIndicateServer();
108
 
-        m_mainWindow->installEventFilter(this);
109
 
-        connect(Preferences::self(), SIGNAL(configChanged()),
110
 
-            SLOT(updateIndicateServer()));
111
 
-        #endif
112
 
     }
113
 
 
114
 
     NotificationHandler::~NotificationHandler()
115
 
@@ -75,9 +42,6 @@ namespace Konversation
116
 
         if (!chatWin || !chatWin->notificationsEnabled())
117
 
             return;
118
 
 
119
 
-        if (Preferences::self()->messageIndicatorShowChannel())
120
 
-            addIndicator(chatWin, fromNick);
121
 
-
122
 
         if (Preferences::self()->disableNotifyWhileAway() && chatWin->getServer() && chatWin->getServer()->isAway())
123
 
             return;
124
 
 
125
 
@@ -106,9 +70,6 @@ namespace Konversation
126
 
         if (!chatWin || !chatWin->notificationsEnabled())
127
 
             return;
128
 
 
129
 
-        if (Preferences::self()->messageIndicatorShowOwnNick())
130
 
-            addIndicator(chatWin, fromNick);
131
 
-
132
 
         if (Preferences::self()->disableNotifyWhileAway() && chatWin->getServer() && chatWin->getServer()->isAway())
133
 
             return;
134
 
 
135
 
@@ -135,9 +96,6 @@ namespace Konversation
136
 
         if (!chatWin || !chatWin->notificationsEnabled())
137
 
             return;
138
 
 
139
 
-        if (Preferences::self()->messageIndicatorShowQuery())
140
 
-            addIndicator(chatWin, fromNick);
141
 
-
142
 
         if (Preferences::self()->disableNotifyWhileAway() && chatWin->getServer() && chatWin->getServer()->isAway())
143
 
             return;
144
 
 
145
 
@@ -400,105 +358,6 @@ namespace Konversation
146
 
         KNotification::event(QString::fromLatin1("channelJoin"), i18n("You have joined %1.",channel), QPixmap(), m_mainWindow);
147
 
     }
148
 
 
149
 
-    void NotificationHandler::addIndicator(ChatWindow* chatWin, const QString& nick)
150
 
-    {
151
 
-        #ifdef HAVE_INDICATEQT
152
 
-        ViewContainer* viewContainer = m_mainWindow->getViewContainer();
153
 
-        if (m_mainWindow->isActiveWindow() && chatWin == viewContainer->getFrontView()) {
154
 
-            // Do not show indicator if the user is already using this chat
155
 
-            // window
156
 
-            return;
157
 
-        }
158
 
-        Indicator* indicator = m_indicatorForChatWindow.value(chatWin);
159
 
-        if (!indicator) {
160
 
-            indicator = new Indicator(m_indicateServer);
161
 
-            indicator->m_chatWin = chatWin;
162
 
-            m_indicatorForChatWindow.insert(chatWin, indicator);
163
 
-            connect(chatWin, SIGNAL(closing(ChatWindow*)), SLOT(deleteIndicatorForChatWindow(ChatWindow*)));
164
 
-            connect(viewContainer, SIGNAL(viewChanged(ChatWindow*)), SLOT(deleteIndicatorForChatWindow(ChatWindow*)));
165
 
-
166
 
-            connect(indicator, SIGNAL(display(QIndicate::Indicator*)), SLOT(slotIndicatorDisplay(QIndicate::Indicator*)));
167
 
-            indicator->show();
168
 
-        }
169
 
-        QString name;
170
 
-        if (chatWin->getType() == ChatWindow::Query) {
171
 
-            name = nick;
172
 
-        } else {
173
 
-            name = QString("%1 (%2)").arg(chatWin->getName()).arg(nick);
174
 
-        }
175
 
-        indicator->setNameProperty(name);
176
 
-        indicator->setTimeProperty(QDateTime::currentDateTime());
177
 
-        indicator->setDrawAttentionProperty(true);
178
 
-        #else
179
 
-        Q_UNUSED(chatWin);
180
 
-        Q_UNUSED(nick);
181
 
-        #endif
182
 
-    }
183
 
-
184
 
-    void NotificationHandler::slotIndicatorDisplay(QIndicate::Indicator* _indicator)
185
 
-    {
186
 
-        #ifdef HAVE_INDICATEQT
187
 
-        Indicator* indicator = static_cast<Indicator*>(_indicator);
188
 
-        ChatWindow* chatWin = indicator->m_chatWin;
189
 
-        m_indicatorForChatWindow.remove(chatWin);
190
 
-        delete indicator;
191
 
-
192
 
-        m_mainWindow->show();
193
 
-        KWindowSystem::forceActiveWindow(m_mainWindow->winId());
194
 
-        if (chatWin) {
195
 
-            m_mainWindow->getViewContainer()->showView(chatWin);
196
 
-            chatWin->adjustFocus();
197
 
-        }
198
 
-        #else
199
 
-        Q_UNUSED(_indicator);
200
 
-        #endif
201
 
-    }
202
 
-
203
 
-    void NotificationHandler::slotIndicateServerDisplay()
204
 
-    {
205
 
-        m_mainWindow->show();
206
 
-        KWindowSystem::forceActiveWindow(m_mainWindow->winId());
207
 
-    }
208
 
-
209
 
-    void NotificationHandler::deleteIndicatorForChatWindow(ChatWindow* chatWin)
210
 
-    {
211
 
-        #ifdef HAVE_INDICATEQT
212
 
-        delete m_indicatorForChatWindow.take(chatWin);
213
 
-        #else
214
 
-        Q_UNUSED(chatWin);
215
 
-        #endif
216
 
-    }
217
 
-
218
 
-    bool NotificationHandler::eventFilter(QObject*, QEvent* event)
219
 
-    {
220
 
-        #ifdef HAVE_INDICATEQT
221
 
-        if (event->type() == QEvent::WindowActivate) {
222
 
-            ViewContainer* viewContainer = m_mainWindow->getViewContainer();
223
 
-            QPointer<ChatWindow> chatWin = viewContainer->getFrontView();
224
 
-            if (chatWin) {
225
 
-                deleteIndicatorForChatWindow(chatWin);
226
 
-            }
227
 
-        }
228
 
-        #else
229
 
-        Q_UNUSED(event);
230
 
-        #endif
231
 
-        return false;
232
 
-    }
233
 
-
234
 
-    void NotificationHandler::updateIndicateServer()
235
 
-    {
236
 
-        #ifdef HAVE_INDICATEQT
237
 
-        bool needServer = Preferences::self()->messageIndicatorShowOwnNick()
238
 
-            || Preferences::self()->messageIndicatorShowChannel()
239
 
-            || Preferences::self()->messageIndicatorShowQuery();
240
 
-
241
 
-        if (needServer) {
242
 
-            m_indicateServer->show();
243
 
-        } else {
244
 
-            m_indicateServer->hide();
245
 
-        }
246
 
-        #endif
247
 
-    }
248
 
 }
249
 
 
250
 
 #include "notificationhandler.moc"
251
 
--- konversation-1.3.1.orig/src/notificationhandler.h
252
 
+++ konversation-1.3.1/src/notificationhandler.h
253
 
@@ -12,7 +12,6 @@
254
 
 #ifndef KONVERSATIONNOTIFICATIONHANDLER_H
255
 
 #define KONVERSATIONNOTIFICATIONHANDLER_H
256
 
 
257
 
-#include <QHash>
258
 
 #include <QObject>
259
 
 
260
 
 
261
 
@@ -20,15 +19,9 @@ class ChatWindow;
262
 
 class Application;
263
 
 class MainWindow;
264
 
 
265
 
-namespace QIndicate
266
 
-{
267
 
-    class Server;
268
 
-    class Indicator;
269
 
-}
270
 
-class Indicator;
271
 
-
272
 
 namespace Konversation
273
 
 {
274
 
+
275
 
     class NotificationHandler : public QObject
276
 
     {
277
 
         Q_OBJECT
278
 
@@ -60,20 +53,9 @@ namespace Konversation
279
 
 
280
 
         protected:
281
 
             void startTrayNotification(ChatWindow* chatWin);
282
 
-            virtual bool eventFilter(QObject*, QEvent*);
283
 
-
284
 
-        private slots:
285
 
-            void updateIndicateServer();
286
 
-            void slotIndicatorDisplay(QIndicate::Indicator*);
287
 
-            void slotIndicateServerDisplay();
288
 
-            void deleteIndicatorForChatWindow(ChatWindow*);
289
 
 
290
 
         private:
291
 
             MainWindow* m_mainWindow;
292
 
-            QIndicate::Server* m_indicateServer;
293
 
-            QHash<ChatWindow*, Indicator*> m_indicatorForChatWindow;
294
 
-
295
 
-            void addIndicator(ChatWindow*, const QString& nick);
296
 
     };
297
 
 
298
 
 }
299
 
--- konversation-1.3.1.orig/src/CMakeLists.txt
300
 
+++ konversation-1.3.1/src/CMakeLists.txt
301
 
@@ -126,7 +126,6 @@ kde4_add_ui_files(config_SRCS
302
 
     config/theme_configui.ui
303
 
     config/warnings_configui.ui
304
 
     config/watchednicknames_configui.ui
305
 
-    config/messageindicator_config.ui
306
 
 )
307
 
 
308
 
     #=== Viewer
309
 
@@ -207,11 +206,6 @@ if (QCA2_FOUND)
310
 
         cipher.cpp)
311
 
 endif (QCA2_FOUND)
312
 
 
313
 
-if (INDICATEQT_FOUND)
314
 
-    include_directories(${INDICATEQT_INCLUDE_DIRS})
315
 
-    link_directories(${INDICATEQT_LIBRARY_DIRS})
316
 
-endif (INDICATEQT_FOUND)
317
 
-
318
 
 set(upnp_SRCS
319
 
     upnp/soap.cpp
320
 
     upnp/upnpdescriptionparser.cpp
321
 
@@ -252,8 +246,7 @@ kde4_add_executable(konversation ${konve
322
 
 
323
 
 target_link_libraries(konversation ${KDE4_KIO_LIBS} ${KDE4_KUTILS_LIBS} ${KDE4_KPARTS_LIBS}
324
 
                             ${KDE4_KDE3SUPPORT_LIBS} ${KDE4_KABC_LIBS}
325
 
-                            ${KDE4_KNOTIFYCONFIG_LIBRARY} ${PHONON_LIBRARY} ${KDE4_SOLID_LIBS}
326
 
-                            ${INDICATEQT_LIBRARIES})
327
 
+                            ${KDE4_KNOTIFYCONFIG_LIBRARY} ${PHONON_LIBRARY} ${KDE4_SOLID_LIBS})
328
 
 
329
 
 if (X11_FOUND AND X11_Xutil_FOUND)
330
 
     target_link_libraries(konversation ${X11_X11_LIB})
331
 
--- konversation-1.3.1.orig/src/config/settingsdialog.cpp
332
 
+++ konversation-1.3.1/src/config/settingsdialog.cpp
333
 
@@ -10,7 +10,6 @@
334
 
   Copyright (C) 2006 Eike Hein <hein@kde.org>
335
 
 */
336
 
 
337
 
-#include "config-konversation.h"
338
 
 #include "settingsdialog.h"
339
 
 #include "configdialog.h"
340
 
 #include "preferences.h"
341
 
@@ -37,10 +36,6 @@
342
 
 
343
 
 #include <config-konversation.h>
344
 
 
345
 
-#ifdef HAVE_INDICATEQT
346
 
-#include "ui_messageindicator_config.h"
347
 
-#endif
348
 
-
349
 
 
350
 
 KonviSettingsDialog::KonviSettingsDialog( QWidget *parent) :
351
 
     KonviConfigDialog( parent, "settings", Preferences::self(), KPageDialog::Tree)
352
 
@@ -184,14 +179,6 @@ KonviSettingsDialog::KonviSettingsDialog
353
 
   //no modified connection needed - it's all kcfg widgets
354
 
   m_pages.append(m_confOSDWdg);
355
 
 
356
 
-  #ifdef HAVE_INDICATEQT
357
 
-  //Notification/Message Indicator
358
 
-  Ui::MessageIndicator_Config confMessageIndicator;
359
 
-  w = new QWidget();
360
 
-  confMessageIndicator.setupUi(w);
361
 
-  addPage(w, notificationGroup, "mail-unread-new", i18n("Message Indicator"));
362
 
-  #endif
363
 
-
364
 
   //Notification/Warning Dialogs
365
 
   m_confWarningsWdg = new Warnings_Config( this, "Warnings" );
366
 
   addPage ( m_confWarningsWdg, notificationGroup, "dialog-warning", i18n("Warning Dialogs") );
367
 
--- konversation-1.3.1.orig/src/config/preferences.cpp
368
 
+++ konversation-1.3.1/src/config/preferences.cpp
369
 
@@ -61,14 +61,16 @@ Preferences::Preferences()
370
 
     mIdentity->setNicknameList(nickList);
371
 
 
372
 
     Konversation::ServerGroupSettingsPtr serverGroup(new Konversation::ServerGroupSettings);
373
 
-    serverGroup->setName("Ubuntu IRC");
374
 
+    serverGroup->setName("Debian IRC");
375
 
     Konversation::ServerSettings server;
376
 
-    server.setHost("irc.ubuntu.com");
377
 
-    server.setPort(8001);
378
 
+    server.setHost("irc.debian.org");
379
 
+    server.setPort(7000);
380
 
     serverGroup->addServer(server);
381
 
     serverGroup->setIdentityId(mIdentity->id());
382
 
     Konversation::ChannelSettings channel;
383
 
-    channel.setName("#kubuntu");
384
 
+    channel.setName("#debian");
385
 
+    serverGroup->addChannel(channel);
386
 
+    channel.setName("#debian-kde");
387
 
     serverGroup->addChannel(channel);
388
 
     serverGroup->setExpanded(false);
389
 
     mServerGroupHash.insert(0, serverGroup);
390
 
--- konversation-1.3.1.orig/src/config/konversation.kcfg
391
 
+++ konversation-1.3.1/src/config/konversation.kcfg
392
 
@@ -518,23 +518,6 @@
393
 
       <whatsthis></whatsthis>
394
 
     </entry>
395
 
   </group>
396
 
-  <group name="MessageIndicator">
397
 
-    <entry key="MessageIndicatorShowOwnNick" type="Bool">
398
 
-      <default>true</default>
399
 
-      <label></label>
400
 
-      <whatsthis></whatsthis>
401
 
-    </entry>
402
 
-    <entry key="MessageIndicatorShowChannel" type="Bool">
403
 
-      <default>false</default>
404
 
-      <label></label>
405
 
-      <whatsthis></whatsthis>
406
 
-    </entry>
407
 
-    <entry key="MessageIndicatorShowQuery" type="Bool">
408
 
-      <default>true</default>
409
 
-      <label></label>
410
 
-      <whatsthis></whatsthis>
411
 
-    </entry>
412
 
-  </group>
413
 
   <group name="Notify List">
414
 
     <entry key="NotifyDelay" type="Int">
415
 
       <default>20</default>