~ubuntu-branches/ubuntu/raring/kvirc/raring

« back to all changes in this revision

Viewing changes to debian/patches/00_hardening_upstream.patch

  • Committer: Package Import Robot
  • Author(s): Raúl Sánchez Siles
  • Date: 2012-07-19 21:56:08 UTC
  • mfrom: (22.1.3 sid)
  • Revision ID: package-import@ubuntu.com-20120719215608-gwlu1pzkkm9wxsyz
Tags: 4:4.1.3+20111124.svn5988-2
* Updated debhelper build-depends to better cope with multiarch.
* Fix "must not be "Multi-Arch: same"" kvirc is Multi-Arch: foreign
  (Closes: #658058)
* Actually provide valid -dbg package. Added 30_upstream_build-g
* Fix "Hardening flags missing". Applying suggested changes.
  (Closes: #669189) Thanks to Simon Ruderich.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Use build flags from environment (dpkg-buildflags).
 
2
 Necessary for hardening flags.
 
3
Author: Simon Ruderich <simon@ruderich.org>
 
4
Last-Update: 2012-04-17
 
5
 
 
6
--- kvirc-4.1.3+20111124.svn5988.orig/CMakeLists.txt
 
7
+++ kvirc-4.1.3+20111124.svn5988/CMakeLists.txt
 
8
@@ -220,8 +220,8 @@ ELSE()
 
9
                ENDIF()
 
10
                IF(CMAKE_COMPILER_IS_GNUCXX)
 
11
                        #force gdb options
 
12
-                       SET(CMAKE_CXX_FLAGS "-O3 -fomit-frame-pointer -DNDEBUG --no-enforce-eh-specs -pipe --exec-charset=UTF-8 --input-charset=UTF-8 --no-implement-inlines --unit-at-a-time --fast-math")
 
13
-                       SET(CMAKE_C_FLAGS "-O3 -fomit-frame-pointer -DNDEBUG --no-enforce-eh-specs -pipe --exec-charset=UTF-8 --input-charset=UTF-8 --no-implement-inlines --unit-at-a-time --fast-math")
 
14
+                       SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O3 -fomit-frame-pointer -DNDEBUG --no-enforce-eh-specs -pipe --exec-charset=UTF-8 --input-charset=UTF-8 --no-implement-inlines --unit-at-a-time --fast-math")
 
15
+                       SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O3 -fomit-frame-pointer -DNDEBUG --no-enforce-eh-specs -pipe --exec-charset=UTF-8 --input-charset=UTF-8 --no-implement-inlines --unit-at-a-time --fast-math")
 
16
                        INCLUDE(CheckCXXCompilerFlag)
 
17
                        CHECK_CXX_COMPILER_FLAG("-fvisibility-inlines-hidden" CXX_HAS_VIH_FLAG)
 
18
                        #gcc doesn't support visibility on PE/win32