~ubuntu-branches/ubuntu/raring/libdvdread/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/07-segfault.patch

  • Committer: Package Import Robot
  • Author(s): Vibhav Pant
  • Date: 2012-12-15 17:06:42 UTC
  • mfrom: (1.3.2) (3.2.15 sid)
  • Revision ID: package-import@ubuntu.com-20121215170642-q0h4cc4r2mchkgcl
Tags: 4.2.0+20121016-1ubuntu1
* Merge from Debian unstable (LP: #1090692).  Remaining changes:
  - Re-add missing install-css.sh.
  - debian/control: add Suggests for install-css.sh on debhelper,
    fakeroot, and build-essential.
  - debian/rules: install install-css.sh, leave perms executable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Peter Van Eynde <pvaneynd@debian.org>
 
2
Description: Fix miscompilation leading to a segfault (Closes: #688574).
 
3
 
 
4
diff -Naurp libdvdread.orig/src/dvd_reader.c libdvdread/src/dvd_reader.c
 
5
--- libdvdread.orig/src/dvd_reader.c    2012-09-24 16:55:49.681245164 +0200
 
6
+++ libdvdread/src/dvd_reader.c 2012-09-24 16:56:06.845356530 +0200
 
7
@@ -30,6 +30,7 @@
 
8
 #include <string.h>
 
9
 #include <ctype.h>
 
10
 #define _GNU_SOURCE
 
11
+#define __USE_GNU
 
12
 #include <unistd.h>
 
13
 #include <limits.h>
 
14
 #include <dirent.h>