~ubuntu-branches/ubuntu/raring/maas/raring-updates

« back to all changes in this revision

Viewing changes to debian/patches/99_enums_js.patch

  • Committer: Package Import Robot
  • Author(s): Andres Rodriguez
  • Date: 2012-07-03 17:42:37 UTC
  • mfrom: (1.1.13)
  • Revision ID: package-import@ubuntu.com-20120703174237-p8l0keuuznfg721k
Tags: 0.1+bzr709+dfsg-0ubuntu1
* New Upstream release
* debian/control:
  - Depends on python-celery, python-tempita, libjs-yui3-{full,min},
    libjs-raphael
* debian/maas.install:
  - Install apiclient, celeryconfig.py, maas-import-pxe-files, preseeds_v2.
  - Update to install various files from chroot, rather tha manually copy
    them from the source.
* debian/maas.links: symlink celeryconfig.py
* debian/maas.maas-celery.upstart: Add job.
* debian/rules:
  - Install celery upstart job.
  - Do not install jslibs as packages are now used.
  - Drop copying of maas_local_settings_sample.py as source now ships
    a maas_local_settings.py
* debian/patches:
  - 04-maas-http-fix.patch: Drop. Merged upstream.
  - 01-fix-database-settings.patch: Refreshed.
  - 99_enums_js.patch: Added until creation of enum.js / build process
    is fixed.
* debian/maas.postinst: Update bzr version to correctly handle upgrades.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: maas-0.1+bzr697+dfsg.orig/src/maasserver/static/js/enums.js
 
2
===================================================================
 
3
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
4
+++ maas-0.1+bzr697+dfsg.orig/src/maasserver/static/js/enums.js 2012-06-28 13:19:34.160274629 -0400
 
5
@@ -0,0 +1,63 @@
 
6
+/*
 
7
+Generated file.  DO NOT EDIT.
 
8
+
 
9
+This file was generated by /home/roaksoax/Desktop/project/maas-whole/maas/src/maasserver/utils/jsenums.py,
 
10
+on 2012-06-28 12:59:04.225069.
 
11
+*/
 
12
+
 
13
+YUI.add('maas.enums', function(Y) {
 
14
+Y.log('loading maas.enums');
 
15
+var module = Y.namespace('maas.enums');
 
16
+
 
17
+module.ARCHITECTURE = {
 
18
+    "amd64": "amd64", 
 
19
+    "i386": "i386"
 
20
+};
 
21
+
 
22
+module.NODE_AFTER_COMMISSIONING_ACTION = {
 
23
+    "DEFAULT": 0, 
 
24
+    "QUEUE": 0
 
25
+};
 
26
+
 
27
+module.NODE_PERMISSION = {
 
28
+    "ADMIN": "admin_node", 
 
29
+    "EDIT": "edit_node", 
 
30
+    "VIEW": "view_node"
 
31
+};
 
32
+
 
33
+module.NODE_STATUS = {
 
34
+    "ALLOCATED": 6, 
 
35
+    "COMMISSIONING": 1, 
 
36
+    "DECLARED": 0, 
 
37
+    "DEFAULT_STATUS": 0, 
 
38
+    "FAILED_TESTS": 2, 
 
39
+    "MISSING": 3, 
 
40
+    "READY": 4, 
 
41
+    "RESERVED": 5, 
 
42
+    "RETIRED": 7
 
43
+};
 
44
+
 
45
+module.POWER_TYPE = {
 
46
+    "DEFAULT": "", 
 
47
+    "IPMI": "ipmi", 
 
48
+    "IPMI_LAN": "ipmi_lan", 
 
49
+    "VIRSH": "virsh", 
 
50
+    "WAKE_ON_LAN": "ether_wake"
 
51
+};
 
52
+
 
53
+module.PRESEED_TYPE = {
 
54
+    "COMMISSIONING": "commissioning", 
 
55
+    "DEFAULT": "", 
 
56
+    "ENLIST": "enlist"
 
57
+};
 
58
+
 
59
+module.PSERV_FAULT = {
 
60
+    "COBBLER_AUTH_ERROR": 4, 
 
61
+    "COBBLER_AUTH_FAILED": 3, 
 
62
+    "COBBLER_DNS_LOOKUP_ERROR": 6, 
 
63
+    "GENERIC_COBBLER_ERROR": 99, 
 
64
+    "NO_COBBLER": 2, 
 
65
+    "NO_SUCH_PROFILE": 5
 
66
+};
 
67
+
 
68
+}, '0.1');