~ubuntu-branches/ubuntu/raring/makedumpfile/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01_fix_makefile.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): John Wright
  • Date: 2010-03-03 17:17:35 UTC
  • mfrom: (1.1.3 upstream) (7.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20100303171735-vxw4zqii21mcj0a0
* New upstream version
* Preserve upstream's original makedumpfile.8 in clean target
* kdump-config: Fix a typo
* Switch to the "3.0 (quilt)" source format
  - Remove unneeded Build-Depends on quilt
* Update kdump-tools.README.Debian to reflect that recent kernels
  don't need a crash kernel start address
* Apply patch from Petter Reinholdtsen to fix incorrect dependencies
  in kdump-tools.init (Closes: #569685)
* Indicate support for Linux 2.6.32
  - Although upstream hasn't updated its LATEST_VERSION macro, this
    version works without modification on Linux 2.6.32.  Squelch a
    warning that a 2.6.32 kernel is not supported.
* Backport upstream commit 4a16bd39866093f4949f8e9dc183fa2321bda22d
  - Fix buffer overflow when writing dh->signature

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 01_fix_makefile.dpatch by  <egon@top>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad makedumpfile-1.3.3~/Makefile makedumpfile-1.3.3/Makefile
9
 
--- makedumpfile-1.3.3~/Makefile        2009-04-20 08:26:23.000000000 +0200
10
 
+++ makedumpfile-1.3.3/Makefile 2009-06-23 13:23:37.538753532 +0200
11
 
@@ -39,7 +39,7 @@
12
 
        rm -f $(OBJ) $(OBJ_ARCH) makedumpfile makedumpfile.8.gz
13
 
 
14
 
 install:
15
 
-       cp makedumpfile ${DESTDIR}/bin
16
 
-       cp makedumpfile-R.pl ${DESTDIR}/bin
17
 
-       cp makedumpfile.8.gz ${DESTDIR}/usr/share/man/man8
18
 
+       install -D -m755 ./makedumpfile ${DESTDIR}/usr/bin/makedumpfile
19
 
+       install -D -m755 ./makedumpfile-R.pl ${DESTDIR}/usr/bin/makedumpfile-R.pl
20
 
+       install -D -m755 ./makedumpfile.8.gz ${DESTDIR}/usr/share/man/man8/makedumpfile.8.gz
21