~ubuntu-branches/ubuntu/raring/njplot/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/no_unneded_libs.patch

  • Committer: Bazaar Package Importer
  • Author(s): Andreas Tille
  • Date: 2011-02-22 13:15:08 UTC
  • mfrom: (3.1.5 sid)
  • Revision ID: james.westby@ubuntu.com-20110222131508-8jg4f3vrtoqc8ktp
Tags: 2.3-3
* Standards-Version: 3.9.1 (no changes needed)
* debian/source/format: 3.0 (quilt)
* debian/rules: Do not use deprecated variable DEB_OPT_FLAG any
  more but use CFLAGS instead
  Closes: #614432
* debian/patches: Do not link against unused libs (X11, Xmu)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- njplot-2.3.orig/makefile
 
2
+++ njplot-2.3/makefile
 
3
@@ -37,13 +37,13 @@
 
4
         -lvibrant -lncbi \
 
5
         $(PDFLIB)   \
 
6
         -L$(MOTIFLIB) -lXm  \
 
7
-        -L/usr/X11R6/lib -lXmu -lXt -lX11 -lm
 
8
+        -L/usr/X11R6/lib -lXt -lm
 
9
         
 
10
 unrooted : $(OBJUNROOTED)
 
11
        $(CC) -g -o unrooted $(OBJUNROOTED) \
 
12
         -L$(VIBRANT)/lib -lvibrant -lncbi \
 
13
         -L$(MOTIFLIB) -lXm \
 
14
-        -L/usr/X11R6/lib -lXmu -lXt -lX11  -lm
 
15
+        -L/usr/X11R6/lib -lXt -lm
 
16
 
 
17
 newicktops: njplot-vib.c
 
18
        $(CC) -DNO_GUI  -DNO_PDF -o $@ njplot-vib.c -lm