~ubuntu-branches/ubuntu/raring/nss/raring-security

« back to all changes in this revision

Viewing changes to debian/patches/38_kbsd.patch

Tags: 3.12.8-0ubuntu0.10.10.1
* New upstream release v3.12.8 (NSS_3_12_8_RTM)
  - Fix browser wildcard certificate validation issue
  - Update root certs
  - Fix SSL deadlocks
* Refresh patches:
  - update debian/patches/38_kbsd.patch
  - update debian/patches/97_SSL_RENEGOTIATE_TRANSITIONAL.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
8
8
 nss/lib/ssl/sslmutex.h     |    2 +-
9
9
 7 files changed, 33 insertions(+), 20 deletions(-)
10
10
 
11
 
Index: nss-3.12.6/mozilla/security/nss/lib/freebl/unix_rand.c
12
 
===================================================================
13
 
--- nss-3.12.6.orig/mozilla/security/nss/lib/freebl/unix_rand.c 2010-03-25 13:48:26.593065793 +0000
14
 
+++ nss-3.12.6/mozilla/security/nss/lib/freebl/unix_rand.c      2010-03-25 13:48:26.623067512 +0000
15
 
@@ -188,6 +188,8 @@
 
11
--- a/mozilla/security/nss/lib/freebl/unix_rand.c
 
12
+++ b/mozilla/security/nss/lib/freebl/unix_rand.c
 
13
@@ -188,6 +188,8 @@ static SECStatus RNG_kstat(PRUint32* fed
16
14
 
17
15
 #if defined(SCO) || defined(UNIXWARE) || defined(BSDI) || defined(FREEBSD) \
18
16
     || defined(NETBSD) || defined(DARWIN) || defined(OPENBSD) \
21
19
     || defined(NTO) || defined(__riscos__)
22
20
 #include <sys/times.h>
23
21
 
24
 
Index: nss-3.12.6/mozilla/security/coreconf/arch.mk
25
 
===================================================================
26
 
--- nss-3.12.6.orig/mozilla/security/coreconf/arch.mk   2009-06-05 03:14:49.000000000 +0100
27
 
+++ nss-3.12.6/mozilla/security/coreconf/arch.mk        2010-03-25 13:48:26.623067512 +0000
28
 
@@ -155,6 +155,14 @@
 
22
--- a/mozilla/security/coreconf/arch.mk
 
23
+++ b/mozilla/security/coreconf/arch.mk
 
24
@@ -155,6 +155,14 @@ ifeq ($(OS_ARCH),Linux)
29
25
     ifneq ($(words $(OS_RELEASE)),1)
30
26
        OS_RELEASE := $(word 1,$(OS_RELEASE)).$(word 2,$(OS_RELEASE))
31
27
     endif
40
36
 endif
41
37
 
42
38
 #
43
 
Index: nss-3.12.6/mozilla/security/nss/lib/ssl/sslmutex.c
44
 
===================================================================
45
 
--- nss-3.12.6.orig/mozilla/security/nss/lib/ssl/sslmutex.c     2009-06-05 03:34:14.000000000 +0100
46
 
+++ nss-3.12.6/mozilla/security/nss/lib/ssl/sslmutex.c  2010-03-25 13:48:26.623067512 +0000
47
 
@@ -89,7 +89,7 @@
 
39
--- a/mozilla/security/nss/lib/ssl/sslmutex.c
 
40
+++ b/mozilla/security/nss/lib/ssl/sslmutex.c
 
41
@@ -89,7 +89,7 @@ static SECStatus single_process_sslMutex
48
42
     return SECSuccess;
49
43
 }
50
44
 
53
47
 
54
48
 #include <unistd.h>
55
49
 #include <fcntl.h>
56
 
Index: nss-3.12.6/mozilla/security/nss/lib/ssl/sslmutex.h
57
 
===================================================================
58
 
--- nss-3.12.6.orig/mozilla/security/nss/lib/ssl/sslmutex.h     2009-06-05 03:34:15.000000000 +0100
59
 
+++ nss-3.12.6/mozilla/security/nss/lib/ssl/sslmutex.h  2010-03-25 13:48:26.623067512 +0000
60
 
@@ -83,7 +83,7 @@
 
50
--- a/mozilla/security/nss/lib/ssl/sslmutex.h
 
51
+++ b/mozilla/security/nss/lib/ssl/sslmutex.h
 
52
@@ -83,7 +83,7 @@ typedef struct
61
53
 
62
54
 typedef int    sslPID;
63
55
 
66
58
 
67
59
 #include <sys/types.h>
68
60
 #include "prtypes.h"
69
 
Index: nss-3.12.6/mozilla/security/coreconf/Linux.mk
70
 
===================================================================
71
 
--- nss-3.12.6.orig/mozilla/security/coreconf/Linux.mk  2010-01-15 22:19:00.000000000 +0000
72
 
+++ nss-3.12.6/mozilla/security/coreconf/Linux.mk       2010-03-25 13:54:10.280567769 +0000
73
 
@@ -52,6 +52,16 @@
 
61
--- a/mozilla/security/coreconf/Linux.mk
 
62
+++ b/mozilla/security/coreconf/Linux.mk
 
63
@@ -52,6 +52,16 @@ RANLIB                       = ranlib
74
64
 
75
65
 DEFAULT_COMPILER = gcc
76
66
 
87
77
 ifeq ($(OS_TEST),ppc64)
88
78
        CPU_ARCH        = ppc
89
79
 ifeq ($(USE_64),1)
90
 
@@ -59,14 +69,11 @@
 
80
@@ -59,14 +69,11 @@ ifeq ($(USE_64),1)
91
81
 endif
92
82
 else
93
83
 ifeq ($(OS_TEST),alpha)
105
95
        CPU_ARCH        = x86
106
96
        ARCHFLAG        = -m32
107
97
 endif
108
 
@@ -80,8 +87,8 @@
 
98
@@ -80,8 +87,8 @@ else
109
99
 ifeq (,$(filter-out parisc%,$(OS_TEST)))
110
100
        CPU_ARCH        = hppa
111
101
 else
116
106
        CPU_ARCH        = x86
117
107
 else
118
108
 ifeq ($(OS_TEST),sh4a)
119
 
@@ -101,7 +108,7 @@
 
109
@@ -101,7 +108,7 @@ endif
120
110
 
121
111
 LIBC_TAG               = _glibc
122
112
 
125
115
        OS_REL_CFLAGS   += -DLINUX2_0
126
116
        MKSHLIB         = $(CC) -shared -Wl,-soname -Wl,$(@:$(OBJDIR)/%.so=%.so) $(RPATH)
127
117
        ifdef MAPFILE
128
 
@@ -139,8 +146,6 @@
 
118
@@ -143,8 +150,6 @@ ifdef USE_PTHREADS
129
119
        DEFINES         += -D_REENTRANT
130
120
 endif
131
121
 
134
124
 DSO_CFLAGS             = -fPIC
135
125
 DSO_LDOPTS             = -shared $(ARCHFLAG)
136
126
 # The linker on Red Hat Linux 7.2 and RHEL 2.1 (GNU ld version 2.11.90.0.8)
137
 
@@ -150,7 +155,7 @@
138
 
 DSO_LDOPTS             += $(if $(findstring 2.11.90.0.8,$(shell ld -v)),,$(ZDEFS_FLAG))
139
 
 LDFLAGS                        += $(ARCHFLAG)
 
127
@@ -160,7 +165,7 @@ ifdef _SBOX_DIR
 
128
 LDFLAGS                        += -Wl,-rpath-link,/usr/lib:/lib
 
129
 endif
140
130
 
141
131
-# INCLUDES += -I/usr/include -Y/usr/include/linux
142
132
+# INCLUDES += -I/usr/include
143
133
 G++INCLUDES            = -I/usr/include/g++
144
134
 
145
135
 #
146
 
Index: nss-3.12.6/mozilla/security/coreconf/Linux2.6.mk
147
 
===================================================================
148
 
--- nss-3.12.6.orig/mozilla/security/coreconf/Linux2.6.mk       2009-06-11 01:55:32.000000000 +0100
149
 
+++ nss-3.12.6/mozilla/security/coreconf/Linux2.6.mk    2010-03-25 13:48:26.623067512 +0000
 
136
--- a/mozilla/security/coreconf/Linux2.6.mk
 
137
+++ b/mozilla/security/coreconf/Linux2.6.mk
150
138
@@ -37,7 +37,10 @@
151
139
 
152
140
 include $(CORE_DEPTH)/coreconf/Linux.mk
158
146
 MKSHLIB         = $(CC) $(DSO_LDOPTS) -Wl,-soname -Wl,$(@:$(OBJDIR)/%.so=%.so) $(RPATH)
159
147
 
160
148
 ifdef MAPFILE
161
 
Index: nss-3.12.6/mozilla/security/coreconf/config.mk
162
 
===================================================================
163
 
--- nss-3.12.6.orig/mozilla/security/coreconf/config.mk 2009-08-25 23:35:11.000000000 +0100
164
 
+++ nss-3.12.6/mozilla/security/coreconf/config.mk      2010-03-25 13:48:26.623067512 +0000
165
 
@@ -63,7 +63,7 @@
 
149
--- a/mozilla/security/coreconf/config.mk
 
150
+++ b/mozilla/security/coreconf/config.mk
 
151
@@ -63,7 +63,7 @@ endif
166
152
 #######################################################################
167
153
 
168
154
 TARGET_OSES = FreeBSD BSD_OS NetBSD OpenUNIX OS2 QNX Darwin BeOS OpenBSD \