~ubuntu-branches/ubuntu/raring/ophcrack/raring

« back to all changes in this revision

Viewing changes to debian/patches/00_validate_sysinfo.diff

  • Committer: Package Import Robot
  • Author(s): Julián Moreno Patiño
  • Date: 2012-06-14 21:59:45 UTC
  • mfrom: (3.1.6 sid)
  • Revision ID: package-import@ubuntu.com-20120614215945-c66gjgrjsnzrjthd
Tags: 3.4.0-2
* Add missing copyright.
* Add ophcrack.install to install
  ophcrack.desktop file.
* Update patch to detect properly sysinfo
  structure.

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
Forwarded: no
3
3
Origin: http://lists.debian.org/debian-bsd/2010/04/msg00026.html
4
4
Author: Petr Salinger <Petr.Salinger@seznam.cz>
5
 
Last-Update: 2012-05-27
 
5
Last-Update: 2012-06-14
6
6
--- a/configure.in
7
7
+++ b/configure.in
8
8
@@ -192,6 +192,7 @@
15
15
 [ AC_MSG_CHECKING(for libqt4)
16
16
--- a/src/misc.c
17
17
+++ b/src/misc.c
18
 
@@ -161,10 +161,12 @@
 
18
@@ -42,7 +42,7 @@
 
19
 #define WINVER 0x0500
 
20
 #include <windows.h>
 
21
 #else
 
22
-#if HAVE_SYS_SYSINFO_H
 
23
+#if HAVE_STRUCT_SYSINFO
 
24
 #include <sys/sysinfo.h>
 
25
 #elif HAVE_SYS_SYSCTL_H
 
26
 #include <sys/sysctl.h>
 
27
@@ -160,7 +160,7 @@
 
28
   /* Otherwise, we try to guess. */
19
29
   else {
20
30
 
21
 
 #if HAVE_SYS_SYSINFO_H
22
 
+    #if HAVE_STRUCT_SYSINFO
 
31
-#if HAVE_SYS_SYSINFO_H
 
32
+#if HAVE_STRUCT_SYSINFO
23
33
     struct sysinfo info;   
24
34
     sysinfo(&info);
25
35
     freeram = (uint64_t)info.freeram;
26
 
     cacheram = 0;
27
 
+    #endif
28
 
 #elif HAVE_SYS_SYSCTL_H
29
 
     int mib[2] = {CTL_HW, HW_USERMEM}, mem;
30
 
     size_t len;
31