~ubuntu-branches/ubuntu/raring/paml/raring

« back to all changes in this revision

Viewing changes to debian/patches/makefile.patch

  • Committer: Bazaar Package Importer
  • Author(s): Pjotr Prins
  • Date: 2010-09-11 23:01:37 UTC
  • Revision ID: james.westby@ubuntu.com-20100911230137-sf93nkg1ig78vwnj
Tags: 4.4c-2
Adjusting for non-free section.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: paml-4.4c/Makefile
 
2
===================================================================
 
3
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
4
+++ paml-4.4c/Makefile  2010-09-11 17:33:04.957524695 +0200
 
5
@@ -0,0 +1,9 @@
 
6
+
 
7
+all install build:
 
8
+       echo "Executing make $@ in src directory, instead."
 
9
+       make -C src $@
 
10
+
 
11
+clean:
 
12
+       echo "Cleaning binaries"
 
13
+       rm -f $(find src -name "*.c" | sed -e 's/.c$//')
 
14
+
 
15
Index: paml-4.4c/src/Makefile
 
16
===================================================================
 
17
--- paml-4.4c.orig/src/Makefile 2010-09-08 09:29:29.810248323 +0200
 
18
+++ paml-4.4c/src/Makefile      2010-09-11 18:01:01.116529194 +0200
 
19
@@ -35,3 +35,11 @@
 
20
        $(CC) $(CFLAGS) -o $@ yn00.c tools.c $(LIBS)
 
21
 chi2 : chi2.c
 
22
        $(CC) $(CFLAGS) -o $@ chi2.c $(LIBS)
 
23
+
 
24
+PREFIX=/usr
 
25
+DESTDIR=/
 
26
+
 
27
+install:
 
28
+       if [ ! -d "$(DESTDIR)/$(PREFIX)/bin" ]; then mkdir -p "$(DESTDIR)/$(PREFIX)/bin"; fi
 
29
+       cp $(PRGS) $(DESTDIR)/$(PREFIX)/bin/
 
30
+