~ubuntu-branches/ubuntu/raring/pd-smlib/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/nonlinux_fixes.patch

  • Committer: Package Import Robot
  • Author(s): Hans-Christoph Steiner
  • Date: 2012-09-25 12:20:08 UTC
  • mfrom: (1.1.1)
  • Revision ID: package-import@ubuntu.com-20120925122008-jhr5hyl3juh91eyv
Tags: 0.12.2-1
* updated to upstream version v0.12.2
* removed patches since they are in new upstream release
* bumped standards version to 3.9.3

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Author: IOhannes m zmölnig
2
 
Description: upstream Makefile forgot about Hurd & kFreeBSD; 
3
 
 they should be handled the same as Linux
4
 
--- pd-smlib.orig/Makefile
5
 
+++ pd-smlib/Makefile
6
 
@@ -41,6 +41,7 @@
7
 
 #
8
 
 #------------------------------------------------------------------------------#
9
 
 
10
 
+
11
 
 # get library version from meta file
12
 
 LIBRARY_VERSION = $(shell sed -n 's|^\#X text [0-9][0-9]* [0-9][0-9]* VERSION \(.*\);|\1|p' $(LIBRARY_NAME)-meta.pd)
13
 
 
14
 
@@ -121,6 +122,34 @@
15
 
   STRIP = strip --strip-unneeded -R .note -R .comment
16
 
   DISTBINDIR=$(DISTDIR)-$(OS)-$(shell uname -m)
17
 
 endif
18
 
+ifeq ($(UNAME),GNU)
19
 
+  # GNU/Hurd, should work like GNU/Linux for basically all externals
20
 
+  CPU := $(shell uname -m)
21
 
+  SOURCES += $(SOURCES_linux)
22
 
+  EXTENSION = pd_linux
23
 
+  OS = linux
24
 
+  PD_PATH = /usr
25
 
+  OPT_CFLAGS = -O6 -funroll-loops -fomit-frame-pointer
26
 
+  ALL_CFLAGS += -fPIC
27
 
+  ALL_LDFLAGS += -Wl,--export-dynamic  -shared -fPIC
28
 
+  ALL_LIBS += -lc
29
 
+  STRIP = strip --strip-unneeded -R .note -R .comment
30
 
+  DISTBINDIR=$(DISTDIR)-$(OS)-$(shell uname -m)
31
 
+endif
32
 
+ifeq ($(UNAME),GNU/kFreeBSD)
33
 
+  # Debian GNU/kFreeBSD, should work like GNU/Linux for basically all externals
34
 
+  CPU := $(shell uname -m)
35
 
+  SOURCES += $(SOURCES_linux)
36
 
+  EXTENSION = pd_linux
37
 
+  OS = linux
38
 
+  PD_PATH = /usr
39
 
+  OPT_CFLAGS = -O6 -funroll-loops -fomit-frame-pointer
40
 
+  ALL_CFLAGS += -fPIC
41
 
+  ALL_LDFLAGS += -Wl,--export-dynamic  -shared -fPIC
42
 
+  ALL_LIBS += -lc
43
 
+  STRIP = strip --strip-unneeded -R .note -R .comment
44
 
+  DISTBINDIR=$(DISTDIR)-$(OS)-$(shell uname -m)
45
 
+endif
46
 
 ifeq (CYGWIN,$(findstring CYGWIN,$(UNAME)))
47
 
   CPU := $(shell uname -m)
48
 
   SOURCES += $(SOURCES_cygwin)