~ubuntu-branches/ubuntu/raring/php5/raring

« back to all changes in this revision

Viewing changes to debian/patches/php-5.3.9-gnusrc.patch

  • Committer: Package Import Robot
  • Author(s): Clint Byrum
  • Date: 2012-06-18 16:10:26 UTC
  • mfrom: (1.1.24) (0.3.58 sid)
  • Revision ID: package-import@ubuntu.com-20120618161026-hg1fc5r9z1a4hlqz
Tags: 5.4.4-1ubuntu1
* Merge from Debian unstable. Remaining changes:
  - d/rules: Simplify apache config settings since we never build 
    interbase or firebird.
  - debian/rules: export DEB_HOST_MULTIARCH properly.
  - Add build-dependency on lemon, which we now need.
  - Dropped firebird2.1-dev, libc-client-dev, libmcrypt-dev as it is in universe.
  - Dropped libcurl-dev not in the archive.
  - debian/control: replace build-depends on mysql-server with
    mysql-server-core-5.5 and mysql-client-5.5 to avoid upstart and
    mysql-server-5.5 postinst confusion with starting up multiple
    mysqlds listening on the same port.
  - Dropped php5-imap, php5-interbase, php5-mcrypt since we have versions
    already in universe.
  - Dropped libonig-dev and libqgdbm since its in universe. (libonig MIR
    has been declined due to an inactive upstream. So this is probably
    a permanent change).
  - modulelist: Drop imap, interbase, sybase, and mcrypt.
  - debian/rules:
    * Dropped building of mcrypt, imap, and interbase.
    * Install apport hook for php5.
    * stop mysql instance on clean just in case we failed in tests
* Dropped Changes:
  * d/rules: enable Suhosin patch with PHP5_SUHOSIN=yes -- Upstream suhosin
    has been slow to adopt PHP 5.4, and is showing signs of disengagement.
    Therefore, we will follow Debian's lead and drop Suhosin for now.
  - d/control: build-depend on mysql 5.5 instead of 5.1 for running tests.
    -- Debian just deps on mysql-server
  - Suggest php5-suhosin rather than recommends. -- Dropping suhosin
  - d/setup-mysql.sh: modify to work with mysql 5.5 differences -- superseded
    in Debian.
  - Only build php5-sqlite for sqlite3, dropping the obsolete sqlite2. --
    superseded in Debian
  - d/maxlifetime: Improve maxlifetime script to scan for more SAPIs and 
    scan all *.ini in conf.d directory. -- Change came from Debian
  - d/libapache2-mod-php5.postinst,libapache2-mod-php5filter.postinst: 
    Restart apache on first install to ensure module is fully enabled.
    -- Change came from Debian
  - debian/patches/php5-CVE-2012-1823.patch: filter query strings that
    are prefixed with '-' -- Fixed upstream
  - debian/control: Recommend php5-dev for php-pear. -- This was a poorly
    conceived idea anyway.
  - Pre-Depend on a new enough version of dpkg for dpkg-maintscript-helper
    rather than checking whether it exists at run-time, leading to more
    predictable behaviour on upgrades. -- Applied in Debian
  - d/p/gd-multiarch-fix.patch: superseded
* d/NEWS: add note explaining that SUHOSIN is no longer enabled in the
  Ubuntu packages.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -up php-5.3.9/configure.in.gnusrc php-5.3.9/configure.in
2
 
--- php-5.3.9/configure.in.gnusrc       2012-01-10 12:21:57.000000000 +0100
3
 
+++ php-5.3.9/configure.in      2012-01-10 18:53:24.020907113 +0100
4
 
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
 
1
--- a/configure.in
 
2
+++ b/configure.in
 
3
@@ -136,6 +136,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
5
4
 AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
6
5
 AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
7
6
 
10
9
 dnl Setting up the PHP version based on the information above.
11
10
 dnl -------------------------------------------------------------------------
12
11
 
13
 
diff -up php-5.3.9/ext/interbase/interbase.c.gnusrc php-5.3.9/ext/interbase/interbase.c
14
 
--- php-5.3.9/ext/interbase/interbase.c.gnusrc  2012-01-01 14:15:04.000000000 +0100
15
 
+++ php-5.3.9/ext/interbase/interbase.c 2012-01-10 18:53:24.021907113 +0100
 
12
--- a/ext/interbase/interbase.c
 
13
+++ b/ext/interbase/interbase.c
16
14
@@ -24,7 +24,6 @@
17
15
 #include "config.h"
18
16
 #endif
21
19
 
22
20
 #include "php.h"
23
21
 
24
 
diff -up php-5.3.9/ext/pdo_firebird/firebird_driver.c.gnusrc php-5.3.9/ext/pdo_firebird/firebird_driver.c
25
 
--- php-5.3.9/ext/pdo_firebird/firebird_driver.c.gnusrc 2012-01-01 14:15:04.000000000 +0100
26
 
+++ php-5.3.9/ext/pdo_firebird/firebird_driver.c        2012-01-10 18:53:24.022907113 +0100
 
22
--- a/ext/pdo_firebird/firebird_driver.c
 
23
+++ b/ext/pdo_firebird/firebird_driver.c
27
24
@@ -22,7 +22,6 @@
28
25
 #include "config.h"
29
26
 #endif
32
29
 
33
30
 #include "php.h"
34
31
 #ifdef ZEND_ENGINE_2
35
 
diff -up php-5.3.9/ext/standard/file.c.gnusrc php-5.3.9/ext/standard/file.c
36
 
--- php-5.3.9/ext/standard/file.c.gnusrc        2012-01-01 14:15:04.000000000 +0100
37
 
+++ php-5.3.9/ext/standard/file.c       2012-01-10 18:53:24.023907113 +0100
38
 
@@ -113,9 +113,6 @@ php_file_globals file_globals;
 
32
--- a/ext/standard/file.c
 
33
+++ b/ext/standard/file.c
 
34
@@ -112,9 +112,6 @@ php_file_globals file_globals;
39
35
 #endif
40
36
 
41
37
 #if defined(HAVE_FNMATCH) && !defined(PHP_WIN32)
45
41
 # include <fnmatch.h>
46
42
 #endif
47
43
 
48
 
diff -up php-5.3.9/ext/zlib/zlib_fopen_wrapper.c.gnusrc php-5.3.9/ext/zlib/zlib_fopen_wrapper.c
49
 
--- php-5.3.9/ext/zlib/zlib_fopen_wrapper.c.gnusrc      2012-01-01 14:15:04.000000000 +0100
50
 
+++ php-5.3.9/ext/zlib/zlib_fopen_wrapper.c     2012-01-10 18:53:52.308907791 +0100
 
44
--- a/ext/zlib/zlib_fopen_wrapper.c
 
45
+++ b/ext/zlib/zlib_fopen_wrapper.c
51
46
@@ -19,8 +19,6 @@
52
47
 
53
 
 /* $Id: zlib_fopen_wrapper.c 321634 2012-01-01 13:15:04Z felipe $ */
 
48
 /* $Id$ */
54
49
 
55
50
-#define _GNU_SOURCE
56
51
-
57
52
 #include "php.h"
58
53
 #include "php_zlib.h"
59
54
 #include "fopen_wrappers.h"
60
 
diff -up php-5.3.9/main/php.h.gnusrc php-5.3.9/main/php.h
61
 
--- php-5.3.9/main/php.h.gnusrc 2012-01-01 14:15:04.000000000 +0100
62
 
+++ php-5.3.9/main/php.h        2012-01-10 18:53:24.025907114 +0100
 
55
--- a/main/php.h
 
56
+++ b/main/php.h
63
57
@@ -30,6 +30,7 @@
64
58
 #define PHP_HAVE_STREAMS
65
59
 #define YYDEBUG 0
68
62
 #include "php_version.h"
69
63
 #include "zend.h"
70
64
 #include "zend_qsort.h"
71
 
diff -up php-5.3.9/main/streams/cast.c.gnusrc php-5.3.9/main/streams/cast.c
72
 
--- php-5.3.9/main/streams/cast.c.gnusrc        2012-01-01 14:15:04.000000000 +0100
73
 
+++ php-5.3.9/main/streams/cast.c       2012-01-10 18:54:09.479908202 +0100
 
65
--- a/main/streams/cast.c
 
66
+++ b/main/streams/cast.c
74
67
@@ -18,7 +18,6 @@
75
68
 
76
 
 /* $Id: cast.c 321634 2012-01-01 13:15:04Z felipe $ */
 
69
 /* $Id$ */
77
70
 
78
71
-#define _GNU_SOURCE
79
72
 #include "php.h"
80
73
 #include "php_globals.h"
81
74
 #include "php_network.h"
82
 
diff -up php-5.3.9/main/streams/memory.c.gnusrc php-5.3.9/main/streams/memory.c
83
 
--- php-5.3.9/main/streams/memory.c.gnusrc      2012-01-01 14:15:04.000000000 +0100
84
 
+++ php-5.3.9/main/streams/memory.c     2012-01-10 18:54:25.102908576 +0100
 
75
--- a/main/streams/memory.c
 
76
+++ b/main/streams/memory.c
85
77
@@ -18,7 +18,6 @@
86
78
 
87
 
 /* $Id: memory.c 321634 2012-01-01 13:15:04Z felipe $ */
 
79
 /* $Id$ */
88
80
 
89
81
-#define _GNU_SOURCE
90
82
 #include "php.h"
91
83
 
92
84
 PHPAPI int php_url_decode(char *str, int len);
93
 
diff -up php-5.3.9/main/streams/streams.c.gnusrc php-5.3.9/main/streams/streams.c
94
 
--- php-5.3.9/main/streams/streams.c.gnusrc     2012-01-01 14:15:04.000000000 +0100
95
 
+++ php-5.3.9/main/streams/streams.c    2012-01-10 18:54:42.953909003 +0100
 
85
--- a/main/streams/streams.c
 
86
+++ b/main/streams/streams.c
96
87
@@ -21,7 +21,6 @@
97
88
 
98
 
 /* $Id: streams.c 321634 2012-01-01 13:15:04Z felipe $ */
 
89
 /* $Id$ */
99
90
 
100
91
-#define _GNU_SOURCE
101
92
 #include "php.h"
102
93
 #include "php_globals.h"
103
94
 #include "php_network.h"
104
 
diff -up php-5.3.9/Zend/zend_language_parser.c.gnusrc php-5.3.9/Zend/zend_language_parser.c
105
 
--- php-5.3.9/Zend/zend_language_parser.c.gnusrc        2012-01-10 14:37:07.000000000 +0100
106
 
+++ php-5.3.9/Zend/zend_language_parser.c       2012-01-10 18:53:24.031907115 +0100
107
 
@@ -112,6 +112,8 @@
108
 
 #include "zend_API.h"
109
 
 #include "zend_constants.h"
 
95
--- a/Zend/zend_language_parser.c
 
96
+++ b/Zend/zend_language_parser.c
 
97
@@ -67,6 +67,8 @@
 
98
 #define yydebug zenddebug
 
99
 #define yynerrs zendnerrs
110
100
 
111
101
+#include <string.h>
112
102
+
113
103
 
114
 
 #define YYERROR_VERBOSE
115
 
 #define YYSTYPE znode
 
104
 /* Tokens.  */
 
105
 #ifndef YYTOKENTYPE