~ubuntu-branches/ubuntu/raring/requests/raring

« back to all changes in this revision

Viewing changes to debian/patches/01_do-not-use-python-certifi.patch

  • Committer: Package Import Robot
  • Author(s): Daniele Tricoli
  • Date: 2012-05-04 14:34:47 UTC
  • mfrom: (1.1.9)
  • Revision ID: package-import@ubuntu.com-20120504143447-3psyffw2slct0a1j
Tags: 0.12.1-1
* New upstream release
* debian/control
  - Added python-oauthlib to python-requests' Recommends field
* debian/patches/01_do-not-use-python-certifi.patch
  - Refreshed

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Description: To verify SSL certificates for HTTPS requests, use the bundle
2
 
 provided by ca-certificates instead of python-certifi. Since requests 0.11.2
3
 
 it is not needed to hard-code bundle path because requests will search for it.
 
2
 provided by ca-certificates instead of python-certifi.
4
3
Author: Daniele Tricoli <eriol@mornie.org>
5
4
Forwarded: not-needed
6
 
Last-Update: 2012-04-23
 
5
Last-Update: 2012-05-04
7
6
 
8
7
--- a/setup.py
9
8
+++ b/setup.py
10
 
@@ -21,7 +21,7 @@
11
 
     os.system('python tests/test_requests.py')
12
 
     sys.exit()
 
9
@@ -32,7 +32,7 @@
 
10
 # On certain supported platforms (e.g., Red Hat / Debian / FreeBSD), Requests can
 
11
 # use the system CA bundle instead; see `requests.utils` for details.
 
12
 # If your platform is supported, set `requires` to [] instead:
 
13
-requires = ['certifi>=0.0.7']
 
14
+requires = []
13
15
 
14
 
-required = ['certifi>=0.0.7',]
15
 
+required = []
16
 
 packages = [
17
 
     'requests',
18
 
     'requests.packages',
 
16
 # chardet is used to optimally guess the encodings of pages that don't declare one.
 
17
 # At this time, chardet is not a required dependency. However, it's sufficiently