~ubuntu-branches/ubuntu/raring/suitesparse/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/06-BTF_Lib_Makefile.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Christophe Prud'homme
  • Date: 2007-10-22 11:10:41 UTC
  • mto: This revision was merged to the branch mainline in revision 6.
  • Revision ID: james.westby@ubuntu.com-20071022111041-c2fdtrxz70i1og6u
Tags: 3.0.0-7
* Bug fix: "trying to overwrite `/usr/lib/libamd.a', which is also
  in package libumfpack4-dev", thanks to Soeren Sonnenburg (Closes:
  #447555).
* debian/control: 
  + added Homepage field
  + removed duplicate field Replaces

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 06-BTF_Lib_Makefile.dpatch by Daniel Rus Morales <danirus@tol-project.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: New content to build the BTF shared library
 
6
 
 
7
@DPATCH@
 
8
diff -u trunk~/BTF/Lib/Makefile trunk/BTF/Lib/Makefile
 
9
--- trunk~/BTF/Lib/Makefile     2007-05-03 22:34:57.000000000 +0200
 
10
+++ trunk/BTF/Lib/Makefile      2007-07-17 09:56:53.000000000 +0200
 
11
@@ -15,38 +15,56 @@
 
12
 
 
13
 all: library
 
14
 
 
15
-library: libbtf.a
 
16
+library: libbtf.a libbtf.so.1.2
 
17
 
 
18
 OBJ = btf_order.o btf_maxtrans.o btf_strongcomp.o \
 
19
     btf_l_order.o btf_l_maxtrans.o btf_l_strongcomp.o
 
20
+OBJ_SL = $(subst .o,.oo,$(OBJ))
 
21
 
 
22
 libbtf.a: $(OBJ)
 
23
        $(AR) libbtf.a $(OBJ)
 
24
        $(RANLIB) libbtf.a
 
25
 
 
26
-$(OBJ): $(INC)
 
27
+libbtf.so.1.2: $(OBJ_SL)
 
28
+       $(CC) -shared $^ -lm -Wl,-soname -Wl,libbtf.so.1 -o $@
 
29
+       ln -s $@ libbtf.so.1
 
30
+       ln -s $@ libbtf.so
 
31
+
 
32
+$(OBJ) $(OBJ_SL): $(INC)
 
33
 
 
34
 #-------------------------------------------------------------------------------
 
35
 
 
36
 btf_order.o: ../Source/btf_order.c
 
37
        $(C) -c $(I) $< -o $@
 
38
+btf_order.oo: ../Source/btf_order.c
 
39
+       $(C) -fPIC -c $(I) $< -o $@
 
40
 
 
41
 btf_maxtrans.o: ../Source/btf_maxtrans.c
 
42
        $(C) -c $(I) $< -o $@
 
43
+btf_maxtrans.oo: ../Source/btf_maxtrans.c
 
44
+       $(C) -fPIC -c $(I) $< -o $@
 
45
 
 
46
 btf_strongcomp.o: ../Source/btf_strongcomp.c
 
47
        $(C) -c $(I) $< -o $@
 
48
+btf_strongcomp.oo: ../Source/btf_strongcomp.c
 
49
+       $(C) -fPIC -c $(I) $< -o $@
 
50
 
 
51
 #-------------------------------------------------------------------------------
 
52
 
 
53
 btf_l_order.o: ../Source/btf_order.c
 
54
        $(C) -c $(I) -DDLONG $< -o $@
 
55
+btf_l_order.oo: ../Source/btf_order.c
 
56
+       $(C) -fPIC -c $(I) -DDLONG $< -o $@
 
57
 
 
58
 btf_l_maxtrans.o: ../Source/btf_maxtrans.c
 
59
        $(C) -c $(I) -DDLONG $< -o $@
 
60
+btf_l_maxtrans.oo: ../Source/btf_maxtrans.c
 
61
+       $(C) -fPIC -c $(I) -DDLONG $< -o $@
 
62
 
 
63
 btf_l_strongcomp.o: ../Source/btf_strongcomp.c
 
64
        $(C) -c $(I) -DDLONG $< -o $@
 
65
+btf_l_strongcomp.oo: ../Source/btf_strongcomp.c
 
66
+       $(C) -fPIC -c $(I) -DDLONG $< -o $@
 
67
 
 
68
 #-------------------------------------------------------------------------------
 
69
 
 
70
@@ -57,3 +75,6 @@
 
71
 
 
72
 clean:
 
73
        - $(RM) $(CLEAN)
 
74
+       -$(RM) *.oo
 
75
+       -$(RM) *.a
 
76
+       -$(RM) *.so*