~ubuntu-branches/ubuntu/raring/tcl8.5/raring

« back to all changes in this revision

Viewing changes to debian/patches/rpath.diff

  • Committer: Package Import Robot
  • Author(s): Colin Watson
  • Date: 2011-12-20 18:16:54 UTC
  • mfrom: (11.2.3 sid)
  • Revision ID: package-import@ubuntu.com-20111220181654-ucrvquqz66e1dv80
Tags: 8.5.11-1ubuntu1
* Resynchronise with Debian.  Remaining changes:
  - Don't use tcl itself to install things when building, to allow for
    cross-building.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Patch by Chris Waters removes -rpath from search flags and adds -soname
2
2
to library build options.
3
3
 
4
 
--- tcl8.5-8.5.10.orig/unix/configure
5
 
+++ tcl8.5-8.5.10/unix/configure
 
4
--- tcl8.5-8.5.11.orig/unix/configure
 
5
+++ tcl8.5-8.5.11/unix/configure
6
6
@@ -7351,6 +7351,9 @@
7
7
            # get rid of the warnings.
8
8
            #CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
13
13
            SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
14
14
            DL_OBJS="tclLoadDl.o"
15
15
            DL_LIBS="-ldl"
16
 
--- tcl8.5-8.5.10.orig/unix/Makefile.in
17
 
+++ tcl8.5-8.5.10/unix/Makefile.in
18
 
@@ -719,7 +719,10 @@
 
16
--- tcl8.5-8.5.11.orig/unix/Makefile.in
 
17
+++ tcl8.5-8.5.11/unix/Makefile.in
 
18
@@ -721,7 +721,10 @@
19
19
            fi
20
20
        @echo "Installing $(LIB_FILE) to $(LIB_INSTALL_DIR)/"
21
21
        @@INSTALL_LIB@
27
27
        @echo "Installing ${TCL_EXE} as $(BIN_INSTALL_DIR)/tclsh$(VERSION)@EXEEXT@"
28
28
        @$(INSTALL_PROGRAM) ${TCL_EXE} "$(BIN_INSTALL_DIR)"/tclsh$(VERSION)@EXEEXT@
29
29
        @echo "Installing tclConfig.sh to $(CONFIG_INSTALL_DIR)/"
30
 
--- tcl8.5-8.5.10.orig/unix/tcl.m4
31
 
+++ tcl8.5-8.5.10/unix/tcl.m4
 
30
--- tcl8.5-8.5.11.orig/unix/tcl.m4
 
31
+++ tcl8.5-8.5.11/unix/tcl.m4
32
32
@@ -1401,6 +1401,9 @@
33
33
            # get rid of the warnings.
34
34
            #CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"