~ubuntu-branches/ubuntu/raring/whichman/raring

« back to all changes in this revision

Viewing changes to debian/patches/00_Makefile.patch

  • Committer: Package Import Robot
  • Author(s): Robert Luberda
  • Date: 2012-02-19 16:05:46 UTC
  • Revision ID: package-import@ubuntu.com-20120219160546-nd61zqumiov4zvbl
Tags: 2.4-7
* Switch to debhelper v9 and tiny rules file.
* Rename & refresh patches with gbp-pq import/export.
* Fix lintian's `spelling-error-in-copyright'.
* debian/rules: remove .pc/.dpkg-source-unapply file in rules.
  This fixes broken behaviour of dpkg-buildpackage (see Bug#649521).
* debian/control:
  + Standards-Version: 3.9.2 (no changes);
  + add VCS fields;
  + sort dependency fields with wrap-and-sort.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Upstream Makefile fixes.
2
 
 
3
 
diff -Nur whichman-2.4.old/Makefile whichman-2.4/Makefile
4
 
--- whichman-2.4.old/Makefile   2004-04-15 04:19:10.000000000 +0200
5
 
+++ whichman-2.4/Makefile       2008-01-27 14:45:55.000000000 +0100
6
 
@@ -9,6 +9,8 @@
7
 
 #sun c/c++-compiler:
8
 
 #CC=CC
9
 
 #CFLAGS= -O
10
 
+STRIP=strip
11
 
+
12
 
 
13
 
 all:whichman ftff ftwhich
14
 
 
15
 
@@ -31,9 +33,9 @@
16
 
        $(CC) $(CFLAGS) -c levdist.c
17
 
 
18
 
 install: whichman ftff ftwhich $(MANP)
19
 
-       strip whichman
20
 
-       strip ftwhich
21
 
-       strip ftff
22
 
+       $(STRIP) whichman
23
 
+       $(STRIP) ftwhich
24
 
+       $(STRIP) ftff
25
 
        [ -d "$(prefix)/bin" ] || $(INSTALL) -d $(prefix)/bin
26
 
        [ -d "$(mandir)/man1" ] || $(INSTALL) -d $(mandir)/man1
27
 
        $(INSTALL) -m 755 whichman $(prefix)/bin