~ubuntu-branches/ubuntu/raring/wxwidgets2.8/raring

« back to all changes in this revision

Viewing changes to debian/patches/multiarch_paths.patch

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2011-08-19 08:45:53 UTC
  • Revision ID: james.westby@ubuntu.com-20110819084553-80x6dj77ebrneoda
Tags: 2.8.11.0-0ubuntu10
debian/patches/multiarch_paths.patch: look in the multiarch path
when detecting libraries.  Closes LP: #828999.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: look in the multiarch path when detecting libraries
 
2
Author: Steve Langasek <steve.langasek@ubuntu.com>
 
3
Bug-Ubuntu: https://bugs.launchpad.net/bugs/828999
 
4
Index: wxwidgets2.8-2.8.11.0/configure.in
 
5
===================================================================
 
6
--- wxwidgets2.8-2.8.11.0.orig/configure.in
 
7
+++ wxwidgets2.8-2.8.11.0/configure.in
 
8
@@ -2736,6 +2736,9 @@
 
9
 AC_MSG_RESULT($wx_cv_std_libpath)
 
10
 
 
11
 SEARCH_LIB="`echo "$SEARCH_INCLUDE" | sed s@include@$wx_cv_std_libpath@g` /usr/$wx_cv_std_libpath"
 
12
+if test -n "$DEB_HOST_MULTIARCH"; then
 
13
+   SEARCH_LIB="/usr/lib/$DEB_HOST_MULTIARCH $SEARCH_LIB"
 
14
+fi
 
15
 
 
16
 dnl Cross compiling with gcc?
 
17
 if test "$build" != "$host" -a "$GCC" = yes; then