~ubuntu-branches/ubuntu/saucy/activity-log-manager/saucy

« back to all changes in this revision

Viewing changes to debian/patches/05_fix_userdirs.patch

  • Committer: Package Import Robot
  • Author(s): Jeremy Bicha
  • Date: 2013-07-04 12:32:19 UTC
  • mfrom: (1.1.6)
  • Revision ID: package-import@ubuntu.com-20130704123219-9ucew0nqo70uadiz
Tags: 0.9.6-0ubuntu1
* New upstream release. (LP: #1189253, #1050620, #1167531)
* Don't split control-center plugin to a separate package
* debian/control:
  - Bump minimum vala
  - Build-depend on libwhoopsie-dev, libzeitgeist-2.0-dev, and
    libgcrypt11-dev (LP: #1197569)
* debian/watch: Fixed
* Dropped patches applied in new version:
  - 01_move_to_personal_section.patch
  - 02_handle_upstart_in_whoopsie.patch:
  - 03_correct_path_to_whoopsie_preferences.patch:
  - 04_correct_privacy_policy_url.patch:
  - 05_add_missing_configvapi.patch
  - 05_fix_userdirs.patch
* debian/patches/01_really_hide_automatic_reports.patch:
  - Don't show "Send automatic reports" since that feature isn't
    implemented yet
* debian/patches/02_update_standalone_title.patch:
  - Update the title of the standalone app to Activity Log Manager too
* debian/patches/06_add_unity_dash_privacy.patch:
  - Refreshed and set to only show when Unity is running (LP: #1082552)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: activity-log-manager-0.9.4/src/Makefile.in
2
 
===================================================================
3
 
--- activity-log-manager-0.9.4.orig/src/Makefile.in     2012-03-20 19:15:07.000000000 +0100
4
 
+++ activity-log-manager-0.9.4/src/Makefile.in  2012-11-26 13:53:53.000000000 +0100
5
 
@@ -379,8 +379,7 @@
6
 
        --pkg gtk+-3.0 \
7
 
        --pkg gee-1.0  \
8
 
        --target-glib=2.26 \
9
 
-       --pkg gio-unix-2.0 \
10
 
-       config.vapi
11
 
+       --pkg gio-unix-2.0
12
 
 
13
 
 SHARED_CFLAGS = \
14
 
        -Wall \
15
 
Index: activity-log-manager-0.9.4/src/files-widget.vala
16
 
===================================================================
17
 
--- activity-log-manager-0.9.4.orig/src/files-widget.vala       2012-03-20 17:39:25.000000000 +0100
18
 
+++ activity-log-manager-0.9.4/src/files-widget.vala    2012-11-26 13:55:33.081759039 +0100
19
 
@@ -261,15 +261,25 @@
20
 
                mime_dict.set(_("E-mail"), NMO_EMAIL);
21
 
                mime_dict.set(_("Website"), NFO_WEBSITE);
22
 
 
23
 
+                       UserDirectory[] special_dirs =
24
 
+                       {
25
 
+                               UserDirectory.DESKTOP,
26
 
+                               UserDirectory.DOCUMENTS,
27
 
+                               UserDirectory.DOWNLOAD,
28
 
+                               UserDirectory.MUSIC,
29
 
+                               UserDirectory.PICTURES,
30
 
+                               UserDirectory.PUBLIC_SHARE,
31
 
+                               UserDirectory.TEMPLATES,
32
 
+                               UserDirectory.VIDEOS
33
 
+                       };
34
 
+
35
 
                        defined_dirs = new HashMap<string, UserDirectory>(str_hash, str_equal);
36
 
-                       defined_dirs.set(Environment.get_user_special_dir(UserDirectory.DESKTOP), UserDirectory.DESKTOP);
37
 
-                       defined_dirs.set(Environment.get_user_special_dir(UserDirectory.DOCUMENTS), UserDirectory.DOCUMENTS);
38
 
-                       defined_dirs.set(Environment.get_user_special_dir(UserDirectory.DOWNLOAD), UserDirectory.DOWNLOAD);
39
 
-                       defined_dirs.set(Environment.get_user_special_dir(UserDirectory.MUSIC), UserDirectory.MUSIC);
40
 
-                       defined_dirs.set(Environment.get_user_special_dir(UserDirectory.PICTURES), UserDirectory.PICTURES);
41
 
-                       defined_dirs.set(Environment.get_user_special_dir(UserDirectory.PUBLIC_SHARE), UserDirectory.PUBLIC_SHARE);
42
 
-                       defined_dirs.set(Environment.get_user_special_dir(UserDirectory.TEMPLATES), UserDirectory.TEMPLATES);
43
 
-                       defined_dirs.set(Environment.get_user_special_dir(UserDirectory.VIDEOS), UserDirectory.VIDEOS);
44
 
+                       for(int i = 0; i < special_dirs.length; i++) {
45
 
+                               string dir_path = Environment.get_user_special_dir(special_dirs[i]);
46
 
+                               if (dir_path != null) {
47
 
+                                       defined_dirs.set(dir_path, special_dirs[i]);
48
 
+                               }
49
 
+                       }
50
 
                
51
 
                        //FIXME: Not sure if the correct icon is being fetched for stock folder
52
 
                        stock_folder_icon = this.render_icon_pixbuf(Stock.DIRECTORY, IconSize.LARGE_TOOLBAR);