~ubuntu-branches/ubuntu/saucy/bouncy/saucy

« back to all changes in this revision

Viewing changes to debian/patches/use_dejavu_fonts.patch

  • Committer: Package Import Robot
  • Author(s): Markus Koschany, Ansgar Burchardt, Markus Koschany
  • Date: 2013-05-15 19:18:01 UTC
  • Revision ID: package-import@ubuntu.com-20130515191801-faij9zk3xg7y77sg
Tags: 0.6.20071104-4
* Team upload.

[ Ansgar Burchardt ]
* debian/game.sh: Use exec when calling python.

[ Markus Koschany ]
* Switch to package format 3.0 (quilt).
* Bump compat level to 9 and require debhelper >=9.
* debian/control:
  - Drop quilt build-dependency because package format 3.0 uses quilt by
    default.
  - Bump Standards-Version to 3.9.4, no changes needed.
  - Replace python with ${python:Depends}.
  - Add python, python-pygame and python-opengl to Build-Depends-Indep.
* Simplify debian/rules by using dh sequencer and build with --python2.
* Drop bouncy.dirs file which is not necessary.
* Add DEP3 headers to all patches.
* Update debian/copyright to copyright format 1.0.
* Install bouncy.6 via manpages files.
* bouncy.desktop: Add keywords and a comment in German.
* Rename game.sh to bouncy, move it to the debian/bin subdirectory and
  install it to /usr/games directly. Hence we can also drop bouncy.links.
* Remove data_path.patch, it was not applied anyway.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: bouncy-0.6.20071104/fonts.py
 
1
From: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
 
2
Date: Sat, 11 May 2013 01:04:32 +0200
 
3
Subject: use_dejavu_fonts
 
4
 
2
5
===================================================================
3
 
--- bouncy-0.6.20071104.orig/fonts.py
4
 
+++ bouncy-0.6.20071104/fonts.py
 
6
---
 
7
 fonts.py        |    8 ++++----
 
8
 game.py         |    4 ++--
 
9
 leveledit.py    |    9 +++------
 
10
 pyglyph/html.py |    2 +-
 
11
 4 files changed, 10 insertions(+), 13 deletions(-)
 
12
 
 
13
diff --git a/fonts.py b/fonts.py
 
14
index beeb28a..a1bb32e 100644
 
15
--- a/fonts.py
 
16
+++ b/fonts.py
5
17
@@ -1,13 +1,13 @@
6
18
 import pyglyph
7
19
 
20
32
+mono20 = fonts.get_font(family='DejaVu sans mono',
21
33
     size=20, bold=False, italic=False)
22
34
 
23
 
Index: bouncy-0.6.20071104/game.py
24
 
===================================================================
25
 
--- bouncy-0.6.20071104.orig/game.py
26
 
+++ bouncy-0.6.20071104/game.py
27
 
@@ -44,7 +44,7 @@
 
35
diff --git a/game.py b/game.py
 
36
index 04dc6e0..ab6dcac 100644
 
37
--- a/game.py
 
38
+++ b/game.py
 
39
@@ -44,7 +44,7 @@ class Game(ui.UserInterface):
28
40
     def menu(self):
29
41
 
30
42
         instructions = pyglyph.layout_html('''
33
45
                 (I)nstructions <br>
34
46
                 (E)asy <br>
35
47
                 (N)ormal <br>
36
 
@@ -132,7 +132,7 @@
 
48
@@ -132,7 +132,7 @@ class Game(ui.UserInterface):
37
49
 
38
50
     def instructions(self):
39
51
         instructions = pyglyph.layout_html('''
42
54
 <b>Bouncy the Rabbit by Richard Jones</b>
43
55
 <br>
44
56
 Written for the 3rd PyWeek Challenge: http://www.pyweek.org/
45
 
Index: bouncy-0.6.20071104/leveledit.py
46
 
===================================================================
47
 
--- bouncy-0.6.20071104.orig/leveledit.py
48
 
+++ bouncy-0.6.20071104/leveledit.py
 
57
diff --git a/leveledit.py b/leveledit.py
 
58
index 7dcca1a..49b4b21 100644
 
59
--- a/leveledit.py
 
60
+++ b/leveledit.py
49
61
@@ -1,4 +1,5 @@
50
62
 import sys, pygame, csv, shutil, os
51
63
+import fonts
52
64
 from pygame.locals import *
53
65
 from pygame.constants import *
54
66
 
55
 
@@ -44,12 +45,8 @@
 
67
@@ -44,12 +45,8 @@ class LevelEditor:
56
68
         self.mode = 'props'
57
69
 
58
70
         # load up fonts
67
79
 
68
80
         # button labels and callback funcs
69
81
         self.buttons = [
70
 
Index: bouncy-0.6.20071104/pyglyph/html.py
71
 
===================================================================
72
 
--- bouncy-0.6.20071104.orig/pyglyph/html.py
73
 
+++ bouncy-0.6.20071104/pyglyph/html.py
74
 
@@ -131,7 +131,7 @@
 
82
diff --git a/pyglyph/html.py b/pyglyph/html.py
 
83
index 18714b1..a792e3b 100644
 
84
--- a/pyglyph/html.py
 
85
+++ b/pyglyph/html.py
 
86
@@ -131,7 +131,7 @@ class StylePrototype:
75
87
             self._attrs[Attribute.Bold] = False
76
88
             self._attrs[Attribute.Italic] = False
77
89
             self._attrs[Attribute.FontSize] = 12