~ubuntu-branches/ubuntu/saucy/directfb/saucy

« back to all changes in this revision

Viewing changes to debian/patches/93_fix_unicode_key_handling.patch

  • Committer: Package Import Robot
  • Author(s): Fathi Boudra
  • Date: 2012-05-19 20:22:53 UTC
  • mfrom: (2.1.16 sid)
  • Revision ID: package-import@ubuntu.com-20120519202253-1m34cravlouqjqdi
Tags: 1.2.10.0-5
* Update debian/control:
  - bump debhelper build dependency to 9.
  - drop libsysfs-dev build dependency. (Closes: #627651)
  - bump Standards-Version to 3.9.3 (no changes needed).
* Add debian/patches/100_fix_format_string_errors.patch:
  Fix FTBFS with -Werror=format-security. Thanks to Micah Gersten.
  (Closes: #645809)
* libpng1.5 transition:
  - add support for libpng 1.5. (Closes: #648138)
  - replace libpng12-dev build dependency by libpng-dev. (Closes: #662302)
* Add multiarch support. (Closes: #663039)

Show diffs side-by-side

added added

removed removed

Lines of Context:
6
6
Author: Jérémy Bobbio <lunar@debian.org>
7
7
Bug-Debian: http://bugs.debian.org/401296
8
8
 
 
9
---
 
10
 inputdrivers/keyboard/keyboard.c       |   17 +++++++++++++++++
 
11
 inputdrivers/linux_input/linux_input.c |   23 +++++++++++++++++++++++
 
12
 2 files changed, 40 insertions(+)
 
13
 
9
14
--- a/inputdrivers/keyboard/keyboard.c
10
15
+++ b/inputdrivers/keyboard/keyboard.c
11
 
@@ -87,6 +87,10 @@ keyboard_get_symbol( int                
 
16
@@ -87,6 +87,10 @@ keyboard_get_symbol( int
12
17
      unsigned char index = KVAL(value);
13
18
      int           base  = (level == DIKSI_BASE);
14
19
 
52
57
 
53
58
--- a/inputdrivers/linux_input/linux_input.c
54
59
+++ b/inputdrivers/linux_input/linux_input.c
55
 
@@ -388,6 +388,10 @@ keyboard_get_symbol( int                
 
60
@@ -388,6 +388,10 @@ keyboard_get_symbol( int
56
61
      unsigned char index = KVAL(value);
57
62
      int           base  = (level == DIKSI_BASE);
58
63