~ubuntu-branches/ubuntu/saucy/ecasound2.2/saucy

« back to all changes in this revision

Viewing changes to debian/patches/11_configure_in_alsa_fix.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Junichi Uekawa
  • Date: 2008-03-23 21:42:49 UTC
  • mfrom: (3.1.6 hardy)
  • Revision ID: james.westby@ubuntu.com-20080323214249-evlfv3y1o8q747la
Tags: 2.4.6.1-2
* Bug fix: "FTBFS with GCC 4.3: missing #includes", thanks to Martin
  Michlmayr (Closes: #454890).
- 13_gcc4: updated

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 11_configure_in_alsa_fix.dpatch by Junichi Uekawa <dancer@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: fix configure.in to work with newer autoconf with more vigorous use of { }
6
 
 
7
 
@DPATCH@
8
 
diff -urNad ecasound2.2-2.4.4~/configure.in ecasound2.2-2.4.4/configure.in
9
 
--- ecasound2.2-2.4.4~/configure.in     2006-09-23 10:12:58.613080960 +0900
10
 
+++ ecasound2.2-2.4.4/configure.in      2006-09-23 10:12:58.735062416 +0900
11
 
@@ -936,7 +936,8 @@
12
 
 if test x$alsa_support = x; then
13
 
     AC_CHECK_LIB(asound, snd_pcm_delay,
14
 
                 alsa_support=yes,
15
 
-                alsa_support=no AC_CHECK_LIB(asound, main, AC_MSG_ERROR([ALSA version older than 0.9.0 not supported - update to a newer version or compile with --disable-alsa])))
16
 
+                alsa_support=no
17
 
+                AC_CHECK_LIB(asound, main, AC_MSG_ERROR([ALSA version older than 0.9.0 not supported - update to a newer version or compile with --disable-alsa])))
18
 
 fi
19
 
 
20
 
 AM_CONDITIONAL(ECA_AM_COMPILE_ALSA, test x$alsa_support = xyes)