~ubuntu-branches/ubuntu/saucy/eucalyptus/saucy

« back to all changes in this revision

Viewing changes to debian/patches/24-label-metadata-ip.patch

  • Committer: Bazaar Package Importer
  • Author(s): Dave Walker (Daviey), Dave Walker (Daviey)
  • Date: 2011-03-01 12:17:35 UTC
  • mfrom: (1.1.49 upstream)
  • Revision ID: james.westby@ubuntu.com-20110301121735-ww7xxanzp3ov87sn
Tags: 2.0.1+bzr1256-0ubuntu1
[ Dave Walker (Daviey) ]
* New upstream snapshot of minor point release, 2.0.1 (r1256).
  - Fixes FTBFS, (LP: #687970)
  - Stop unauthenticated users being able to reset user password. (LP: #675372).
  - Fixes node controller memory leak. (LP: #523211)
  - Rearrange of linker options for libEucalyptusNC.so. (LP: #724470)
* Switch from dhcp3-server to isc-dhcp-server as the new default. (LP: #711590)
  - debian/:
    + control: eucalyptus-cc, drop Recommends on dhcp3-server and add 
      isc-dhcp-server as the new default.
    + eucalyptus.conf: Use different dhcpd binary name.
    + patches/{18-priv_security.patch|08-ubuntu-default-networking.patch},
      updated rootwrap to use different dhpcd binary.
* Refreshed 06-UEC-webinterface.patch, dropping hunks now applied upstream.
* Updated standards version to 3.9.1, no changes required.
* debian/control: Updated VCS location.
* debian/source/include-binaries: Included newer favicon, overiding shipped.
* debian/{local/registration}/Makefile: Introduced a stanza for, for 
  re-arranging of Linker flags, resolving FTBFS. Added -Wall.
* debian/*: The binary resulting jars have been updated from *-2.0.0 to
  *-2.0.1.  References updated as appropriate.
* debian/patches/*: Refreshed patches

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/cluster/handlers.c        2010-08-17 16:41:18 +0000
2
 
+++ b/cluster/handlers.c        2010-08-17 19:45:51 +0000
 
1
--- a/cluster/handlers.c
 
2
+++ b/cluster/handlers.c
3
3
@@ -726,7 +726,7 @@
4
4
       ret = 1;
5
5
     } else {
9
9
        logprintfl(EUCAINFO,"running cmd %s\n", cmd);
10
10
        rc = system(cmd);
11
11
        rc = rc>>8;
12
 
 
13
 
=== modified file 'net/vnetwork.c'
14
 
--- b/net/vnetwork.c    2010-06-21 11:14:52 +0000
15
 
+++ b/net/vnetwork.c    2010-08-17 19:45:51 +0000
 
12
--- a/net/vnetwork.c
 
13
+++ b/net/vnetwork.c
16
14
@@ -249,7 +249,7 @@
17
15
     return(1);
18
16
   }
31
29
 
32
30
   logprintfl(EUCADEBUG, "vnetAddGatewayIP(): running cmd '%s'\n", cmd);
33
31
   rc = system(cmd);
34