~ubuntu-branches/ubuntu/saucy/gimp/saucy-updates

« back to all changes in this revision

Viewing changes to debian/patches/04_gold_linker.patch

  • Committer: Package Import Robot
  • Author(s): Robert Ancell
  • Date: 2010-12-06 16:20:34 UTC
  • Revision ID: package-import@ubuntu.com-20101206162034-5z99hh17b9zhst2o
Tags: 2.6.11-1ubuntu2
* debian/control:
  - Add build-depends on dh-autoreconf
  - List dependencies one line per dependency
  - Use standards version 3.9.1
  - Add ${misc:Depends} to all packages
* debian/rules:
  - Use autoreconf.mk
* debian/patches/04_gold_linker.patch:
  - Explicitly specify library dependencies at link time, so we can use gold

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 582cb0f14eb9f145bd2a2f5c9fda12309ae0229f Mon Sep 17 00:00:00 2001
 
2
From: Manish Singh <yosh@gimp.org>
 
3
Date: Sun, 24 May 2009 17:42:39 +0000
 
4
Subject: Explicitly specify library dependencies at link time, so we can use gold.
 
5
 
 
6
---
 
7
diff --git a/libgimpthumb/Makefile.am b/libgimpthumb/Makefile.am
 
8
index a78a83a..98acd24 100644
 
9
--- a/libgimpthumb/Makefile.am
 
10
+++ b/libgimpthumb/Makefile.am
 
11
@@ -86,7 +86,10 @@ noinst_PROGRAMS = gimp-thumbnail-list
 
12
 
 
13
 gimp_thumbnail_list_SOURCES = gimp-thumbnail-list.c
 
14
 
 
15
-gimp_thumbnail_list_LDADD = libgimpthumb-$(GIMP_API_VERSION).la
 
16
+gimp_thumbnail_list_LDADD = \
 
17
+       libgimpthumb-$(GIMP_API_VERSION).la \
 
18
+       $(GDK_PIXBUF_LIBS) \
 
19
+       $(GLIB_LIBS)
 
20
 
 
21
 
 
22
 install-data-local: install-ms-lib install-libtool-import-lib
 
23
diff --git a/plug-ins/common/Makefile.am b/plug-ins/common/Makefile.am
 
24
index 66dc6dd..d58ecee 100644
 
25
--- a/plug-ins/common/Makefile.am
 
26
+++ b/plug-ins/common/Makefile.am
 
27
@@ -7,21 +7,22 @@
 
28
 ## Modify those two files instead of this one; for most
 
29
 ## plug-ins you should only need to modify plugin-defs.pl.
 
30
 
 
31
+if OS_WIN32
 
32
+mwindows = -mwindows
 
33
+else
 
34
+libm = -lm
 
35
+endif
 
36
 
 
37
 libgimp = $(top_builddir)/libgimp/libgimp-$(GIMP_API_VERSION).la
 
38
 libgimpbase = $(top_builddir)/libgimpbase/libgimpbase-$(GIMP_API_VERSION).la
 
39
 libgimpcolor = $(top_builddir)/libgimpcolor/libgimpcolor-$(GIMP_API_VERSION).la
 
40
 libgimpconfig = $(top_builddir)/libgimpconfig/libgimpconfig-$(GIMP_API_VERSION).la
 
41
-libgimpmath = $(top_builddir)/libgimpmath/libgimpmath-$(GIMP_API_VERSION).la
 
42
+libgimpmath = $(top_builddir)/libgimpmath/libgimpmath-$(GIMP_API_VERSION).la $(libm)
 
43
 libgimpmodule = $(top_builddir)/libgimpmodule/libgimpmodule-$(GIMP_API_VERSION).la
 
44
 libgimpui = $(top_builddir)/libgimp/libgimpui-$(GIMP_API_VERSION).la
 
45
 libgimpwidgets = $(top_builddir)/libgimpwidgets/libgimpwidgets-$(GIMP_API_VERSION).la
 
46
 
 
47
 
 
48
-if OS_WIN32
 
49
-mwindows = -mwindows
 
50
-endif
 
51
-
 
52
 AM_LDFLAGS = $(mwindows)
 
53
 
 
54
 libexecdir = $(gimpplugindir)/plug-ins
 
55
diff --git a/plug-ins/common/mkgen.pl b/plug-ins/common/mkgen.pl
 
56
index 40b4b74..b0cd786 100755
 
57
--- a/plug-ins/common/mkgen.pl
 
58
+++ b/plug-ins/common/mkgen.pl
 
59
@@ -51,21 +51,22 @@ print MK <<EOT;
 
60
 ## Modify those two files instead of this one; for most
 
61
 ## plug-ins you should only need to modify plugin-defs.pl.
 
62
 
 
63
+if OS_WIN32
 
64
+mwindows = -mwindows
 
65
+else
 
66
+libm = -lm
 
67
+endif
 
68
 
 
69
 libgimp = \$(top_builddir)/libgimp/libgimp-\$(GIMP_API_VERSION).la
 
70
 libgimpbase = \$(top_builddir)/libgimpbase/libgimpbase-\$(GIMP_API_VERSION).la
 
71
 libgimpcolor = \$(top_builddir)/libgimpcolor/libgimpcolor-\$(GIMP_API_VERSION).la
 
72
 libgimpconfig = \$(top_builddir)/libgimpconfig/libgimpconfig-\$(GIMP_API_VERSION).la
 
73
-libgimpmath = \$(top_builddir)/libgimpmath/libgimpmath-\$(GIMP_API_VERSION).la
 
74
+libgimpmath = \$(top_builddir)/libgimpmath/libgimpmath-\$(GIMP_API_VERSION).la \$(libm)
 
75
 libgimpmodule = \$(top_builddir)/libgimpmodule/libgimpmodule-\$(GIMP_API_VERSION).la
 
76
 libgimpui = \$(top_builddir)/libgimp/libgimpui-\$(GIMP_API_VERSION).la
 
77
 libgimpwidgets = \$(top_builddir)/libgimpwidgets/libgimpwidgets-\$(GIMP_API_VERSION).la
 
78
 
 
79
 
 
80
-if OS_WIN32
 
81
-mwindows = -mwindows
 
82
-endif
 
83
-
 
84
 AM_LDFLAGS = \$(mwindows)
 
85
 
 
86
 libexecdir = \$(gimpplugindir)/plug-ins
 
87
diff --git a/plug-ins/help-browser/Makefile.am b/plug-ins/help-browser/Makefile.am
 
88
index 14fbe02..7360433 100644
 
89
--- a/plug-ins/help-browser/Makefile.am
 
90
+++ b/plug-ins/help-browser/Makefile.am
 
91
@@ -36,6 +36,7 @@ LDADD = \
 
92
        $(libgimpbase)          \
 
93
        $(WEBKIT_LIBS)          \
 
94
        $(GIO_LIBS)             \
 
95
+       $(GLIB_LIBS)            \
 
96
        $(RT_LIBS)              \
 
97
        $(INTLLIBS)
 
98
 
 
99
--
 
100
cgit v0.8.3.1