~ubuntu-branches/ubuntu/saucy/gnome-session/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/105_hide_session_startup_help.patch

  • Committer: Package Import Robot
  • Author(s): Jeremy Bicha
  • Date: 2013-06-19 10:37:29 UTC
  • mfrom: (1.1.84) (2.1.15 experimental)
  • Revision ID: package-import@ubuntu.com-20130619103729-653t3vjxw4voqetf
Tags: 3.8.2.1-1ubuntu1
* Merge with Debian (LP: #1185873, #1191290). Remaining changes:
 - debian/control.in:
   + gnome-session
     - Don't depend on gnome-shell
     - Drop the Recommends on gnome-power-manager, the code gnome-session
       uses has moved to gnome-settings-daemon
     - Recommend session-migration
   + gnome-session-fallback
     - Recommend cups-pk-helper for gnome-session-fallback so that
       System Settings>Printers works
 - Use logind for session tracking and shutdown/restart
 - Add upstart user session
 - debian/gnome-session-bin.postinst, debian/gnome-session-bin.prerm:
    Moved registering gnome-session binary as a session manager to 
    gnome-session-bin package
 - debian/postinst, postrm:
    set the default lightdm session as ubuntu if none already set
 - don't install defaults.list (installed by desktop-file-utils in ubuntu):
    debian/gnome-session-common.dirs and gnome-session-common.install
 - debian/patches/20_hide_nodisplay.patch:
    Don't show applications in the Sessions properties dialog that have
    NoDisplay=true.
 - debian/patches/22_support_autostart_delay.patch:
    Bugzilla patch to support adding a delay to autostart apps, using
    a "X-GNOME-Autostart-Delay" key in the desktop file
 - debian/patches/50_ubuntu_sessions.patch:
    + Add Ubuntu session
    + gnome-shell.desktop adds --session=gnome now that the "ubuntu" session
      is the default. Use TryExec to test if gnome-shell is installed.
 - debian/patches/51_remove_session_saving_from_gui.patch:
    add GNOME_SESSION_SAVE environment variable for people wanting to
    use the save session still, knowing that it can break your system
    if used unwisely (LP: #771896)
 - debian/patches/52_xdg_current_desktop.patch:
    Set XDG_CURRENT_DESKTOP inside gnome-session based on a
    new key 'DesktopName' in gnome-session .desktop files.
 - debian/patches/53_add_sessionmigration.patch, debian/control:
    recommends and launch the session-migration if present at the start
    of the session. This sync tool is running different session migration
    scripts that can be provided in various desktop packages.
 - debian/patches/95_dbus_request_shutdown.patch:
    Add "RequestShutdown" and "RequestReboot" DBus methods to allow other
    applications to shutdown or reboot the machine via the session manager.
  - debian/patches/103_kill_the_fail_whale.patch:
    Kill the Fail Whale as it tends to be more annoying than helpful
* Refreshed patches as necessary
* Dropped patches applied upstream or no longer applicable:
  - 00git_logind_test.patch
  - 04_consolekit_init_upower.patch
  - 04_fallback_warning_notify.patch
  - 12_no_gdm_fallback.patch
  - 80_new_upstream_session_dialog.patch
  - 96_no_catch_sigsegv.patch
  - 97_dont_blacklist_llvmpipe.patch
  - 101_screen_lock_on_suspend.patch
  - 104_dont_show_fallback_warning.patch
* Completely drop gnome-session-fallback (moved to gnome-panel source):
  - debian/gnome-session-fallback.*
  - debian/gnome-wm.desktop
  - debian/patches/00_revert_remove_fallback_session.patch
  - debian/patches/01_gnome-wm.patch
  - debian/patches/02_fallback_desktop.patch
  - debian/patches/03_fallback_desktop_makefile.patch
  - debian/scripts/
* Thanks Rico Tzschichholz, Tim Lunn, and Robert Ancell for helping with
  this update!

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Hide Help button (until GNOME provides the help for 3.x again)
2
 
Author: Michael Terry <michael.terry@canonical.com>
3
 
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=658712
4
 
Bug-Ubuntu: https://launchpad.net/bugs/838539
5
 
 
6
 
Index: gnome-session-3.2.1/capplet/gsm-properties-dialog.c
7
 
===================================================================
8
 
--- gnome-session-3.2.1.orig/capplet/gsm-properties-dialog.c    2011-11-29 13:28:39.000000000 -0500
9
 
+++ gnome-session-3.2.1/capplet/gsm-properties-dialog.c 2011-11-29 13:36:20.467490766 -0500
10
 
@@ -476,7 +476,6 @@
11
 
         GtkTargetList     *targetlist;
12
 
 
13
 
         gtk_dialog_add_buttons (GTK_DIALOG (dialog),
14
 
-                                GTK_STOCK_HELP, GTK_RESPONSE_HELP,
15
 
                                 GTK_STOCK_CLOSE, GTK_RESPONSE_CLOSE,
16
 
                                 NULL);
17