~ubuntu-branches/ubuntu/saucy/haproxy/saucy

« back to all changes in this revision

Viewing changes to debian/patches/0001-Replace-bash-with-sh-and-fix-bashisms.patch

  • Committer: Package Import Robot
  • Author(s): Vincent Bernat, Apollon Oikonomopoulos, Vincent Bernat, Prach Pongpanich
  • Date: 2013-05-06 20:02:14 UTC
  • mfrom: (1.3.1)
  • mto: This revision was merged to the branch mainline in revision 18.
  • Revision ID: package-import@ubuntu.com-20130506200214-36s6p81fsa5zqybt
[ Apollon Oikonomopoulos ]
* New upstream version (Closes: #643650, #678953)
   + This fixes CVE-2012-2942 (Closes: #674447)
   + This fixes CVE-2013-1912 (Closes: #704611)
* Ship vim addon as vim-haproxy (Closes: #702893)
* Check for the configuration file after sourcing /etc/default/haproxy
  (Closes: #641762)
* Use /dev/log for logging by default (Closes: #649085)

[ Vincent Bernat ]
* debian/control:
   + add Vcs-* fields
   + switch maintenance to Debian HAProxy team. (Closes: #706890)
   + drop dependency to quilt: 3.0 (quilt) format is in use.
* debian/rules:
   + don't explicitly call dh_installchangelog.
   + use dh_installdirs to install directories.
   + use dh_install to install error and configuration files.
   + switch to `linux2628` Makefile target for Linux.
* debian/postrm:
   + remove haproxy user and group on purge.
* Ship a more minimal haproxy.cfg file: no `listen` blocks but `global`
  and `defaults` block with appropriate configuration to use chroot and
  logging in the expected way.

[ Prach Pongpanich ]
* debian/copyright:
   + add missing copyright holders
   + update years of copyright
* debian/rules:
   + build with -Wl,--as-needed to get rid of unnecessary depends
* Remove useless files in debian/haproxy.{docs,examples}
* Update debian/watch file, thanks to Bart Martens

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Christo Buschek <crito@30loops.net>
 
2
Date: Thu, 11 Apr 2013 14:18:19 +0300
 
3
Subject: Replace bash with sh and fix bashisms
 
4
 
 
5
---
 
6
 examples/debugfind        |    2 +-
 
7
 examples/stats_haproxy.sh |    4 ++--
 
8
 2 files changed, 3 insertions(+), 3 deletions(-)
 
9
 
 
10
diff --git a/examples/debugfind b/examples/debugfind
 
11
index 88e9760..100f5ef 100644
 
12
--- a/examples/debugfind
 
13
+++ b/examples/debugfind
 
14
@@ -1,4 +1,4 @@
 
15
-#!/bin/bash
 
16
+#!/bin/sh
 
17
 if [ $# -lt 2 ]; then
 
18
        echo "Usage: $0 regex debug_file > extracted_file"
 
19
        exit 1
 
20
diff --git a/examples/stats_haproxy.sh b/examples/stats_haproxy.sh
 
21
index 25f23d3..a8bd02b 100644
 
22
--- a/examples/stats_haproxy.sh
 
23
+++ b/examples/stats_haproxy.sh
 
24
@@ -1,4 +1,4 @@
 
25
-#!/bin/bash
 
26
+#!/bin/sh
 
27
 
 
28
 ## contrib by prizee.com
 
29
 
 
30
@@ -11,7 +11,7 @@ fi
 
31
 
 
32
 printUsage ()
 
33
 {
 
34
-    echo -e "Usage : $(basename $0) [options] -s section
 
35
+    printf "Usage : $(basename $0) [options] -s section
 
36
 --section -s section\t: section to use ( --list format)
 
37
 Options :
 
38
 --socket -S [socket]\t: socket to use (default: /var/run/haproxy.stat)