~ubuntu-branches/ubuntu/saucy/hplip/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/10_shebang_fixes.dpatch

  • Committer: Package Import Robot
  • Author(s): Till Kamppeter, Till Kamppeter
  • Date: 2013-09-11 21:36:00 UTC
  • mfrom: (1.7.3)
  • Revision ID: package-import@ubuntu.com-20130911213600-ajinn0lfwkbkt1cf
Tags: 3.13.9-0ubuntu1
[ Till Kamppeter ]
* New upstream release
   o Bug fixes and added hardware support
   o Added support for: HP Designjet Z5400 44-in PostScript ePrinter,
     Deskjet Ink Advantage 1018 Printer, 1518/2540/2545/2546 All-in-One
     Printer, 4515/4518 e-All-in-One Printer, Envy 4504 e-All-in-One,
     LaserJet Pro MFP M435nw, Officejet 4630/4632/4635 e-All-in-One Printer,
     OfficeJet Pro 8600 Premium e-AiO N911n, Photosmart 5521 e-All-in-One
     Printer
   o HP OfficeJet G55 is not detecting through USB (LP: #1209339)
   o Collate broken under hplip-3.13.7 as hpps sends SET COPIES (LP: #1209352)
   o Fix for plugin (firmware) installation and test page in 'hp-setup -i'
* debian/patches/10_shebang_fixes.dpatch,
  debian/patches/hp-setup-prompt-for-custom-PPD.dpatch,
  debian/patches/kbsd.dpatch,
  debian/patches/make-commafy-correctly-work-with-python-2.dpatch,
  debian/patches/black-stripes-on-pcl5c-printouts.dpatch: Removed, applied
  upstream.
* debian/patches/hp_photosmart_pro_b9100_support.dpatch,
  debian/patches/hp-check_debian.dpatch
  debian/patches/hp-mkuri-take-into-account-already-installed-plugin-also-for-exit-value.dpatch,
  debian/patches/simple-scan-as-default.dpatch,
  debian/patches/add-lidil-two-cartridge-modes.dpatch,
  debian/patches/hp-systray-make-menu-title-visible-in-sni-qt-indicator.dpatch,
  debian/patches/hp-systray-make-menu-appear-in-sni-qt-indicator-with-kde.dpatch,
  debian/patches/hpaio-option-duplex.diff: Refreshed with quilt.
* debian/patches/ubuntu-hp-mkuri-notification-text.dpatch: Manually adapted
  to the new source code.
* debian/hplip.install, debian/rules: Removed hplipjs and hpcac filters, they
  are removed from HPLIP.
* debian/hplip.dirs, debian/hplip.postinst, debian/hplip.postrm: Added
  /var/log/hp/tmp/ (775 root.lp), needed by hp-sendfax (LP: #1187132).
* debian/printer-driver-postscript-hp.install: Some DesignJet PPDs do not
  have "ps" in their names and therefore did not get packaged.
* debian/non-shipped-files.txt: Updated.
* debian/rules: Remove the non-shipped files in the end of the install-stamp
  rule, as some of them get created after "make install" by this rule.
* debian/rules: Do not create HAL .fdi file.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 10_hashbang_fixes.dpatch by Henrique de Moraes Holschuh <hmh@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Fix missing, weird or otherwise broken shebang lines
6
 
 
7
 
@DPATCH@
8
 
Index: hplip-3.12.4/__init__.py
9
 
===================================================================
10
 
--- hplip-3.12.4.orig/__init__.py       2012-04-10 18:35:13.000000000 +1000
11
 
+++ hplip-3.12.4/__init__.py    2012-05-26 10:21:29.000000000 +1000
12
 
@@ -1,3 +1,4 @@
13
 
+#!/usr/bin/env python
14
 
 # -*- coding: utf-8 -*-
15
 
 #
16
 
 # (c) Copyright 2003-2007 Hewlett-Packard Development Company, L.P.