~ubuntu-branches/ubuntu/saucy/joystick/saucy

« back to all changes in this revision

Viewing changes to debian/patches/fix-warnings.patch

  • Committer: Bazaar Package Importer
  • Author(s): Stephen Kitt
  • Date: 2011-04-04 16:56:39 UTC
  • mfrom: (1.1.2 upstream)
  • mto: This revision was merged to the branch mainline in revision 14.
  • Revision ID: james.westby@ubuntu.com-20110404165639-wwp0enzkfqi841i7
* New upstream version:
  - Builds with --as-needed. Closes: #607009.
  - inputattach supports W8001. Closes: #616443.
  - inputattach supports Zhen-Hua. LP: #648945.
* Drop all patches, merged upstream. Drop README.source explaining quilt
  usage, and --with-quilt directive to sh.
* Drop manpages, merged upstream.
* Drop store/restore tools, merged upstream.
* Rework udev rules:
  - provide agents to delay invoking inputattach or jscal-restore until
    they become available;
  - drop jskeepalive and use sleep instead to stop Acrux devices from
    going into a coma (as suggested by Oliver Neukum), for kernels prior
    to 2.6.39;
  - only apply the udev rules when adding devices (as suggested by
    Roberto Neri).
* Standards-Version 3.9.1, no change required.
* No longer ship evtest, its source is maintained separately (and will
  be removed from future upstream versions of joystick).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Fix SDL-related warnings.
2
 
 
3
 
--- joystick-20051019.orig/utils/Makefile
4
 
+++ joystick-20051019/utils/Makefile
5
 
@@ -41,8 +41,7 @@
6
 
        $(RM) *.o *.swp $(PROGRAMS) *.orig *.rej map *~
7
 
 
8
 
 ffcfstress: ffcfstress.c
9
 
-       $(CC) -O2 -fno-implement-inlines -funsigned-char \
10
 
-        -lm ffcfstress.c -o ffcfstress
11
 
+       $(CC) -O2 -funsigned-char -lm ffcfstress.c -o ffcfstress
12
 
 
13
 
 ffmvforce.o: ffmvforce.c
14
 
        $(CC) -c $(CFLAGS) $(CPPFLAGS) $^ -o $@ `sdl-config --cflags`
15
 
--- joystick-20051019.orig/utils/ffmvforce.c
16
 
+++ joystick-20051019/utils/ffmvforce.c
17
 
@@ -147,7 +147,7 @@
18
 
                fprintf(stderr, "Could not initialize SDL: %s\n", SDL_GetError());
19
 
                exit(1);
20
 
        }
21
 
-       on_exit(SDL_Quit, NULL);
22
 
+       atexit(SDL_Quit);
23
 
        screen = SDL_SetVideoMode(WIN_W, WIN_H, 0, SDL_SWSURFACE);
24
 
        if (screen == NULL) {
25
 
                fprintf(stderr, "Could not set video mode: %s\n", SDL_GetError());