~ubuntu-branches/ubuntu/saucy/libdvdread/saucy

« back to all changes in this revision

Viewing changes to debian/patches/03-endian.patch

  • Committer: Package Import Robot
  • Author(s): Bryce Harrington
  • Date: 2011-11-28 17:12:51 UTC
  • mfrom: (1.1.4) (3.2.10 sid)
  • Revision ID: package-import@ubuntu.com-20111128171251-fxbi0nd6rrz3lsfb
Tags: 4.2.0-1ubuntu1
* Merge from debian testing.  Remaining changes:
  - Re-add missing install-css.sh. Update the script with patch by Gene Cumm
    for dynamic version calculation.
  - debian/control: add Suggests for install-css.sh on wget, debhelper, etc.
  - debian/rules: install install-css.sh, leave perms executable.
  - 100-quell-vts-tmapt-warning.patch - Don't recommend sending bug
    reports when VTS_TMAPT is missing
  - 102-reorder-linkage.patch - Fix link order for shared library loading.
* Drop 101-fix-msb-unicode.patch; fixed upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Lorenz Minder <lminder@gmx.net>
 
2
Description: Use correct endianess on big-endian machines (Closes: #531621).
 
3
 
 
4
diff -Naurp libdvdread.orig/src/bswap.h libdvdread/src/bswap.h
 
5
--- libdvdread.orig/src/bswap.h 2011-01-06 13:08:49.000000000 +0000
 
6
+++ libdvdread/src/bswap.h      2011-01-06 13:14:17.000000000 +0000
 
7
@@ -22,6 +22,11 @@
 
8
 #ifndef LIBDVDREAD_BSWAP_H
 
9
 #define LIBDVDREAD_BSWAP_H
 
10
 
 
11
+#include <endian.h>
 
12
+#if BYTE_ORDER == BIG_ENDIAN
 
13
+#define WORDS_BIGENDIAN
 
14
+#endif
 
15
+
 
16
 #include <config.h>
 
17
 
 
18
 #if defined(WORDS_BIGENDIAN)