~ubuntu-branches/ubuntu/saucy/libnl3/saucy

« back to all changes in this revision

Viewing changes to debian/patches/0004-more-out-of-tree-build-fixes.patch

  • Committer: Package Import Robot
  • Author(s): Heiko Stuebner
  • Date: 2012-06-30 15:54:25 UTC
  • mfrom: (3.1.6 sid)
  • Revision ID: package-import@ubuntu.com-20120630155425-6wx9v9q70vry53vg
Tags: 3.2.7-4
* Add watch file (Closes: #679473)
* Use dh-autoreconf to update the build system (Closes: 679474)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Nur -x '*.orig' -x '*~' libnl3/doc/Makefile.am libnl3.new/doc/Makefile.am
2
 
--- libnl3/doc/Makefile.am      2012-04-02 15:17:22.222698000 -0400
3
 
+++ libnl3.new/doc/Makefile.am  2012-04-02 15:34:47.796619394 -0400
4
 
@@ -79,16 +79,16 @@
5
 
        images/icons/callouts/15.png
6
 
 
7
 
 %.html: %.txt
8
 
-       ./resolve-asciidoc-refs.py $< > asciidoc.tmp
9
 
+       ../../../../doc/resolve-asciidoc-refs.py $< > asciidoc.tmp
10
 
        asciidoc $(ASCIIDOCOPTS) -o $@ asciidoc.tmp
11
 
-       ./doxygen-link.py libnl.dict $@ > asciidoc.tmp
12
 
+       ../../../../doc/doxygen-link.py libnl.dict $@ > asciidoc.tmp
13
 
        mv asciidoc.tmp $@
14
 
 
15
 
 asciidoc: core.html route.html index.html
16
 
 
17
 
 api_ref:
18
 
        doxygen Doxyfile;
19
 
-       ./gen-tags.sh | ./tags2dict.sh > libnl.dict
20
 
+       ../../../../doc/gen-tags.sh | ../../../../doc/tags2dict.sh > libnl.dict
21
 
 
22
 
 gendoc:
23
 
        $(MAKE) api_ref
24
 
diff -Nur -x '*.orig' -x '*~' libnl3/doc/Makefile.in libnl3.new/doc/Makefile.in
25
 
--- libnl3/doc/Makefile.in      2012-04-02 15:17:22.222698000 -0400
26
 
+++ libnl3.new/doc/Makefile.in  2012-04-02 15:35:40.560622455 -0400
27
 
@@ -452,16 +452,16 @@
28
 
 .PHONY: gendoc api_refs asciidoc
29
 
 
30
 
 %.html: %.txt
31
 
-       ./resolve-asciidoc-refs.py $< > asciidoc.tmp
32
 
+       ../../../../doc/resolve-asciidoc-refs.py $< > asciidoc.tmp
33
 
        asciidoc $(ASCIIDOCOPTS) -o $@ asciidoc.tmp
34
 
-       ./doxygen-link.py libnl.dict $@ > asciidoc.tmp
35
 
+       ../../../../doc/doxygen-link.py libnl.dict $@ > asciidoc.tmp
36
 
        mv asciidoc.tmp $@
37
 
 
38
 
 asciidoc: core.html route.html index.html
39
 
 
40
 
 api_ref:
41
 
        doxygen Doxyfile;
42
 
-       ./gen-tags.sh | ./tags2dict.sh > libnl.dict
43
 
+       ../../../../doc/gen-tags.sh | ../../../../doc/tags2dict.sh > libnl.dict
44
 
 
45
 
 gendoc:
46
 
        $(MAKE) api_ref
47
 
diff -Nur -x '*.orig' -x '*~' libnl3/lib/Makefile.am libnl3.new/lib/Makefile.am
48
 
--- libnl3/lib/Makefile.am      2012-04-02 15:34:46.760619334 -0400
49
 
+++ libnl3.new/lib/Makefile.am  2012-04-02 15:34:47.796619394 -0400
50
 
@@ -39,15 +39,19 @@
51
 
 # Hack to avoid using ylwrap. It does not function correctly in combination
52
 
 # with --header-file=
53
 
 route/pktloc_grammar.c: route/pktloc_grammar.l
54
 
+       $(AM_V_GEN) install -d route/
55
 
        $(AM_V_GEN) $(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
56
 
 
57
 
 route/pktloc_syntax.c: route/pktloc_syntax.y
58
 
+       $(AM_V_GEN) install -d route/
59
 
        $(AM_V_GEN) $(YACC) -d $(YFLAGS) -o $@ $^
60
 
 
61
 
 route/cls/ematch_grammar.c: route/cls/ematch_grammar.l
62
 
+       $(AM_V_GEN) install -d route/cls/
63
 
        $(AM_V_GEN) $(LEX) --header-file=route/cls/ematch_grammar.h $(LFLAGS) -o $@ $^
64
 
 
65
 
 route/cls/ematch_syntax.c: route/cls/ematch_syntax.y
66
 
+       $(AM_V_GEN) install -d route/cls/
67
 
        $(AM_V_GEN) $(YACC) -d $(YFLAGS) -o $@ $^
68
 
 
69
 
 libnl_route_3_la_LIBADD  = libnl-3.la
70
 
diff -Nur -x '*.orig' -x '*~' libnl3/lib/Makefile.in libnl3.new/lib/Makefile.in
71
 
--- libnl3/lib/Makefile.in      2012-04-02 15:17:22.222698000 -0400
72
 
+++ libnl3.new/lib/Makefile.in  2012-04-02 15:34:47.800619394 -0400
73
 
@@ -1274,15 +1274,19 @@
74
 
 # Hack to avoid using ylwrap. It does not function correctly in combination
75
 
 # with --header-file=
76
 
 route/pktloc_grammar.c: route/pktloc_grammar.l
77
 
+       $(AM_V_GEN) install -d route/
78
 
        $(AM_V_GEN) $(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
79
 
 
80
 
 route/pktloc_syntax.c: route/pktloc_syntax.y
81
 
+       $(AM_V_GEN) install -d route/
82
 
        $(AM_V_GEN) $(YACC) -d $(YFLAGS) -o $@ $^
83
 
 
84
 
 route/cls/ematch_grammar.c: route/cls/ematch_grammar.l
85
 
+       $(AM_V_GEN) install -d route/cls/
86
 
        $(AM_V_GEN) $(LEX) --header-file=route/cls/ematch_grammar.h $(LFLAGS) -o $@ $^
87
 
 
88
 
 route/cls/ematch_syntax.c: route/cls/ematch_syntax.y
89
 
+       $(AM_V_GEN) install -d route/cls/
90
 
        $(AM_V_GEN) $(YACC) -d $(YFLAGS) -o $@ $^
91
 
 
92
 
 # Tell versions [3.59,3.63) of GNU make to not export all variables.