~ubuntu-branches/ubuntu/saucy/libv8/saucy

« back to all changes in this revision

Viewing changes to debian/patches/0011_use_system_gyp.patch

  • Committer: Package Import Robot
  • Author(s): Jérémy Lal
  • Date: 2012-04-07 16:26:13 UTC
  • mfrom: (15.1.27 sid)
  • Revision ID: package-import@ubuntu.com-20120407162613-dqo1m6w9r3fh8tst
Tags: 3.8.9.16-3
* mipsel build fixes :
  + v8_use_mips_abi_hardfloat=false, this lowers EABI requirements.
  + v8_can_use_fpu_instructions=false, detect if FPU is present.
  + set -Wno-unused-but-set-variable only on mipsel.

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
Last-Update: 2011-10-22
5
5
--- a/Makefile
6
6
+++ b/Makefile
7
 
@@ -182,27 +182,27 @@
 
7
@@ -207,27 +207,27 @@
8
8
 
9
9
 # GYP file generation targets.
10
10
 $(OUTDIR)/Makefile-ia32: $(GYPFILES) $(ENVFILE)
36
36
+       gyp --generator-output="$(OUTDIR)" build/all.gyp \
37
37
                      -Ibuild/standalone.gypi --depth=. -S-native $(GYPFLAGS)
38
38
 
39
 
 # Replaces the old with the new environment file if they're different, which
 
39
 $(OUTDIR)/Makefile-android: $(GYPFILES) $(ENVFILE) build/android.gypi \