~ubuntu-branches/ubuntu/saucy/log4shib/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/debian-changes

  • Committer: Package Import Robot
  • Author(s): Russ Allbery
  • Date: 2013-06-25 16:11:47 UTC
  • mfrom: (1.1.4)
  • Revision ID: package-import@ubuntu.com-20130625161147-80aoffvyaw7k1xj9
Tags: 1.0.8-1
* New upstream release.
  - Use upstream fix for converting the thread ID to a string.
* Move doxygen and graphviz to Build-Depends-Indep now that the buildds
  have proper arch-specific build support.  The upstream build system
  should automatically decline to build the documentation if those
  packages aren't installed.

Show diffs side-by-side

added added

removed removed

Lines of Context:
7
7
 
8
8
For full commit history and separated commits, see the packaging Git
9
9
repository.
10
 
--- log4shib-1.0.7.orig/Makefile.am
11
 
+++ log4shib-1.0.7/Makefile.am
 
10
--- log4shib-1.0.8.orig/Makefile.am
 
11
+++ log4shib-1.0.8/Makefile.am
12
12
@@ -2,12 +2,12 @@ AUTOMAKE_OPTIONS = foreign
13
13
 ACLOCAL_AMFLAGS = -I m4
14
14
 
25
25
 
26
26
 bin_SCRIPTS = log4shib-config
27
27
 
28
 
--- log4shib-1.0.7.orig/configure.ac
29
 
+++ log4shib-1.0.7/configure.ac
 
28
--- log4shib-1.0.8.orig/configure.ac
 
29
+++ log4shib-1.0.8/configure.ac
30
30
@@ -168,7 +168,6 @@ include/Makefile
31
31
 include/log4shib/Makefile
32
32
 include/log4shib/threading/Makefile
35
35
 msvc6/Makefile
36
36
 msvc6/log4shib/Makefile
37
37
 msvc6/log4shibDLL/Makefile
38
 
--- log4shib-1.0.7.orig/src/PThreads.cpp
39
 
+++ log4shib-1.0.7/src/PThreads.cpp
40
 
@@ -6,8 +6,8 @@ namespace log4shib {
41
 
     namespace threading {
42
 
 
43
 
         std::string getThreadId() {
44
 
-            char buffer[16];
45
 
-            ::sprintf(buffer, "%ld", pthread_self());
46
 
+            char buffer[32];
47
 
+            ::sprintf(buffer, "%ld", (long) pthread_self());
48
 
             return std::string(buffer);     
49
 
         }
50