~ubuntu-branches/ubuntu/saucy/mupen64plus-video-arachnoid/saucy

« back to all changes in this revision

Viewing changes to debian/patches/unused_glu.patch

  • Committer: Package Import Robot
  • Author(s): Sven Eckelmann
  • Date: 2013-05-05 14:21:41 UTC
  • mfrom: (3.1.3 experimental)
  • Revision ID: package-import@ubuntu.com-20130505142141-hu122rcme4kvwy7c
Tags: 1.99.5-2
* Upload to unstable
* Remove obsolete DM-Upload-Allowed in debian/control
* Disable extra debug code in release builds with -DNDEBUG in
  debian/rules

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Remove unused dependency to GLU
2
 
 The OpenGL Utility Library was only used in a dead code path and can be
3
 
 removed without loosing any functionality.
4
 
Author: Sven Eckelmann <sven@narfation.org>
5
 
 
6
 
---
7
 
diff --git a/projects/msvc9/GraphicsPlugin.vcproj b/projects/msvc9/GraphicsPlugin.vcproj
8
 
index ef34ea6b467bd96422ee218664cb49c5c3376011..72aa48485e72e2e8d11fc58385c7a2a1beea3a9a 100755
9
 
--- a/projects/msvc9/GraphicsPlugin.vcproj
10
 
+++ b/projects/msvc9/GraphicsPlugin.vcproj
11
 
@@ -64,7 +64,7 @@
12
 
                        />
13
 
                        <Tool
14
 
                                Name="VCLinkerTool"
15
 
-                               AdditionalDependencies="opengl32.lib glu32.lib"
16
 
+                               AdditionalDependencies="opengl32.lib"
17
 
                                OutputFile="mupen64plus-video-arachnoid.dll"
18
 
                                LinkIncremental="2"
19
 
                                GenerateDebugInformation="true"
20
 
@@ -143,7 +143,7 @@
21
 
                        />
22
 
                        <Tool
23
 
                                Name="VCLinkerTool"
24
 
-                               AdditionalDependencies="opengl32.lib glu32.lib"
25
 
+                               AdditionalDependencies="opengl32.lib"
26
 
                                OutputFile="mupen64plus-video-arachnoid.dll"
27
 
                                LinkIncremental="1"
28
 
                                GenerateDebugInformation="true"
29
 
diff --git a/projects/unix/Makefile b/projects/unix/Makefile
30
 
index 2ff6a0d4e712860c8016bdc981f8d8edb59aaf80..d6f73a11e784a6a7a5c6a32ad2eaa9e4c8e83243 100755
31
 
--- a/projects/unix/Makefile
32
 
+++ b/projects/unix/Makefile
33
 
@@ -120,12 +120,9 @@ else
34
 
   ifeq ($(shell pkg-config --modversion gl 2>/dev/null),)
35
 
     $(error No OpenGL development libraries found!)
36
 
   endif
37
 
-  ifeq ($(shell pkg-config --modversion glu 2>/dev/null),)
38
 
-    $(error No OpenGL utility development libraries found!)
39
 
-  endif
40
 
 
41
 
-  CFLAGS += -pthread $(shell pkg-config --cflags gl glu)
42
 
-  LDLIBS += -pthread $(shell pkg-config --libs gl glu)
43
 
+  CFLAGS += -pthread $(shell pkg-config --cflags gl)
44
 
+  LDLIBS += -pthread $(shell pkg-config --libs gl)
45
 
 endif
46
 
 ifeq ($(OS), LINUX)
47
 
   LDLIBS += -ldl 
48
 
diff --git a/src/GraphicsPlugin.cpp b/src/GraphicsPlugin.cpp
49
 
index 1afc14e9c0b39e9f4cdb06ed781e5538951985eb..959c8f467237dc01bc65151f0c9b7e0e3dc99f6a 100755
50
 
--- a/src/GraphicsPlugin.cpp
51
 
+++ b/src/GraphicsPlugin.cpp
52
 
@@ -309,89 +309,6 @@ void renderRedBox(float x, float y, float z, float width, float height,  float l
53
 
     glEnd();
54
 
 }
55
 
 
56
 
-void GraphicsPlugin::_motionBlur()
57
 
-{
58
 
-        glMatrixMode(GL_PROJECTION);                    
59
 
-        glLoadIdentity();                                    
60
 
-        gluPerspective(45.0f,(GLfloat)800.0f/(GLfloat)600.0f, .5f ,150.0f);
61
 
-
62
 
-        glMatrixMode(GL_MODELVIEW);
63
 
-        glLoadIdentity();
64
 
-        gluLookAt(0, 0, 10,     0, 0, 0,     0, 1, 0);        
65
 
-
66
 
-        ////Render new stuff to the motion blur texture
67
 
-        if ( animate(50) )
68
 
-        {
69
 
-            //Render to frame buffer
70
 
-//            framebuffer01.beginRendering();
71
 
-            {
72
 
-                renderMotionBlur();
73
 
-                
74
 
-                glMatrixMode(GL_PROJECTION);                    
75
 
-                glLoadIdentity();                                    
76
 
-                gluPerspective(45.0f,(GLfloat)800.0f/(GLfloat)600.0f, .5f ,150.0f);
77
 
-
78
 
-                glMatrixMode(GL_MODELVIEW);
79
 
-                glLoadIdentity();
80
 
-                gluLookAt(0, 0, 10,     0, 0, 0,     0, 1, 0);    
81
 
-
82
 
-                renderRedBox(0, 0, 0,    1, 5, 1);
83
 
-                //m_displayListParser->processDisplayList();
84
 
-
85
 
-        
86
 
-            }
87
 
-            glFlush();
88
 
-           // framebuffer01.endRendering();
89
 
-            glClear(GL_COLOR_BUFFER_BIT | GL_DEPTH_BUFFER_BIT);    
90
 
-        }
91
 
-
92
 
-        //glDisable(GL_BLEND);
93
 
-        //glEnable(GL_DEPTH_TEST);
94
 
-
95
 
-        //renderMotionBlur();
96
 
-        //renderTriangle();
97
 
-
98
 
-        renderMotionBlur();
99
 
-
100
 
-     //   glMatrixMode(GL_PROJECTION);                        
101
 
-        //glLoadIdentity();                                    
102
 
-        //gluPerspective(45.0f,(GLfloat)800.0f/(GLfloat)600.0f, .5f ,150.0f);
103
 
-
104
 
-     //   glMatrixMode(GL_MODELVIEW);
105
 
-     //   glLoadIdentity();
106
 
-        //gluLookAt(0, 0, 10,     0, 0, 0,     0, 1, 0);        
107
 
-
108
 
-        //renderRedBox(0, 0, 0,    1, 5, 1);
109
 
-
110
 
-        m_rdp.triggerInterrupt();
111
 
-        m_rsp.triggerInterrupt();
112
 
-        
113
 
-
114
 
-        //Render new stuff to frame buffer
115
 
-        //framebuffer02.beginRendering();
116
 
-        {
117
 
-      //      m_displayListParser->processDisplayList();  
118
 
-      //      RSP::getSingleton().reset();
119
 
-      //      RDP::getSingleton().reset();
120
 
-
121
 
-      //      glClear(GL_COLOR_BUFFER_BIT | GL_DEPTH_BUFFER_BIT);    
122
 
-      //      glDisable(GL_BLEND);
123
 
-      //      glEnable(GL_DEPTH_TEST);
124
 
-      //      glDisable(GL_ALPHA_TEST);
125
 
-            //m_displayListParser->processDisplayList();
126
 
-        }
127
 
-        //glFlush();
128
 
-        //framebuffer02.endRendering();
129
 
-        //glClear(GL_COLOR_BUFFER_BIT | GL_DEPTH_BUFFER_BIT);    
130
 
-
131
 
-        //Blend old stuff and new stuff      
132
 
-
133
 
-        //framebuffer02.render2();
134
 
-        
135
 
-        //FrameBuffer::getSingleton().render();
136
 
-
137
 
-}
138
 
-
139
 
 //-----------------------------------------------------------------------------
140
 
 // ProcessDisplayList
141
 
 //-----------------------------------------------------------------------------
142
 
@@ -448,18 +365,7 @@ void GraphicsPlugin::processDisplayList()
143
 
         m_rsp.reset();
144
 
         m_rdp.reset();
145
 
         m_openGLMgr.setCullMode(false, true);
146
 
-
147
 
-
148
 
-        if ( false )
149
 
-        {
150
 
-            _motionBlur();
151
 
-        }
152
 
-        else 
153
 
-        {
154
 
-            m_displayListParser->processDisplayList();
155
 
-            
156
 
-        }
157
 
-        
158
 
+        m_displayListParser->processDisplayList();
159
 
     }
160
 
 
161
 
         //Clear Screen?
162
 
diff --git a/src/OpenGLManager.h b/src/OpenGLManager.h
163
 
index 380a8c3b9129d08ace98ad289213e647351a9094..3359cf231208100adf0a1084cce3e0b1d501a141 100755
164
 
--- a/src/OpenGLManager.h
165
 
+++ b/src/OpenGLManager.h
166
 
@@ -26,7 +26,6 @@
167
 
 //OpenGL includes
168
 
 #include "m64p.h"
169
 
 #include "OpenGL.h"
170
 
-#include <GL/glu.h>
171
 
 
172
 
 //*****************************************************************************
173
 
 //* OpenGL Manager Class                                                        
174
 
diff --git a/src/texture/ImageFormatSelector.cpp b/src/texture/ImageFormatSelector.cpp
175
 
index 716368e9a512630a38bb6588a84d7b17790a985f..8d705966eea932875b5d179b4b300c364ac36ff0 100755
176
 
--- a/src/texture/ImageFormatSelector.cpp
177
 
+++ b/src/texture/ImageFormatSelector.cpp
178
 
@@ -32,7 +32,6 @@
179
 
 #include "GBIDefs.h"
180
 
 #include "m64p.h"
181
 
 #include "OpenGL.h"
182
 
-#include <GL/glu.h>
183
 
 #include "Memory.h"
184
 
 
185
 
 #ifndef GL_EXT_packed_pixels