~ubuntu-branches/ubuntu/saucy/net-dns-fingerprint/saucy

« back to all changes in this revision

Viewing changes to debian/patches/01-Fingerprint.pm.patch

  • Committer: Package Import Robot
  • Author(s): Thorsten Alteholz, Jari Aalto
  • Date: 2012-03-10 15:00:00 UTC
  • Revision ID: package-import@ubuntu.com-20120310150000-9v7uc51zibx30cmy
Tags: 0.9.3-4
* debian/rules: use only one changelog (Closes: #614707)
* debian/rules: replace $PREFIX by $DESTDIR in make call
* debian/control: remove not needed Priority:-lines in
                  binary packages
* debian/control: remove not needed Section:-line for
                  fpdns
* debian/control: add ${misc:Depends} to fpdns

[ Jari Aalto ]
* Remove deprecated dpatch and upgrade to packaging format "3.0 quilt".
  Note: patch 03 was updated with "quilt refresh" to make
  it apply cleanly.
* Update to Standards-Version to 3.9.3 and debhelper to 9.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Thorsten Alteholz  <debian@alteholz.de>
 
2
Subject: Make separator configurable
 
3
 
 
4
--- Net-DNS-Fingerprint-0.9.3/Fingerprint.pm    2005-09-05 15:33:36.000000000 +0200
 
5
+++ net-dns-fingerprint-0.9.3/Fingerprint.pm    2009-10-08 22:23:37.000000000 +0200
 
6
@@ -46,6 +46,7 @@
 
7
     debug    => 0,
 
8
     qversion => 0,
 
9
     qchaos   => 0,
 
10
+    separator => " ",
 
11
 );
 
12
 
 
13
 my $versionlength = 40;
 
14
@@ -470,7 +471,7 @@
 
15
 
 
16
     push @s, "($r{state};$r{id})" if($self->{debug});
 
17
 
 
18
-    return join(" ", @s);
 
19
+    return join($self->{separator}, @s);
 
20
 }
 
21
 
 
22
 sub query_version