~ubuntu-branches/ubuntu/saucy/network-manager-applet/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/hide_policy_items_env_var.patch

  • Committer: Package Import Robot
  • Author(s): Mathieu Trudel-Lapierre
  • Date: 2013-03-08 11:47:45 UTC
  • mfrom: (105.1.1 raring-proposed)
  • Revision ID: package-import@ubuntu.com-20130308114745-7p3ns9ikmfcluod4
Tags: 0.9.8.0-1ubuntu2
debian/control: add docbook-to-man to Build-Depends, missing in the
previous upload.

Show diffs side-by-side

added added

removed removed

Lines of Context:
16
16
===================================================================
17
17
--- a/src/applet.c
18
18
+++ b/src/applet.c
19
 
@@ -1639,8 +1639,16 @@ nma_menu_device_get_menu_item (NMDevice
 
19
@@ -1628,8 +1628,16 @@ nma_menu_device_get_menu_item (NMDevice
20
20
                                       (GClosureNotify) applet_device_info_destroy, 0);
21
21
                if (is_permission_yes (applet, NM_CLIENT_PERMISSION_NETWORK_CONTROL))
22
22
                        gtk_widget_set_sensitive (item, TRUE);
34
34
                break;
35
35
        }
36
36
        default:
37
 
@@ -1778,6 +1786,8 @@ nma_menu_add_vpn_submenu (GtkWidget *men
 
37
@@ -1767,6 +1775,8 @@ nma_menu_add_vpn_submenu (GtkWidget *men
38
38
        GtkMenuItem *item;
39
39
        GSList *list, *iter;
40
40
        int num_vpn_active = 0;
43
43
 
44
44
        vpn_menu = GTK_MENU (gtk_menu_new ());
45
45
 
46
 
@@ -1845,30 +1855,58 @@ nma_menu_add_vpn_submenu (GtkWidget *men
 
46
@@ -1834,30 +1844,58 @@ nma_menu_add_vpn_submenu (GtkWidget *men
47
47
                gtk_menu_shell_append (GTK_MENU_SHELL (vpn_menu), GTK_WIDGET (item));
48
48
        }
49
49
 
109
109
        }
110
110
 
111
111
        g_slist_free (list);
112
 
@@ -1954,6 +1992,8 @@ nma_set_notifications_enabled_cb (GtkWid
 
112
@@ -1943,6 +1981,8 @@ nma_set_notifications_enabled_cb (GtkWid
113
113
 static void nma_menu_show_cb (GtkWidget *menu, NMApplet *applet)
114
114
 {
115
115
        guint32 n_wifi;
118
118
 
119
119
        g_return_if_fail (menu != NULL);
120
120
        g_return_if_fail (applet != NULL);
121
 
@@ -1973,10 +2013,21 @@ static void nma_menu_show_cb (GtkWidget
 
121
@@ -1962,10 +2002,21 @@ static void nma_menu_show_cb (GtkWidget
122
122
        n_wifi = nma_menu_add_devices (menu, applet);
123
123
 
124
124
        if (n_wifi > 0 && nm_client_wireless_get_enabled (applet->nm_client)) {
141
141
        }
142
142
 
143
143
        nma_menu_add_vpn_submenu (menu, applet);
144
 
@@ -2152,6 +2203,7 @@ nma_context_menu_update (NMApplet *apple
 
144
@@ -2141,6 +2192,7 @@ nma_context_menu_update (NMApplet *apple
145
145
                 * so set the "Edit Connections..." menu item insensitive.
146
146
                 */
147
147
                gtk_widget_set_sensitive (applet->connections_menu_item, FALSE);
149
149
        }
150
150
 }
151
151
 
152
 
@@ -4117,6 +4169,10 @@ static void nma_init (NMApplet *applet)
 
152
@@ -3987,6 +4039,10 @@ static void nma_init (NMApplet *applet)
153
153
        applet->icon_theme = NULL;
154
154
        applet->notification = NULL;
155
155
        applet->icon_size = 16;