~ubuntu-branches/ubuntu/saucy/pdfresurrect/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/fix_manpage_path.patch

  • Committer: Package Import Robot
  • Author(s): Francois Marier
  • Date: 2012-05-28 13:47:34 UTC
  • Revision ID: package-import@ubuntu.com-20120528134734-t1dxfx9xg70a3viq
Tags: 0.10-4
* Switch to a minimal debian/rules file
* Add patch for DESTDIR support in Makefile
* Add patch to fix manpage path
* Add patch to add LDFLAGS support in the Makefile
* Add patch to add CPPFLAGS support in the Makefile
* Don't overwrite external CFLAGS in configure script

* Bump Standards-Version up to 3.9.3
* Bump debhelper compatibility to 9

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Install the manpage in the right path on Debian systems
 
2
Forwarded: no
 
3
Author: Francois Marier <francois@debian.org>
 
4
Last-Update: 2012-05-28
 
5
 
 
6
--- a/Makefile.in
 
7
+++ b/Makefile.in
 
8
@@ -15,11 +15,11 @@ $(APP): $(OBJS)
 
9
 
 
10
 install:
 
11
        cp $(APP) $(DESTDIR)$(PREFIX)/bin/
 
12
-       cp $(MANPAGE) $(DESTDIR)$(PREFIX)/man/man1/
 
13
+       cp $(MANPAGE) $(DESTDIR)$(PREFIX)/share/man/man1/
 
14
 
 
15
 uninstall:
 
16
        rm $(DESTDIR)$(PREFIX)/bin/$(APP)
 
17
-       rm $(DESTDIR)$(PREFIX)/man/man1/$(MANPAGE)
 
18
+       rm $(DESTDIR)$(PREFIX)/share/man/man1/$(MANPAGE)
 
19
 
 
20
 clean:
 
21
        rm -rfv $(OBJS) $(APP)