~ubuntu-branches/ubuntu/saucy/psicode/saucy

« back to all changes in this revision

Viewing changes to debian/patches/11_testsuite.patch

  • Committer: Package Import Robot
  • Author(s): Debichem Team, Michael Banck, Daniel Leidert
  • Date: 2013-08-07 22:48:32 UTC
  • mfrom: (5.1.4 sid)
  • Revision ID: package-import@ubuntu.com-20130807224832-l2s29edqjwdhbp77
Tags: 3.4.0-5
[ Michael Banck ]
* debian/patches/11_testsuite.patch: New patch, adds CCSD(T)/CASSCF
  geometry optimizations with analytical gradients and CC2/EOM-CCSD/MRCC
  energies to quicktests.  Further, do not exit immediately if one test
  fails.
* debian/patches/12_613088_fix_manpage.patch: New patch, removes the
  mangling of the main psi3 manpage with macros (closes: #613088).
* debian/upstream: Removed WIREs article for now as it is specfic to PSI4.
* debian/rules (override_dh_auto_test): Only run testsuite if
  DEB_BUILD_OPTIONS does not contain `nocheck', as per policy.
* debian/psirc.example: New file, contains an example ~/.psirc.
* debian/rules (override_dh_auto_install): Install it.

[ Daniel Leidert ]
* debian/compat: Increased level to 7.
* debian/control (Uploaders): Removed myself.
  (Standards-Version): Bumped to 3.9.4.
  (Build-Depends): Added required version for autotools-dev addon. Replaced
  bison by byacc (closes: #713570).
  (Vcs-Browser, Vcs-Svn): Fixed vcs-field-not-canonical.
  (DM-Upload-Allowed): Dropped.
* debian/dirs: Renamed to debian/psi3.dirs.
* debian/docs: Renamed to debian/psi3.docs. Added user manual.
* debian/psi3.doc-base: Added.
* debian/rules: Use variables instead of commands (e.g. MAKE, RM). Call
  the autotools_dev addon.
  (override_dh_auto_test): Removed the nofilter check. dh will do this.
* debian/upstream: Added.
* debian/README.source: Dropped obsolete file.
* debian/TODO: Dropped.
* debian/patches/*.patch: Added header tags.
* debian/patches/13_parallel-make.patch: Added.
  - Try to improve the compilation process of flex/byacc related stuff.
* debian/patches/14_fix_typos.patch: Added.
  - Fix spelling errors.
* debian/patches/series: Adjusted.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Michael Banck <mbanck@debian.org>
 
2
Description: Add CCSD(T)/CASSCF geometry optimizations and CC2/EOM-CCSD/MRCC
 
3
energies to quicktests and do not exit immediately if a test fails.
 
4
 
 
5
--- a/tests/Makefile.in
 
6
+++ b/tests/Makefile.in
 
7
@@ -50,50 +50,50 @@
 
8
 
 
9
 # the bare minimum
 
10
 quicktestdirs = scf-opt scf-freq scf-polar rhf-stab \
 
11
-rhf-oeprop cc1 mp2-opt mp2-direct-sp mp2-scs \
 
12
-dboc-rhf1 mp2r12-sp1 rhf-lindep1 cisd-sp casscf-sp \
 
13
-psi_start
 
14
+rhf-oeprop cc1 cc12 cc13a cc36 mp2-opt mp2-direct-sp mp2-scs \
 
15
+dboc-rhf1 mp2r12-sp1 rhf-lindep1 cisd-sp casscf-sp casscf-opt \
 
16
+psimrcc-sp1 psi_start
 
17
 
 
18
 tests:
 
19
        for dir in $(subdirs); \
 
20
        do \
 
21
-        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE)) || exit 1; \
 
22
+        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE) && exit 0); \
 
23
        done
 
24
 
 
25
 quicktests:
 
26
        for dir in $(quicktestdirs); \
 
27
        do \
 
28
-        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE)) || exit 1; \
 
29
+        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE) && exit 0); \
 
30
        done
 
31
 
 
32
 cc_tests:
 
33
        for dir in $(cc_subdirs); \
 
34
        do \
 
35
-        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE)) || exit 1; \
 
36
+        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE) && exit 0); \
 
37
        done
 
38
 
 
39
 ci_tests:
 
40
        for dir in $(ci_subdirs); \
 
41
        do \
 
42
-        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE)) || exit 1; \
 
43
+        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE) && exit 0); \
 
44
        done
 
45
 
 
46
 mcscf_tests:
 
47
        for dir in $(mcscf_subdirs); \
 
48
        do \
 
49
-        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE)) || exit 1; \
 
50
+        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE) && exit 0); \
 
51
        done
 
52
 
 
53
 scf_tests:
 
54
        for dir in $(scf_subdirs); \
 
55
        do \
 
56
-        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE)) || exit 1; \
 
57
+        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE) && exit 0); \
 
58
        done
 
59
 
 
60
 psirb_tests:
 
61
        for dir in $(rb_subdirs); \
 
62
        do \
 
63
-        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE)) || exit 1; \
 
64
+        (cd $${dir} && echo ...Testing $${dir}... && $(MAKE) && exit 0); \
 
65
        done
 
66
 
 
67
 clean: