~ubuntu-branches/ubuntu/saucy/pyao/saucy

« back to all changes in this revision

Viewing changes to debian/patches/python25.patch

  • Committer: Package Import Robot
  • Author(s): Luca Falavigna
  • Date: 2011-12-11 15:21:43 UTC
  • mfrom: (3.1.5 sid)
  • Revision ID: package-import@ubuntu.com-20111211152143-jg9tr0yq8mqpu3ge
Tags: 0.82-5
* QA upload.
* Switch to format 3.0 (quilt).
* debian/patches/*:
  - Convert inline patches to quilt ones.
* debian/compat:
  - Bump compatibility level to 8.
* debian/control:
  - Bump X-Python-Version to >= 2.5.
  - Bump Standards-Version to 3.9.2.
  - Drop Breaks: ${python:Breaks} field, no longer needed.
  - Add debug package.
* debian/rules:
  - Pass --dbg-package to dh to build the debug package.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Fix FTBFS with python2.5
 
2
Author: Philipp Jocham
 
3
 
 
4
Index: pyao-0.82/src/aomodule.c
 
5
===================================================================
 
6
--- pyao-0.82.orig/src/aomodule.c       2011-12-10 14:22:01.816344171 +0100
 
7
+++ pyao-0.82/src/aomodule.c    2011-12-10 14:22:33.600345144 +0100
 
8
@@ -4,7 +4,7 @@
 
9
 static ao_option *
 
10
 dict_to_options(PyObject *dict)
 
11
 {
 
12
-  int pos = 0;
 
13
+  Py_ssize_t pos = 0;
 
14
   PyObject *key, *val;
 
15
   ao_option *head = NULL;
 
16
   int ret;