~ubuntu-branches/ubuntu/saucy/pyicu/saucy

« back to all changes in this revision

Viewing changes to debian/patches/platform-definitions-fix.diff

  • Committer: Package Import Robot
  • Author(s): B. Clausius
  • Date: 2013-07-20 21:40:05 UTC
  • mfrom: (3.1.11 sid)
  • Revision ID: package-import@ubuntu.com-20130720214005-nm54wkpjtejljck3
Tags: 1.5-2ubuntu1
* Resynchronise with Debian.
* Added transitional packages python3-pyicu[-dbg] to migrate
  to python3-icu[-dbg]

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## platform-definitions-fix.dpatch by Jakub Wilk <jwilk@debian.org>
 
3
##
 
4
## DP: Fixing FTBFS due to new platform definitions. Setup.py doesn't need to
 
5
## DP: take care of them in our case.
 
6
 
 
7
@DPATCH@
 
8
Index: PyICU-1.5/setup.py
 
9
===================================================================
 
10
--- PyICU-1.5.orig/setup.py
 
11
+++ PyICU-1.5/setup.py
 
12
@@ -48,7 +48,7 @@ LIBRARIES = {
 
13
 }
 
14
 
 
15
 platform = sys.platform
 
16
-if platform.startswith('linux'):
 
17
+if platform.startswith('linux') or platform.startswith('gnu'):
 
18
     platform = 'linux'
 
19
 
 
20
 if 'PYICU_INCLUDES' in os.environ: