~ubuntu-branches/ubuntu/saucy/qemu/saucy

« back to all changes in this revision

Viewing changes to debian/patches/patches-arm-1.3.0/0032-fix-omap_spi-rxs-flag-status-update.patch

  • Committer: Package Import Robot
  • Author(s): Serge Hallyn
  • Date: 2013-02-22 13:34:07 UTC
  • mfrom: (2.1.36 raring)
  • Revision ID: package-import@ubuntu.com-20130222133407-ny5zhxn2lm3rr0r8
Tags: 1.4.0+dfsg-1expubuntu2
* substitute (apparently identical) patches from 1.4.0 qemu-linaro rebasing
  tree.
* add qemu-common to qemu-system-common B/R (was accidentally dropped from
  1.3.0 in 1.4.0 merge).
* debian/control: fix kvm P/C/B/R:
  - make all C/B/R against kvm versioned
  - don't have any qemu-system-* other than x86 Provides: kvm

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From cfd6e7653fcf3d7d7419e6555547770447d318ee Mon Sep 17 00:00:00 2001
2
 
From: =?UTF-8?q?Juha=20Riihim=C3=A4ki?= <juha.riihimaki@nokia.com>
3
 
Date: Tue, 4 Dec 2012 14:10:08 +0000
4
 
Subject: [PATCH 32/77] fix omap_spi rxs flag status update
5
 
MIME-Version: 1.0
6
 
Content-Type: text/plain; charset=UTF-8
7
 
Content-Transfer-Encoding: 8bit
8
 
 
9
 
Signed-off-by: Juha Riihimäki <juha.riihimaki@nokia.com>
10
 
---
11
 
 hw/omap_spi.c | 5 ++++-
12
 
 1 file changed, 4 insertions(+), 1 deletion(-)
13
 
 
14
 
diff --git a/hw/omap_spi.c b/hw/omap_spi.c
15
 
index 060e82c..6d173a1 100644
16
 
--- a/hw/omap_spi.c
17
 
+++ b/hw/omap_spi.c
18
 
@@ -229,8 +229,11 @@ static void omap_mcspi_transfer_run(OMAPSPIBusState *s, int chnum)
19
 
     ch->tx = 0;
20
 
     ch->status |= 1 << 2;               /* EOT */
21
 
     ch->status |= 1 << 1;               /* TXS */
22
 
-    if (trm != 2)
23
 
+    if (trm != 2) {
24
 
         ch->status |= 1;                /* RXS */
25
 
+    } else {
26
 
+        ch->status &= ~1;               /* RXS */
27
 
+    }
28
 
 
29
 
 intr_update:
30
 
     if ((ch->status & 1) &&    trm != 2 &&                     /* RXS */
31
 
1.8.1.2
32