~ubuntu-branches/ubuntu/saucy/tomboy/saucy

« back to all changes in this revision

Viewing changes to debian/patches/04_app_indicator.patch

  • Committer: Package Import Robot
  • Author(s): Iain Lane
  • Date: 2013-06-09 19:50:26 UTC
  • mfrom: (1.5.19)
  • Revision ID: package-import@ubuntu.com-20130609195026-e6u7c3nonn594cl4
Tags: 1.15.2-1ubuntu1
* Rebase on Debian experimental, remaining changes
  + Ubuntu patches:
    - Add app indicator support
    - Update libproxy DLLmap for libproxy.so.1

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
=== modified file 'Tomboy/Makefile.am'
2
 
Index: tomboy/Tomboy/Makefile.am
3
 
===================================================================
4
 
--- tomboy.orig/Tomboy/Makefile.am      2012-06-05 22:05:41.385783742 +0100
5
 
+++ tomboy/Tomboy/Makefile.am   2012-06-05 22:05:45.753783550 +0100
 
2
--- a/Tomboy/Makefile.am
 
3
+++ b/Tomboy/Makefile.am
6
4
@@ -122,6 +122,7 @@
7
5
        $(srcdir)/Tag.cs                        \
8
6
        $(srcdir)/TagButton.cs                  \
19
17
        $(GNOME_LIBS)   \
20
18
        -r:Mono.Posix   \
21
19
        $(DBUS_LIBS)    \
22
 
Index: tomboy/Tomboy/NoteManager.cs
23
 
===================================================================
24
 
--- tomboy.orig/Tomboy/NoteManager.cs   2012-06-05 22:05:41.385783742 +0100
25
 
+++ tomboy/Tomboy/NoteManager.cs        2012-06-05 22:05:45.753783550 +0100
 
20
--- a/Tomboy/NoteManager.cs
 
21
+++ b/Tomboy/NoteManager.cs
26
22
@@ -369,6 +369,9 @@
27
23
                        // Update the trie so addins can access it, if they want.
28
24
                        trie_controller.Update ();
33
29
                        bool startup_notes_enabled = (bool)
34
30
                                                     Preferences.Get (Preferences.ENABLE_STARTUP_NOTES);
35
31
 
36
 
Index: tomboy/Tomboy/RecentChanges.cs
37
 
===================================================================
38
 
--- tomboy.orig/Tomboy/RecentChanges.cs 2012-06-05 22:05:41.385783742 +0100
39
 
+++ tomboy/Tomboy/RecentChanges.cs      2012-06-05 22:05:45.753783550 +0100
40
 
@@ -247,7 +247,8 @@
 
32
--- a/Tomboy/RecentChanges.cs
 
33
+++ b/Tomboy/RecentChanges.cs
 
34
@@ -248,7 +248,8 @@
41
35
                        am ["DeleteNotebookAction"].Activated += OnDeleteNotebook;
42
36
                        am ["CloseWindowAction"].Activated += OnCloseWindow;
43
37
                        if (Tomboy.TrayIconShowing == false &&
47
41
                                am ["CloseWindowAction"].Visible = false;
48
42
 
49
43
                        // Allow Escape to close the window as well as <Control>W
50
 
@@ -1141,7 +1142,8 @@
 
44
@@ -1127,7 +1128,8 @@
51
45
                        instance = null;
52
46
 #if !MAC
53
47
                        if (Tomboy.TrayIconShowing == false &&
57
51
                                Tomboy.ActionManager ["QuitTomboyAction"].Activate ();
58
52
 #endif
59
53
                }
60
 
Index: tomboy/Tomboy/Tomboy.cs
61
 
===================================================================
62
 
--- tomboy.orig/Tomboy/Tomboy.cs        2012-06-05 22:05:41.385783742 +0100
63
 
+++ tomboy/Tomboy/Tomboy.cs     2012-06-05 22:05:45.753783550 +0100
 
54
--- a/Tomboy/Tomboy.cs
 
55
+++ b/Tomboy/Tomboy.cs
64
56
@@ -191,11 +191,17 @@
65
57
 #endif
66
58
                }
82
74
                        StartMainLoop ();
83
75
                }
84
76
 
85
 
Index: tomboy/Tomboy/TomboyIndicatorTray.cs
86
 
===================================================================
87
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
88
 
+++ tomboy/Tomboy/TomboyIndicatorTray.cs        2012-06-05 22:05:45.753783550 +0100
 
77
--- /dev/null
 
78
+++ b/Tomboy/TomboyIndicatorTray.cs
89
79
@@ -0,0 +1,180 @@
90
80
+//  
91
81
+//  Copyright (C) 2009 GNOME Do
267
257
+               }
268
258
+       }
269
259
+}
270
 
Index: tomboy/configure.in
271
 
===================================================================
272
 
--- tomboy.orig/configure.in    2012-06-05 22:05:41.385783742 +0100
273
 
+++ tomboy/configure.in 2012-06-05 22:05:45.753783550 +0100
 
260
--- a/configure.in
 
261
+++ b/configure.in
274
262
@@ -207,6 +207,10 @@
275
263
                  gtk-sharp-2.0 >= $GTKSHARP2_MINIMUM_VERSION)
276
264
 AC_SUBST(GTKSHARP_LIBS)
282
270
 #
283
271
 # Printing at least needs Mono.Cairo
284
272
 #
285
 
Index: tomboy/po/POTFILES.in
286
 
===================================================================
287
 
--- tomboy.orig/po/POTFILES.in  2012-06-05 22:05:41.385783742 +0100
288
 
+++ tomboy/po/POTFILES.in       2012-06-05 22:05:45.757783549 +0100
289
 
@@ -68,6 +68,7 @@
 
273
--- a/po/POTFILES.in
 
274
+++ b/po/POTFILES.in
 
275
@@ -70,6 +70,7 @@
290
276
 Tomboy/Synchronization/SyncManager.cs
291
277
 Tomboy/Synchronization/SyncUtils.cs
292
278
 Tomboy/Tomboy.cs