~ubuntu-branches/ubuntu/saucy/uim/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/07_fix_configure_notoverwrite_po_makefile.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): HIGUCHI Daisuke (VDR dai), HIGUCHI Daisuke (VDR dai)
  • Date: 2011-07-20 12:50:03 UTC
  • Revision ID: james.westby@ubuntu.com-20110720125003-2ryp5pguo9nqkw3z
Tags: 1:1.7.0-3
[ HIGUCHI Daisuke (VDR dai) ]
* debian/patches/
  - dropped merged/needless patches.
* debian/control
  - add Replaces/Breaks: to uim-common and uim-gtk2.0.
    add Suggests: to uim-xim. patches made by
    YOSHINO Yoshihito <yy.y.ja.jp@gmail.com> (Closes: #633401).
* rename plasma-widget-uim from uim-applet-kde (Closes: #583783).
  - debian/control: uim-applet-kde goes to dummy package.
  - debian/plasma-widget-uim.install: renamed from uim-applet-kde.install.
  - debian/rules: add plasma-widget-uim.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 07_fix_configure_notoverwrite_po_makefile.dpatch by  <kiwamu@debian.or.jp>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad uim-1.5.6~/configure uim-1.5.6/configure
9
 
--- uim-1.5.6~/configure        2009-06-23 19:59:29.000000000 +0900
10
 
+++ uim-1.5.6/configure 2009-09-11 14:02:59.000000000 +0900
11
 
@@ -43708,11 +43708,11 @@
12
 
        '"s|^|  $ac_top_srcdir/|" \
13
 
       "$srcdir/po/POTFILES.in" | sed '$!s/$/ \\/' >"po/POTFILES"
14
 
 
15
 
-    sed '/^POTFILES =/,/[^\\]$/ {
16
 
-               /^POTFILES =/!d
17
 
-               r po/POTFILES
18
 
-         }
19
 
-        ' "po/Makefile.in" >"po/Makefile"
20
 
+#    sed '/^POTFILES =/,/[^\\]$/ {
21
 
+#              /^POTFILES =/!d
22
 
+#              r po/POTFILES
23
 
+#        }
24
 
+#       ' "po/Makefile.in" >"po/Makefile"
25
 
     rm -f "po/Makefile.tmp"
26
 
     mv "po/stamp-it.tmp" "po/stamp-it"
27
 
    ;;
28
 
@@ -43730,11 +43730,11 @@
29
 
        '"s|^|  $ac_top_srcdir/|" \
30
 
       "$srcdir/qt/chardict/po/POTFILES.in" | sed '$!s/$/ \\/' >"qt/chardict/po/POTFILES"
31
 
 
32
 
-    sed '/^POTFILES =/,/[^\\]$/ {
33
 
-               /^POTFILES =/!d
34
 
-               r qt/chardict/po/POTFILES
35
 
-         }
36
 
-        ' "qt/chardict/po/Makefile.in" >"qt/chardict/po/Makefile"
37
 
+#    sed '/^POTFILES =/,/[^\\]$/ {
38
 
+#              /^POTFILES =/!d
39
 
+#              r qt/chardict/po/POTFILES
40
 
+#        }
41
 
+#       ' "qt/chardict/po/Makefile.in" >"qt/chardict/po/Makefile"
42
 
     rm -f "qt/chardict/po/Makefile.tmp"
43
 
     mv "qt/chardict/po/stamp-it.tmp" "qt/chardict/po/stamp-it"
44
 
    ;;