~ubuntu-branches/ubuntu/saucy/zoneminder/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/08_jpeg8.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Vagrant Cascadian, Peter Howard, Vagrant Cascadian
  • Date: 2011-07-24 16:44:30 UTC
  • mfrom: (15.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20110724164430-yibtwwjqlqb7hv1o
Tags: 1.24.4-1
[ Peter Howard ]
* Initial release of 1.24.4 (Closes: #634985).
  - Fix 32/64-bit type declarations (Closes: #614404).
* Update patches.

[ Vagrant Cascadian ]
* Add patch to fix FTBFS by using libv4l1-videodev.h from libv4l-dev.
  Thanks to Andreas Metzler for reporting the issue. 
  (Closes: #619813). 
* Document adding the www-data user to the video group in README.Debian.
  (Closes: #611324)
* Depend on libsys-mmap-perl to enable mapped memory support.
  (Closes: #607331)
* Update libjs-mootools patch to use -nc variants (Closes: #635075).
* Depend on javascript-common, to ensure that /javascript is available in 
  the web server.
* Set the upstream version in postinst at build time.
* Use dh-autoreconf to properly clean up autogenerated files during build.
* Add Vcs-HG to debian/control. 
* Add Build-Depends: libv4l-dev, libbz2-dev, dh-autoreconf, libsys-mmap-perl.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 08_jpeg8.dpatch by  <pjh@rhuiden.nridge.com.au>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad Zoneminder-1.24.2~/src/zm_image.cpp Zoneminder-1.24.2/src/zm_image.cpp
9
 
--- Zoneminder-1.24.2~/src/zm_image.cpp 2009-08-13 15:55:30.000000000 +1000
10
 
+++ Zoneminder-1.24.2/src/zm_image.cpp  2010-03-09 20:28:16.000000000 +1100
11
 
@@ -461,7 +461,7 @@
12
 
                return( false );
13
 
        }
14
 
 
15
 
-       jpeg_mem_src( cinfo, inbuffer, inbuffer_size );
16
 
+       zm_jpeg_mem_src( cinfo, inbuffer, inbuffer_size );
17
 
 
18
 
        jpeg_read_header( cinfo, TRUE );
19
 
 
20
 
@@ -523,7 +523,7 @@
21
 
                jpeg_create_compress( cinfo );
22
 
        }
23
 
 
24
 
-       jpeg_mem_dest( cinfo, outbuffer, outbuffer_size );
25
 
+       zm_jpeg_mem_dest( cinfo, outbuffer, outbuffer_size );
26
 
 
27
 
        cinfo->image_width = width;     /* image width and height, in pixels */
28
 
        cinfo->image_height = height;
29
 
diff -urNad Zoneminder-1.24.2~/src/zm_jpeg.c Zoneminder-1.24.2/src/zm_jpeg.c
30
 
--- Zoneminder-1.24.2~/src/zm_jpeg.c    2009-08-13 15:55:30.000000000 +1000
31
 
+++ Zoneminder-1.24.2/src/zm_jpeg.c     2010-03-09 20:28:16.000000000 +1100
32
 
@@ -173,7 +173,7 @@
33
 
  * for closing it after finishing compression.
34
 
  */
35
 
 
36
 
-void jpeg_mem_dest (j_compress_ptr cinfo, JOCTET *outbuffer, int *outbuffer_size )
37
 
+void zm_jpeg_mem_dest (j_compress_ptr cinfo, JOCTET *outbuffer, int *outbuffer_size )
38
 
 {
39
 
     mem_dest_ptr dest;
40
 
 
41
 
@@ -350,7 +350,7 @@
42
 
  * for closing it after finishing decompression.
43
 
  */
44
 
 
45
 
-void jpeg_mem_src( j_decompress_ptr cinfo, const JOCTET *inbuffer, int inbuffer_size )
46
 
+void zm_jpeg_mem_src( j_decompress_ptr cinfo, const JOCTET *inbuffer, int inbuffer_size )
47
 
 {
48
 
     mem_src_ptr src;
49
 
 
50
 
diff -urNad Zoneminder-1.24.2~/src/zm_jpeg.h Zoneminder-1.24.2/src/zm_jpeg.h
51
 
--- Zoneminder-1.24.2~/src/zm_jpeg.h    2009-08-13 15:55:30.000000000 +1000
52
 
+++ Zoneminder-1.24.2/src/zm_jpeg.h     2010-03-09 20:28:16.000000000 +1100
53
 
@@ -36,5 +36,5 @@
54
 
 void zm_jpeg_emit_message( j_common_ptr cinfo, int msg_level );
55
 
 
56
 
 // Prototypes for memory compress/decompression object */
57
 
-void jpeg_mem_src(j_decompress_ptr cinfo, const JOCTET *inbuffer, int inbuffer_size );
58
 
-void jpeg_mem_dest(j_compress_ptr cinfo, JOCTET *outbuffer, int *outbuffer_size );
59
 
+void zm_jpeg_mem_src(j_decompress_ptr cinfo, const JOCTET *inbuffer, int inbuffer_size );
60
 
+void zm_jpeg_mem_dest(j_compress_ptr cinfo, JOCTET *outbuffer, int *outbuffer_size );