~ubuntu-branches/ubuntu/trusty/activity-log-manager/trusty-updates

« back to all changes in this revision

Viewing changes to debian/patches/03_use_libwhoopsie-preferences.patch

  • Committer: Package Import Robot
  • Author(s): Iain Lane
  • Date: 2014-03-25 12:56:33 UTC
  • Revision ID: package-import@ubuntu.com-20140325125633-epl6k2b3y7q52f0x
Tags: 0.9.7-0ubuntu12
* debian/patches/10_build-with-gee-0.8.patch: Port to gee 0.8 API to avoid
  loading two gee versions in the same process (LP: #1293036)
* 01_really_hide_automatic_reports.patch: Delete, this is obsolete given
  03_use_libwhoopsie-preferences.patch. Add 13_hide_automatic_reports.patch
  to achieve this with that new patch. (LP: #1203042)
* 11_make_all_widgets_sensitive.patch: Recursively make all widgets
  sensitive/insensitive when we need to, to avoid missing some.
* 12_hide_lock_unlock_button.patch: Hide Lock button when it doesn't do
  anything (when the user can't drop the permissions). (LP: #1239752)
* 14_seconds_combo.patch: Make the entries translatable. (LP: #1235627)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
=== modified file 'configure.ac'
2
 
Index: activity-log-manager-0.9.7/configure.ac
 
2
Index: b/configure.ac
3
3
===================================================================
4
 
--- activity-log-manager-0.9.7.orig/configure.ac        2014-02-03 11:29:09.025259970 +0000
5
 
+++ activity-log-manager-0.9.7/configure.ac     2014-02-03 11:29:09.013259971 +0000
 
4
--- a/configure.ac
 
5
+++ b/configure.ac
6
6
@@ -46,7 +46,7 @@
7
7
 PKG_CHECK_MODULES(GEE, gee-1.0, [HAVE_GEE=yes])
8
8
 PKG_CHECK_MODULES(GIO_UNIX, gio-unix-2.0, [HAVE_GIO_UNIX=yes])
42
42
 if test "x$with_whoopsie" != xno && test "x$HAVE_POLKIT" != xno && test "x$HAVE_LIBWHOOPSIE" != xno; then
43
43
   AC_DEFINE([HAVE_WHOOPSIE], 1, [Enable Whoopsie])
44
44
   WHOOPSIE_ENABLE=yes
45
 
Index: activity-log-manager-0.9.7/data/Makefile.am
 
45
Index: b/data/Makefile.am
46
46
===================================================================
47
 
--- activity-log-manager-0.9.7.orig/data/Makefile.am    2014-02-03 11:29:09.025259970 +0000
48
 
+++ activity-log-manager-0.9.7/data/Makefile.am 2014-02-03 11:29:09.013259971 +0000
 
47
--- a/data/Makefile.am
 
48
+++ b/data/Makefile.am
49
49
@@ -33,10 +33,15 @@
50
50
     switchboard_DATA = alm-switchboard.plug
51
51
 endif
63
63
 CLEANFILES = activity-log-manager.desktop gnome-activity-log-manager-panel.desktop 
64
64
 
65
65
 check: $(desktop_DATA)
66
 
Index: activity-log-manager-0.9.7/po/POTFILES.in
 
66
Index: b/po/POTFILES.in
67
67
===================================================================
68
 
--- activity-log-manager-0.9.7.orig/po/POTFILES.in      2014-02-03 11:29:09.025259970 +0000
69
 
+++ activity-log-manager-0.9.7/po/POTFILES.in   2014-02-03 11:29:09.013259971 +0000
 
68
--- a/po/POTFILES.in
 
69
+++ b/po/POTFILES.in
70
70
@@ -9,5 +9,4 @@
71
71
 src/unified-privacy-applications.vala
72
72
 src/unified-privacy-history.vala
74
74
-src/diagnostics/com.ubuntu.whoopsiepreferences.policy.in
75
75
-[type: gettext/glade]src/diagnostics/whoopsie.ui
76
76
+[type: gettext/glade]data/whoopsie.ui
77
 
Index: activity-log-manager-0.9.7/src/Makefile.am
 
77
Index: b/src/Makefile.am
78
78
===================================================================
79
 
--- activity-log-manager-0.9.7.orig/src/Makefile.am     2014-02-03 11:29:09.025259970 +0000
80
 
+++ activity-log-manager-0.9.7/src/Makefile.am  2014-02-03 11:29:09.013259971 +0000
 
79
--- a/src/Makefile.am
 
80
+++ b/src/Makefile.am
81
81
@@ -42,6 +42,11 @@
82
82
        $(POLKIT_LIBS) \
83
83
        -lm
139
139
 
140
140
 GENERATED_C_FILES = $(SHARED_SOURCES:.vala=.c)
141
141
 GENERATED_O_FILES = $(SHARED_SOURCES:.vala=.o)
142
 
Index: activity-log-manager-0.9.7/src/diagnostics-widget.c
 
142
Index: b/src/diagnostics-widget.c
143
143
===================================================================
144
 
--- activity-log-manager-0.9.7.orig/src/diagnostics-widget.c    2014-02-03 11:29:09.025259970 +0000
145
 
+++ activity-log-manager-0.9.7/src/diagnostics-widget.c 2014-02-03 11:29:29.649259480 +0000
 
144
--- a/src/diagnostics-widget.c
 
145
+++ b/src/diagnostics-widget.c
146
146
@@ -6,7 +6,7 @@
147
147
 #define _GNU_SOURCE
148
148
 #include <stdio.h>
176
176
     g_object_set (self, "valign", GTK_ALIGN_START, NULL);
177
177
 
178
178
     priv->permission = polkit_permission_new_sync (POL_PATH, NULL, NULL, &error);
179
 
Index: activity-log-manager-0.9.7/src/diagnostics/Makefile.am
 
179
Index: b/src/diagnostics/Makefile.am
180
180
===================================================================
181
 
--- activity-log-manager-0.9.7.orig/src/diagnostics/Makefile.am 2014-02-03 11:29:09.025259970 +0000
182
 
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
181
--- a/src/diagnostics/Makefile.am
 
182
+++ /dev/null
183
183
@@ -1,50 +0,0 @@
184
184
-if HAVE_CCPANEL
185
185
-ccpaneldir = $(CCPANEL_DIR)
231
231
-CLEANFILES = whoopsie-generated.[ch] \
232
232
-       $(policykit_DATA)
233
233
-@INTLTOOL_POLICY_RULE@
234
 
Index: activity-log-manager-0.9.7/src/diagnostics/com.ubuntu.WhoopsiePreferences.conf
 
234
Index: b/src/diagnostics/com.ubuntu.WhoopsiePreferences.conf
235
235
===================================================================
236
 
--- activity-log-manager-0.9.7.orig/src/diagnostics/com.ubuntu.WhoopsiePreferences.conf 2014-02-03 11:29:09.025259970 +0000
237
 
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
236
--- a/src/diagnostics/com.ubuntu.WhoopsiePreferences.conf
 
237
+++ /dev/null
238
238
@@ -1,26 +0,0 @@
239
239
-<!DOCTYPE busconfig PUBLIC
240
240
- "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
262
262
-
263
263
-</busconfig>
264
264
-
265
 
Index: activity-log-manager-0.9.7/src/diagnostics/com.ubuntu.WhoopsiePreferences.service
 
265
Index: b/src/diagnostics/com.ubuntu.WhoopsiePreferences.service
266
266
===================================================================
267
 
--- activity-log-manager-0.9.7.orig/src/diagnostics/com.ubuntu.WhoopsiePreferences.service      2014-02-03 11:29:09.025259970 +0000
268
 
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
267
--- a/src/diagnostics/com.ubuntu.WhoopsiePreferences.service
 
268
+++ /dev/null
269
269
@@ -1,4 +0,0 @@
270
270
-[D-BUS Service]
271
271
-Name=com.ubuntu.WhoopsiePreferences
272
272
-Exec=/usr/bin/whoopsie-preferences
273
273
-User=root
274
 
Index: activity-log-manager-0.9.7/src/diagnostics/com.ubuntu.whoopsiepreferences.policy.in
 
274
Index: b/src/diagnostics/com.ubuntu.whoopsiepreferences.policy.in
275
275
===================================================================
276
 
--- activity-log-manager-0.9.7.orig/src/diagnostics/com.ubuntu.whoopsiepreferences.policy.in    2014-02-03 11:29:09.025259970 +0000
277
 
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
276
--- a/src/diagnostics/com.ubuntu.whoopsiepreferences.policy.in
 
277
+++ /dev/null
278
278
@@ -1,18 +0,0 @@
279
279
-<?xml version="1.0" encoding="UTF-8"?>
280
280
-<!DOCTYPE policyconfig PUBLIC
294
294
-    </defaults>
295
295
- </action>
296
296
-</policyconfig>
297
 
Index: activity-log-manager-0.9.7/src/diagnostics/whoopsie-preferences.c
 
297
Index: b/src/diagnostics/whoopsie-preferences.c
298
298
===================================================================
299
 
--- activity-log-manager-0.9.7.orig/src/diagnostics/whoopsie-preferences.c      2014-02-03 11:29:09.025259970 +0000
300
 
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
299
--- a/src/diagnostics/whoopsie-preferences.c
 
300
+++ /dev/null
301
301
@@ -1,363 +0,0 @@
302
302
-/* whoopsie
303
303
- * 
662
662
-        g_key_file_free (key_file);
663
663
-    return 0;
664
664
-}
665
 
Index: activity-log-manager-0.9.7/src/diagnostics/whoopsie-preferences.xml
 
665
Index: b/src/diagnostics/whoopsie-preferences.xml
666
666
===================================================================
667
 
--- activity-log-manager-0.9.7.orig/src/diagnostics/whoopsie-preferences.xml    2014-02-03 11:29:09.025259970 +0000
668
 
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
667
--- a/src/diagnostics/whoopsie-preferences.xml
 
668
+++ /dev/null
669
669
@@ -1,15 +0,0 @@
670
670
-<node>
671
671
- <interface name="com.ubuntu.WhoopsiePreferences">
682
682
-  </method>
683
683
- </interface>
684
684
-</node>
685
 
Index: activity-log-manager-0.9.7/data/whoopsie.ui
 
685
Index: b/data/whoopsie.ui
686
686
===================================================================
687
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
688
 
+++ activity-log-manager-0.9.7/data/whoopsie.ui 2014-02-03 11:29:09.017259970 +0000
 
687
--- /dev/null
 
688
+++ b/data/whoopsie.ui
689
689
@@ -0,0 +1,287 @@
690
690
+<?xml version="1.0" encoding="UTF-8"?>
691
691
+<interface>
974
974
+    </child>
975
975
+  </object>
976
976
+</interface>
977
 
Index: activity-log-manager-0.9.7/src/diagnostics/Makefile.in
 
977
Index: b/src/diagnostics/Makefile.in
978
978
===================================================================
979
 
--- activity-log-manager-0.9.7.orig/src/diagnostics/Makefile.in 2014-02-03 11:29:09.025259970 +0000
980
 
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
979
--- a/src/diagnostics/Makefile.in
 
980
+++ /dev/null
981
981
@@ -1,874 +0,0 @@
982
982
-# Makefile.in generated by automake 1.13.2 from Makefile.am.
983
983
-# @configure_input@
1853
1853
-# Tell versions [3.59,3.63) of GNU make to not export all variables.
1854
1854
-# Otherwise a system limit (for SysV at least) may be exceeded.
1855
1855
-.NOEXPORT:
1856
 
Index: activity-log-manager-0.9.7/src/diagnostics/whoopsie-generated.c
 
1856
Index: b/src/diagnostics/whoopsie-generated.c
1857
1857
===================================================================
1858
 
--- activity-log-manager-0.9.7.orig/src/diagnostics/whoopsie-generated.c        2014-02-03 11:29:09.025259970 +0000
1859
 
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
1858
--- a/src/diagnostics/whoopsie-generated.c
 
1859
+++ /dev/null
1860
1860
@@ -1,1740 +0,0 @@
1861
1861
-/*
1862
1862
- * Generated by gdbus-codegen 2.37.4. DO NOT EDIT.
3598
3598
-  return WHOOPSIE_PREFERENCES (g_object_new (TYPE_WHOOPSIE_PREFERENCES_SKELETON, NULL));
3599
3599
-}
3600
3600
-
3601
 
Index: activity-log-manager-0.9.7/src/diagnostics/whoopsie-generated.h
 
3601
Index: b/src/diagnostics/whoopsie-generated.h
3602
3602
===================================================================
3603
 
--- activity-log-manager-0.9.7.orig/src/diagnostics/whoopsie-generated.h        2014-02-03 11:29:09.025259970 +0000
3604
 
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
 
3603
--- a/src/diagnostics/whoopsie-generated.h
 
3604
+++ /dev/null
3605
3605
@@ -1,237 +0,0 @@
3606
3606
-/*
3607
3607
- * Generated by gdbus-codegen 2.37.4. DO NOT EDIT.
3840
3840
-G_END_DECLS
3841
3841
-
3842
3842
-#endif /* __WHOOPSIE_GENERATED_H__ */
3843
 
Index: activity-log-manager-0.9.7/src/diagnostics/whoopsie.ui
 
3843
Index: b/src/diagnostics/whoopsie.ui
3844
3844
===================================================================
3845
 
--- activity-log-manager-0.9.7.orig/src/diagnostics/whoopsie.ui 2014-02-03 11:29:09.025259970 +0000
3846
 
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
3847
 
@@ -1,266 +0,0 @@
 
3845
--- a/src/diagnostics/whoopsie.ui
 
3846
+++ /dev/null
 
3847
@@ -1,284 +0,0 @@
3848
3848
-<?xml version="1.0" encoding="UTF-8"?>
3849
3849
-<interface>
3850
3850
-  <!-- interface-requires gtk+ 3.0 -->
4009
4009
-                            <property name="orientation">vertical</property>
4010
4010
-                            <property name="spacing">3</property>
4011
4011
-                            <child>
 
4012
-                              <object class="GtkCheckButton" id="send_reports_automatically">
 
4013
-                                <property name="label" translatable="yes">Send a report automatically if a problem prevents login</property>
 
4014
-                                <property name="use_action_appearance">False</property>
 
4015
-                                <property name="visible">False</property>
 
4016
-                                <property name="sensitive">False</property>
 
4017
-                                <property name="can_focus">False</property>
 
4018
-                                <property name="receives_default">False</property>
 
4019
-                                <property name="use_action_appearance">False</property>
 
4020
-                                <property name="xalign">0</property>
 
4021
-                                <property name="draw_indicator">True</property>
 
4022
-                              </object>
 
4023
-                              <packing>
 
4024
-                                <property name="expand">False</property>
 
4025
-                                <property name="fill">True</property>
 
4026
-                                <property name="position">0</property>
 
4027
-                              </packing>
 
4028
-                            </child>
 
4029
-                            <child>
4012
4030
-                              <object class="GtkAlignment" id="show_previous_reports_alignment">
4013
4031
-                                <property name="visible">True</property>
4014
4032
-                                <property name="can_focus">False</property>