~ubuntu-branches/ubuntu/trusty/aide/trusty

« back to all changes in this revision

Viewing changes to debian/patches/05-configure_32-bit_lfs_fix.dpatch

  • Committer: Package Import Robot
  • Author(s): Hannes von Haugwitz
  • Date: 2012-06-20 14:46:28 UTC
  • mfrom: (5.1.13 sid)
  • Revision ID: package-import@ubuntu.com-20120620144628-robctdtcvwv5xr1u
Tags: 0.15.1-6
* lowered dependency on aide-common (closes: #545852):
  - aide, aide-xen, aide-dynamic:
    - moved aide-common from Depends to Recommends
    - added Breaks/Replaces: aide-common (<< 0.15.1-6)
  - moved aide.1 and aide.conf.5 from aide-common to binary packages
  - aide-common: replaced dependency on aide | aide-binary with
    versionised dependency on aide | aide-xen | aide-dynamic
* debian/patches/06-conf_yacc.y_conftext_declaration_fix.dpatch: new
  - fixed broken 'Error in expression' message (closes: #631398)
* 31_aide_lighttpd:
  - adjusted log file rules
* 31_aide_postgresql:
  - handle moved pgstat.stat file
* 31_aide_resolvconf:
  - extended rule for files in /@@{LIBINITRW}/resolvconf/interface/
* 31_aide_cron-apt:
  - adjusted rule for files in mailchanges/
* 31_aide_initramfs-tools: new
  - handle /@@{DEVDOT}initramfs
* 31_aide_util-linux: new
  - handle utab file and mount dir
* 31_aide_xdm: new
  - handle auth files
  - handle pid file
* 31_aide_libvirt-bin:
  - handle .monitor files
  - handle /var/lib/libvirt
  - handle /@@{RUNLOCK}/libvirt-guests
  - handle /@@{RUN}/libvirt/uml-guest
* 31_aide_laptop-mode-tools:
  - handle lock files
  - handle state-brightness-command and nolm-mountopts state file
* 31_aide_munin,31_aide_munin-nodes:
  - /var/www/munin has been moved to /var/cache/munin/www
* 70_aide_run:
  - handle /@@{RUNLOCK}/.ramfs
* removed optional aide-config-zg2 package
* debian/aide-common.prerm: removed (/usr/doc/ handling is obsolete)
* Migrated to dpkg-source 3.0 (quilt) format:
  - converted dpatch patches to quilt
  - use dh7 syntax
  - use dh-autoreconf
  - removed debian/aide_fixperms (not needed anymore)
  - removed build-dep on dpatch
  - set debian/compat to 7
  - build depend on debhelper >= 7.0.50~ and dh-autoreconf
* debian/patches/07-db_file.c_missing_format_string_fix.patch: new
  - added missing format string in dofprintf calls
* Switched to debhelper 9
  - set debian/compat to 9
  - build depend on debhelper >= 9
* aide.conf.in:
  - added X group and use it instead of 'acl+xattrs+e2fsattrs_SELINUX_'
  - fixed typo in comment
  - removed I from HiSerMemberLog
* Moved aide.conf.in back to aide.conf and adjusted debian/rules
* debian/control:
  - removed build-dep on libgcrypt11-dev (not needed anymore)
  - adjusted URLs of Vcs-* fields
  - removed pointer to configuration from description of binary packages
  - bumped to Standards-Version 3.9.3 (no changes necessary)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 05-configure_32-bit_lfs_fix.dpatch
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Description: Fix large file support on 32-bit systems
6
 
## DP: Forwarded: not-needed
7
 
## DP: Author: Hannes von Haugwitz <hannes@vonhaugwitz.com>
8
 
## DP: Applied-Upstream: 0.16a1, http://aide.git.sourceforge.net/git/gitweb.cgi?p=aide/aide;a=commit;h=92c7878
9
 
## DP: Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=615111
10
 
## DP: Last-Update: 2011-03-11
11
 
 
12
 
@DPATCH@
13
 
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' aide~/configure aide/configure
14
 
--- aide~/configure     2011-03-11 06:23:39.000000000 +0000
15
 
+++ aide/configure      2011-03-11 06:29:11.000000000 +0000
16
 
@@ -6435,7 +6435,7 @@
17
 
 if test "x$ac_cv_func_lstat64" = x""yes; then :
18
 
   ac_fn_c_check_func "$LINENO" "stat64" "ac_cv_func_stat64"
19
 
 if test "x$ac_cv_func_stat64" = x""yes; then :
20
 
-  AIDE_DEFS="$AIDE_DEFS -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS"
21
 
+  AIDE_DEFS="$AIDE_DEFS -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
22
 
        AIDE_LSTAT_FUNC="lstat64"
23
 
        compoptionstring="${compoptionstring}WITH_LSTAT64\\n"
24
 
        AIDE_STAT_FUNC="stat64"