~ubuntu-branches/ubuntu/trusty/alsa-plugins/trusty

« back to all changes in this revision

Viewing changes to debian/patches/use_libavutil.patch

  • Committer: Package Import Robot
  • Author(s): Luke Yelavich
  • Date: 2013-07-26 10:57:49 UTC
  • mfrom: (3.1.16 sid)
  • Revision ID: package-import@ubuntu.com-20130726105749-ymn7cpbi75gmgplw
Tags: 1.0.27-2ubuntu1
* Merge from debian unstable, remaining changes:
  - Create libasound2-plugins-extra package which contains plugins that use
    libav.

Show diffs side-by-side

added added

removed removed

Lines of Context:
7
7
 The patch needs to be extended to do proper checks for avutil header files.
8
8
Forwarded: no
9
9
 
10
 
Index: alsa-plugins-1.0.25/configure.in
 
10
Index: alsa-plugins-1.0.27/configure.in
11
11
===================================================================
12
 
--- alsa-plugins-1.0.25.orig/configure.in       2012-01-25 08:57:07.000000000 +0100
13
 
+++ alsa-plugins-1.0.25/configure.in    2012-02-11 22:22:41.439521425 +0100
 
12
--- alsa-plugins-1.0.27.orig/configure.in       2013-04-26 23:02:22.144794780 +0200
 
13
+++ alsa-plugins-1.0.27/configure.in    2013-04-26 23:02:22.140794782 +0200
14
14
@@ -67,7 +67,7 @@
15
15
       AS_HELP_STRING([--disable-avcodec], [Don't build plugins depending on avcodec (a52)]))
16
16
 
20
20
 fi
21
21
 
22
22
 if test "x$HAVE_AVCODEC" = "xno"; then
23
 
Index: alsa-plugins-1.0.25/a52/pcm_a52.c
 
23
Index: alsa-plugins-1.0.27/a52/pcm_a52.c
24
24
===================================================================
25
 
--- alsa-plugins-1.0.25.orig/a52/pcm_a52.c      2012-01-25 08:57:07.000000000 +0100
26
 
+++ alsa-plugins-1.0.25/a52/pcm_a52.c   2012-02-11 22:28:58.219502171 +0100
 
25
--- alsa-plugins-1.0.27.orig/a52/pcm_a52.c      2013-04-26 23:02:22.144794780 +0200
 
26
+++ alsa-plugins-1.0.27/a52/pcm_a52.c   2013-04-26 23:02:22.140794782 +0200
27
27
@@ -26,6 +26,7 @@
28
28
 #include <alsa/pcm_external.h>
29
29
 #include <alsa/pcm_plugin.h>
30
30
 #include AVCODEC_HEADER
31
31
+#include <libavutil/avutil.h>
32
32
 
33
 
 struct a52_ctx {
34
 
        snd_pcm_ioplug_t io;
 
33
 #if LIBAVCODEC_VERSION_MAJOR >= 53 && LIBAVCODEC_VERSION_MINOR >= 34
 
34
 #include <libavutil/audioconvert.h>