~ubuntu-branches/ubuntu/trusty/amsn/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/04_use_xdg-open.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Cody A.W. Somerville
  • Date: 2008-03-29 23:16:00 UTC
  • Revision ID: james.westby@ubuntu.com-20080329231600-knu01lft7cs0cgve
Tags: 0.97+final-0ubuntu4
* Renamed 04_sensible_browserKey.dpatch to 04_use_xdg-open.dpatch
* debian/patches/04_use_xdg-open.dpatch: Updated.
  - Use xdg-open for file manager, and opening files - not just browser.
  - Closes LP: #206639
  - Closes LP: #208816
* debian/patches/05-disable_newVersionCheck.dpatch: Created.
  - Path to disable checking of new versions on start by default.
  - Closes LP: #188675
* debian/patches/06-fix_makefile.dpatch: Created.
  - Ensure proper cleanup and installation of files.
* debian/rules:
  - clean: Calls to rm removed and makefile patched instead.
  - install: Use dh_installdocs to install docs instead of manually copying.
  - Removed spurious comments and old, commented out commands.
  - General cleanup.
* debian/amsn.desktop:
  - Deleted, we no longer use it.
  - Closes LP: #184353
* debian/amsn.docs: Created.
* debian/patches/00list: Regenerated. Closes LP: #208816

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 04_use_xdg-open.dpatch by Tomas Gustavsson.
 
3
##
 
4
## DP: Use xdg-open to open all urls.
 
5
 
 
6
@DPATCH@
 
7
diff -urNad amsn-0.97+final~/config.tcl amsn-0.97+final/config.tcl
 
8
--- amsn-0.97+final~/config.tcl 2007-11-04 11:17:19.000000000 -0400
 
9
+++ amsn-0.97+final/config.tcl  2008-03-29 23:09:19.000000000 -0300
 
10
@@ -82,11 +82,11 @@
 
11
                        ::config::setKey usesnack 0
 
12
                } elseif { [OnUnix] } {
 
13
                        ::config::setKey soundcommand "play \$sound"
 
14
-                       ::config::setKey browser "mozilla \$url"
 
15
+                       ::config::setKey browser "xdg-open \$url"
 
16
                        ::config::setKey notifyXoffset 0
 
17
                        ::config::setKey notifyYoffset 0
 
18
-                       ::config::setKey filemanager "my_filemanager open \$location"
 
19
-                       ::config::setKey openfilecommand ""
 
20
+                       ::config::setKey filemanager "xdg-open \$location"
 
21
+                       ::config::setKey openfilecommand "xdg-open \$file"
 
22
                        ::config::setKey usesnack 0
 
23
                } elseif { [OnWin] } {
 
24
                        ::config::setKey soundcommand "utils/windows/plwav.exe \$sound"