~ubuntu-branches/ubuntu/trusty/apache2/trusty

« back to all changes in this revision

Viewing changes to debian/patches/210-backport-mod-reqtimeout-ftbfs.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Chuck Short
  • Date: 2010-05-05 01:28:04 UTC
  • mfrom: (14.3.15 sid)
  • Revision ID: james.westby@ubuntu.com-20100505012804-vbouq0xs3tu2vvij
Tags: 2.2.15-5ubuntu1
* Merge from debian unstable.  Remaining changes:
  - debian/{control, rules}: Enable PIE hardening.
  - debian/{control, rules, apache2.2-common.ufw.profile}: Add ufw profiles.
  - debian/control: Add bzr tag and point it to our tree.
  - debian/apache2-2.common.apache2.init: Add graceful restart (LP: #456381)
  + Dropped:
    - debian/patches/206-fix-potential-memory-leaks.dpatch: No longer needed.
    - debian/patches/206-report-max-client-mpm-worker.dpatch: No longer needed.
    - debian/config-dir/apache2.conf: Merged back from debian.
    - mod-reqtimeout functionality: Merge back from debian.
    - debian/patches/204_CVE-2010-0408.dpatch: No longer needed.
    - debian/patches/205_CVE-2010-0434.dpatch: No longer needed.
    - debian/patches/203_fix-ab-segfault.dpatch: No longer needed.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
 
3
 
@DPATCH@
4
 
--- apache2-2.2.14.orig/configure       2010-04-13 14:38:14.396175449 -0400
5
 
+++ apache2-2.2.14/configure    2010-04-13 14:52:26.000000000 -0400
6
 
@@ -729,6 +729,7 @@
7
 
 MOD_FILTER_LDADD
8
 
 MOD_INCLUDE_LDADD
9
 
 MOD_EXT_FILTER_LDADD
10
 
+MOD_REQTIMEOUT_LDADD
11
 
 MOD_CASE_FILTER_IN_LDADD
12
 
 MOD_CASE_FILTER_LDADD
13
 
 MOD_EXAMPLE_LDADD
14
 
@@ -912,6 +913,7 @@
15
 
 enable_example
16
 
 enable_case_filter
17
 
 enable_case_filter_in
18
 
+enable_reqtimeout
19
 
 enable_ext_filter
20
 
 enable_include
21
 
 enable_filter
22
 
@@ -1655,6 +1657,7 @@
23
 
   --enable-example        example and demo module
24
 
   --enable-case-filter    example uppercase conversion filter
25
 
   --enable-case-filter-in example uppercase conversion input filter
26
 
+  --enable-reqtimeout     Limit time waiting for request from client
27
 
   --enable-ext-filter     external filter module
28
 
   --disable-include       Server Side Includes
29
 
   --disable-filter        Smart Filtering
30
 
@@ -10084,6 +10083,99 @@
31
 
 
32
 
 
33
 
 
34
 
+  { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to enable mod_reqtimeout" >&5
35
 
+$as_echo_n "checking whether to enable mod_reqtimeout... " >&6; }
36
 
+    # Check whether --enable-reqtimeout was given.
37
 
+if test "${enable_reqtimeout+set}" = set; then :
38
 
+  enableval=$enable_reqtimeout;
39
 
+else
40
 
+  enable_reqtimeout=most
41
 
+fi
42
 
+
43
 
+    _apmod_extra_msg=""
44
 
+      if test "$module_selection" = "most" -a "$enable_reqtimeout" = "most"; then
45
 
+    _apmod_error_fatal="no"
46
 
+  else
47
 
+    _apmod_error_fatal="yes"
48
 
+  fi
49
 
+  if test "$enable_reqtimeout" = "static"; then
50
 
+    enable_reqtimeout=yes
51
 
+  elif test "$enable_reqtimeout" = "yes"; then
52
 
+    enable_reqtimeout=$module_default
53
 
+    _apmod_extra_msg=" ($module_selection)"
54
 
+  elif test "$enable_reqtimeout" = "most"; then
55
 
+    if test "$module_selection" = "most" -o "$module_selection" = "all"; then
56
 
+      enable_reqtimeout=$module_default
57
 
+      _apmod_extra_msg=" ($module_selection)"
58
 
+    elif test "$enable_reqtimeout" != "yes"; then
59
 
+      enable_reqtimeout=no
60
 
+    fi
61
 
+  elif test "$enable_reqtimeout" = "maybe-all"; then
62
 
+    if test "$module_selection" = "all"; then
63
 
+      enable_reqtimeout=$module_default
64
 
+      _apmod_extra_msg=" (all)"
65
 
+    else
66
 
+      enable_reqtimeout=no
67
 
+    fi
68
 
+  fi
69
 
+  if test "$enable_reqtimeout" != "no"; then
70
 
+            :
71
 
+  fi
72
 
+  { $as_echo "$as_me:${as_lineno-$LINENO}: result: $enable_reqtimeout$_apmod_extra_msg" >&5
73
 
+$as_echo "$enable_reqtimeout$_apmod_extra_msg" >&6; }
74
 
+  if test "$enable_reqtimeout" != "no"; then
75
 
+    case "$enable_reqtimeout" in
76
 
+    shared*)
77
 
+      enable_reqtimeout=`echo $enable_reqtimeout|sed 's/shared,*//'`
78
 
+      sharedobjs=yes
79
 
+      shared=yes
80
 
+      DSO_MODULES="$DSO_MODULES reqtimeout"
81
 
+      ;;
82
 
+    *)
83
 
+      MODLIST="$MODLIST reqtimeout"
84
 
+      if test "reqtimeout" = "so"; then
85
 
+          sharedobjs=yes
86
 
+      fi
87
 
+      shared="";;
88
 
+    esac
89
 
+
90
 
+
91
 
+  if test -z ""; then
92
 
+    objects="mod_reqtimeout.lo"
93
 
+  else
94
 
+    objects=""
95
 
+  fi
96
 
+
97
 
+  if test -z "$module_standalone"; then
98
 
+    if test -z "$shared"; then
99
 
+      # The filename of a convenience library must have a "lib" prefix:
100
 
+      libname="libmod_reqtimeout.la"
101
 
+      BUILTIN_LIBS="$BUILTIN_LIBS $modpath_current/$libname"
102
 
+      modpath_static="$modpath_static $libname"
103
 
+      cat >>$modpath_current/modules.mk<<EOF
104
 
+$libname: $objects
105
 
+       \$(MOD_LINK) $objects \$(MOD_REQTIMEOUT_LDADD)
106
 
+EOF
107
 
+    else
108
 
+      apache_need_shared=yes
109
 
+      libname="mod_reqtimeout.la"
110
 
+      shobjects=`echo $objects | sed 's/\.lo/.slo/g'`
111
 
+      modpath_shared="$modpath_shared $libname"
112
 
+      cat >>$modpath_current/modules.mk<<EOF
113
 
+$libname: $shobjects
114
 
+       \$(SH_LINK) -rpath \$(libexecdir) -module -avoid-version  $objects \$(MOD_REQTIMEOUT_LDADD)
115
 
+EOF
116
 
+    fi
117
 
+  fi
118
 
+
119
 
+
120
 
+  APACHE_VAR_SUBST="$APACHE_VAR_SUBST MOD_REQTIMEOUT_LDADD"
121
 
+
122
 
+
123
 
+
124
 
+  fi
125
 
+
126
 
+
127
 
   { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to enable mod_ext_filter" >&5
128
 
 $as_echo_n "checking whether to enable mod_ext_filter... " >&6; }
129
 
     # Check whether --enable-ext-filter was given.