~ubuntu-branches/ubuntu/trusty/armel-cross-toolchain-base/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/eglibc/ubuntu/dpkg-shlibs.patch

  • Committer: Package Import Robot
  • Author(s): Marcin Juszkiewicz
  • Date: 2011-12-12 21:34:01 UTC
  • Revision ID: package-import@ubuntu.com-20111212213401-yf9sg6hm4m5gywbe
Tags: 1.76
* Bumped gcc-4.6 dependency to 4.6.2-6 as it got lot of my changes merged:
  - make cross compilers depend on gcc-cross-base package - closes LP: #862436
  - enable hardening patches for cross builds - closes LP: #868924
  - do not remove gcc cross in 'install-driver' step - closes LP: #877333
  - fix usr_lib for hf/sf build - closes LP: #887111
* Added new patches for eglibc:
  - disable fortify for cross builds
  - set LD_LIBRARY_PATH for dh_shlibdeps (local, not mergeable)
* Dropped build time dependencies on gcc/g++ 4.5.
* Added "init" task for testing patches.
* Disabled "|true" in quilt so it is easier to catch broken patches.
* Disabled patching linux-source as there are no patches for it.
* Dropped binutils patches as they got merged.
* Added /usr/arm-linux-gnueabihf/lib/sf symlink to libc6-dev-armel-cross.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
---
 
2
 rules.d/debhelper.mk |    2 +-
 
3
 1 file changed, 1 insertion(+), 1 deletion(-)
 
4
 
 
5
--- a/debian/rules.d/debhelper.mk
 
6
+++ b/debian/rules.d/debhelper.mk
 
7
@@ -118,11 +118,11 @@ endif
 
8
                install -m 644 -o root -g root debian/$(curpass).triggers \
 
9
                        debian/$(curpass)/DEBIAN/triggers ; \
 
10
        fi
 
11
 
 
12
        dh_installdeb -p$(curpass)
 
13
-       dh_shlibdeps -p$(curpass)
 
14
+       LD_LIBRARY_PATH=$(CURDIR)/../debian/tmp/usr/lib/ dh_shlibdeps -p$(curpass)
 
15
        dh_gencontrol -p$(curpass)
 
16
 
 
17
        if [ $(curpass) = nscd ] ; then \
 
18
                sed -i -e "s/\(Depends:.*libc[0-9.]\+\)-[a-z0-9]\+/\1/" debian/nscd/DEBIAN/control ; \
 
19
        fi