~ubuntu-branches/ubuntu/trusty/binutils-2.26/trusty-security

« back to all changes in this revision

Viewing changes to debian/patches/158_ld_system_root.patch

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2017-02-24 13:04:41 UTC
  • Revision ID: package-import@ubuntu.com-20170224130441-8pxcdc3y92eb2fj2
Tags: 2.26.1-1ubuntu1~14.04
* SRU. LP: #1667662. Backport to trusty, required for LLVM 3.9 backport.
* Disable building multiarch and cross packages.
* Make binutils-2.26 co-installable with binutils.
* Provide unversioned binaries in /usr/lib/binutils-2.26/bin.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: b/ld/configure.ac
 
2
===================================================================
 
3
--- a/ld/configure.ac
 
4
+++ b/ld/configure.ac
 
5
@@ -56,7 +56,9 @@
 
6
  *) TARGET_SYSTEM_ROOT=$with_sysroot ;;
 
7
  esac
 
8
 
 
9
+ if test "x$TARGET_SYSTEM_ROOT" != x/; then
 
10
  TARGET_SYSTEM_ROOT_DEFINE='-DTARGET_SYSTEM_ROOT=\"$(TARGET_SYSTEM_ROOT)\"'
 
11
+ fi
 
12
  use_sysroot=yes
 
13
 
 
14
  if test "x$prefix" = xNONE; then
 
15
Index: b/ld/configure
 
16
===================================================================
 
17
--- a/ld/configure
 
18
+++ b/ld/configure
 
19
@@ -4283,7 +4283,9 @@
 
20
  *) TARGET_SYSTEM_ROOT=$with_sysroot ;;
 
21
  esac
 
22
 
 
23
+ if test "x$TARGET_SYSTEM_ROOT" != x/; then
 
24
  TARGET_SYSTEM_ROOT_DEFINE='-DTARGET_SYSTEM_ROOT=\"$(TARGET_SYSTEM_ROOT)\"'
 
25
+ fi
 
26
  use_sysroot=yes
 
27
 
 
28
  if test "x$prefix" = xNONE; then
 
29
Index: b/ld/ldmain.c
 
30
===================================================================
 
31
--- a/ld/ldmain.c
 
32
+++ b/ld/ldmain.c
 
33
@@ -226,8 +226,8 @@
 
34
     {
 
35
       if (*TARGET_SYSTEM_ROOT == 0)
 
36
        {
 
37
-         einfo ("%P%F: this linker was not configured to use sysroots\n");
 
38
          ld_sysroot = "";
 
39
+         ld_canon_sysroot = "";
 
40
        }
 
41
       else
 
42
        ld_canon_sysroot = lrealpath (ld_sysroot);