~ubuntu-branches/ubuntu/trusty/boxshade/trusty

« back to all changes in this revision

Viewing changes to debian/patches/10_makefile.unx.patch

  • Committer: Bazaar Package Importer
  • Author(s): Andreas Tille, David Paleino, Nelson A. de Oliveira, Andreas Tille
  • Date: 2008-02-26 07:28:42 UTC
  • mfrom: (2.1.2 hardy)
  • Revision ID: james.westby@ubuntu.com-20080226072842-9wnuuhgicnn9r92i
Tags: 3.3.1-3
[ David Paleino ]
* debian/boxshade.1 has been statically generated: this saves some
  time (and space) on buildds (leaving the XML version for future
  editing)
* debian/control:
  - B-D updated (manpage is not generated on buildds anymore)
  - added myself to Uploaders
  - XS-Vcs-* moved to Vcs-* and fixed
  - Homepage field now replaces the old pseudo-field in the long
    description
  - removed XS- from DM-Upload-Allowed
* debian/rules:
  - reflecting static generation of boxshade.1 -- removing boxshade.1
    target
  - some general cleanup
* debian/README.Debian updated: the new debian-med.alioth.d.o website
  is now mentioned.

[ Nelson A. de Oliveira ]
* Added watch file.

[ Andreas Tille ]
* Added myself to uploaders
* Added path to dh_installman
* Moved additional shellscript wrapper boxshade.sh to debian dir
* Added debian/get-orig-source script and added get-orig-source
  target to debian/rules

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: trunk/makefile.unx
 
2
===================================================================
 
3
--- trunk.orig/makefile.unx
 
4
+++ trunk/makefile.unx
 
5
@@ -1,7 +1,7 @@
 
6
 # BOXSHADE makefile for unix (tested under Linux && Solaris)
 
7
 CC     = gcc
 
8
 CFLAGS = -O
 
9
-LDFLAGS= -s
 
10
+# dh_strip takes care of this... LDFLAGS= -s
 
11
 LIBS   = -lm
 
12
 OBJ    =.o
 
13
 EXE    =
 
14
@@ -40,3 +40,8 @@
 
15
 dv_ps$(OBJ):    dv_ps.c    bx_types.h bx_read.h dv_all.h version.h
 
16
 dv_regis$(OBJ): dv_regis.c bx_types.h bx_read.h dv_all.h
 
17
 dv_rtf$(OBJ):   dv_rtf.c   bx_types.h bx_read.h dv_all.h
 
18
+
 
19
+.PHONY: clean
 
20
+
 
21
+clean:
 
22
+       rm -f $(OBJS) boxshade$(EXE)