~ubuntu-branches/ubuntu/trusty/calendarserver/trusty

« back to all changes in this revision

Viewing changes to debian/patches/paths.diff

  • Committer: Bazaar Package Importer
  • Author(s): Guido Guenther, Guido Guenther, Noel Köthe
  • Date: 2008-06-19 17:05:15 UTC
  • Revision ID: james.westby@ubuntu.com-20080619170515-9r6bowaeae6evaly
Tags: 1.2.dfsg-3
[ Guido Guenther ]
* upload to unstable - we no longer conflict on twisted
* [31d2b55] drop dependency on ctypes - it's already included in python2.5
* [652da62] Mention XFS (Closes: #483987) - thanks to Peter Mann
* [29edb85] add Homepage:
* [0c5bcee] redirect stderr to /dev/null on daemon restart This is a
  temporary workaround until the twisted deprecation warnings got
  fixed.

[ Noel Köthe ]
* [1c03474] xs- prefix from Vcs fields

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: calendarserver/bin/caladmin
2
 
===================================================================
3
 
--- calendarserver.orig/bin/caladmin    2007-08-03 17:51:47.000000000 +0200
4
 
+++ calendarserver/bin/caladmin 2008-02-21 18:55:23.000000000 +0100
5
 
@@ -19,7 +19,7 @@
6
 
 
7
 
 import sys, os
8
 
 
9
 
-#PYTHONPATH
10
 
+PYTHONPATH="/usr/lib/caldavd/lib/python2.5/site-packages/"
11
 
 
12
 
 if __name__ == '__main__':
13
 
    if 'PYTHONPATH' in globals():
14
 
Index: calendarserver/bin/caldavd
15
 
===================================================================
16
 
--- calendarserver.orig/bin/caldavd     2007-08-03 17:51:47.000000000 +0200
17
 
+++ calendarserver/bin/caldavd  2008-02-21 18:55:23.000000000 +0100
18
 
@@ -19,13 +19,13 @@
19
 
 ##
20
 
 
21
 
 #PATH
22
 
-#PYTHONPATH
23
 
+PYTHONPATH="/usr/lib/caldavd/lib/python2.5/site-packages"
24
 
 
25
 
 daemonize="";
26
 
 username="";
27
 
 groupname="";
28
 
 configfile="";
29
 
-twistdpath="$(type -p twistd)";
30
 
+twistdpath="/usr/lib/caldavd/bin/twistd";
31
 
 plugin_name="caldav";
32
 
 service_type="";
33
 
 profile="";
34
1
Index: calendarserver/conf/caldavd.plist
35
2
===================================================================
36
 
--- calendarserver.orig/conf/caldavd.plist      2008-02-21 17:54:53.000000000 +0100
37
 
+++ calendarserver/conf/caldavd.plist   2008-02-21 19:03:53.000000000 +0100
 
3
--- calendarserver.orig/conf/caldavd.plist      2008-04-30 16:33:13.000000000 +0200
 
4
+++ calendarserver/conf/caldavd.plist   2008-04-30 16:42:47.000000000 +0200
 
5
@@ -54,7 +54,7 @@
 
6
 
 
7
   <!-- List of IP addresses to bind to [empty = all] -->
 
8
   <key>BindAddresses</key>
 
9
-  <array></array>
 
10
+  <array><string>localhost</string></array>
 
11
 
 
12
   <!-- List of port numbers to bind to for HTTP [empty = same as "Port"] -->
 
13
   <key>BindHTTPPorts</key>
38
14
@@ -75,7 +75,7 @@
39
15
 
40
16
   <!-- Document root -->
121
97
   </dict>
122
98
 
123
99
 
124
 
@@ -264,6 +263,29 @@
 
100
@@ -264,14 +263,27 @@
125
101
   <key>EnableNotifications</key>
126
102
   <true/>
127
103
 
128
 
+  <!--
129
 
+    Twisted
130
 
+  -->
131
 
+
 
104
-
 
105
   <!--
 
106
     Miscellaneous items
 
107
   -->
 
108
 
132
109
+  <key>Twisted</key>
133
110
+  <dict>
134
111
+      <key>twistd</key>
135
 
+      <string>/usr/lib/caldavd/bin/twistd</string>
 
112
+      <string>/usr/bin/twistd</string>
136
113
+  </dict>
137
114
+
138
 
+  <!--
139
 
+    Sockets
140
 
+  -->
141
115
+  <key>PythonDirector</key>
142
116
+  <dict>
143
117
+      <key>pydir</key>
146
120
+      <string>/var/run/caldavd/caldavd-pydir.sock</string>
147
121
+  </dict>
148
122
+
149
 
+  <key>ControlSocket</key>
 
123
   <!-- A unix socket used for communication between the child and master processes. -->
 
124
   <key>ControlSocket</key>
 
125
-  <string>/var/run/caldavd.sock</string>
150
126
+  <string>/var/run/caldavd/caldavd.socket</string>
151
127
 
152
 
   <!--
153
 
     Miscellaneous items
 
128
   <!-- Support for Content-Encoding compression options as specified in RFC2616 Section 3.5 -->
 
129
   <key>ResponseCompression</key>
154
130
Index: calendarserver/setup.py
155
131
===================================================================
156
 
--- calendarserver.orig/setup.py        2008-02-21 17:54:53.000000000 +0100
157
 
+++ calendarserver/setup.py     2008-02-21 19:09:55.000000000 +0100
 
132
--- calendarserver.orig/setup.py        2008-04-30 16:33:13.000000000 +0200
 
133
+++ calendarserver/setup.py     2008-04-30 16:40:20.000000000 +0200
158
134
@@ -140,7 +140,7 @@
159
135
                          "twistedcaldav": ["zoneinfo/*.ics", "zoneinfo/*/*.ics", "zoneinfo/*/*/*.ics"],
160
136
                        },